OpenOffice Crashes on Start in 11.3

Recently OpenOffice has started crashing on me when loading the program. The splash screen will appear for a moment then the KDE crash handler comes up. Here’s what I get when launching from the console:

slomojo@linux-yiyy:~$ ooffice
KCrash: Application ‘soffice.bin’ crashing…

I’ve tried deleting the .ooo3 directory in my home directory but that doesn’t seem to help. Also, I’m running with Sun’s JDK in case that makes any difference.

I know that OpenOffice was working fine for me immediately after my fresh install of 11.3. I only use OpenOffice once every couple of weeks so I’m not sure if there was a specific update or anything that broke things for me.

Any ideas?


Same here. I tried running in konsole:

tim@linux-mouv:~> ooffice
/usr/lib64/ooo3/program/soffice: line 96: 27750 Bus error “$sd_prog/…/basis-link/program/pagein” -L"$sd_prog/…/basis-link/program" ${sd_pagein_args}

Can’t find anything on google. It was working in the clean install. Something went wrong I guess, my system is fully up-to date.

Tried re-installing the open office packages, but It’s still the same.



I have run into the same problem as Slomojo.

KCrash: Application 'soffice.bin' crashing...

Can’t say much more since it is a fresh install of OpenSUSE 11.3.

Did you find any fix?

the fork libreoffice works on my gnome 11.3 64 bit set up
i do not have the suse goOffice or the oo office from the oo site installed so…

Could you please explain what you mean by this? What is libreoffice? What is goOffice?

LibreOffice is the fork of, after’s owner Sun was sold to Oracle: Welcome to The Document Foundation! - The Document Foundation
There also are some different ‘streams’ in, AFAICS JohnVV is referring to those.

Thanks a lot for the hint. For some reason I was thiking that it is some LIBrary that I additionally need and that ‘fork’ refers to process management rather than project management. I really couldn’t make neither fish nor fowl out of it. I also ought to keep myself more informed as to the open software developments or just place the right terms in google…

Anyway, I installed libreoffice and it seems to work so I will give it a go. Many thanks for the suggestion. Although I am still a bit annoyed that OO crashes.

Oracle is turning OO into a “free” limited and not free full Office application

Go office was a split that took place a bit back .For adding new features into OO sun then started adding some of go-Office “new things” back in This basicaly was a mess – but a WORKING mess , and most were happy .
Enter Oracle who wanted all the sun dev team to leave the open doc foundation .A mass quitting took place and libre office was formed .

– a bit very simple and short description , this whole thing is a “soap opera” –

the whole thing would take a small book for the details

but just a guess i think that the errors people are getting with the OO in the repo is a kde bug … all the errors posted here are running on KDE ( i am using Gnome )