openoffice crashes at start

Afret update to 11.2 Openoffice crashes at start “Due to an unexpected error”, but it can run if i start it as root or some new user. I have deleted .ooo3 folder in my home, but it didn’t work. How can it be solved:)?

Sounds like a KDE (or Gnome) configuration problem.From what version and how did you upgrade?

From 11.1 to 11.2. I have disabled old repos, added 11.2 repos and did zypper in zypper , * zypper dup -d

  • and then* zypper dup.

now i have got
System: openSUSE 11.2 (x86_64)
KDE: 4.3.1 (KDE 4.3.1) “release 6”

Updated 3 computers from version 11.1 to 11.2 by booting from DVD, in all 3 have the same problem. OpenOffice start only from root account.

I ran OpenOffice is not in KDE (I use 4.3.3) and it started with no problems on my account.

There are some problems running OpenOffice 3.1.1 on 11.2 and KDE 4.3, which are KDE-related (or perhaps QT-related)

Have a look at this thread:

OpenOffice and Opensuse 11.2 - openSUSE Forums

In short, removal of KDE-integration may solve the problem.

remove /usr/lib/ooo3/basis3.1/program/ and problem solved.