OpenOffice crashes when displaying >1 document

Crash scenario
OpenOffice w/ SuSE 11.1
.ods file opens ok
.odt file crashes both, requests recovery.
Recovery crashes.

Will try to re-install OpenOffice directly from Sun.

Correction OpenOffice

Are you certain the .odt file is not corrupt, or are you doing new (blank) files? What about when you try the other way around?

It just now crashed by opening a different .ods file first, opening a different .ost file, then closing the .ost file.

I think this may be an OpenOffice has with KDE4. When any OpenOffice documents are open, the plasma navigator screen on the bottom doesn’t show all the open applications. Some of the application title blocks are black areas on the screen.

I’m not sure what the problem specially is. I tried several smaller file combinations without OpenOffice crashing. However, the plasma problem exists with even small files.

I tried it with some large files archived from a year ago, and I have the same crashing problem. I doubt that I’m dealing with corrupt file. I’ve got 2G of RAM and adequate HD. This is puzzling.

Of note, everything appears to work just fine on SuSE 11.1RC1. Given that the big difference between these is the desktop, I’m thinking the problem lies with KDE4.

Do you have any desktop effects you can turn off (sorry, not overly familiar with KDE and KDE specifically)?

I tried turning off KDE4 desktop affects, and that didn’t change anything. Portions of the task manager disappear when a cursor passes over it, then reappear when the cursor passes over a second time.

My system dual boots into Windows. The OpenOffice files performed as expected, so the files are not the issue.

As soon as one opens a second text file, or a text and spread sheet, OpenOffice crashes. It tries to do a recovery, then this task crashes. When attempting to open a new file, OpenOffice is stuck in a cycle of attempting to recovery from the prior crash.