OpenLDAP/Samba working, a few users can't login

First off, I’m not sure wether this is the right place to ask, but I’ve found no better. If you can suggest me another place, please do :slight_smile:

Got latest OpenSUSE running, with OpenLDAP and Samba set up since 6 months. Except for a few problems every now and then, everything works fine. Clients use Win2k/XP/Vista/7 to login into the domain.
Coming back from summer break, a user stopped working, as in: it can’t login. Windows error says “…user not in the domain”. Other users are fine.
I’ve checked through YaST and the user is fine, badpasswordcount=0 and it’s not disabled. Changed password to a new one and it didn’t help.

Tried creating new account, (which has to be done through a windows machine using LDAPBrowser, through YaST there’s problems with Samba), and even this user cannot login.

What could be wrong?

On 09/05/2011 12:46 AM, NaeRey wrote:
> First off, I’m not sure wether this is the right place to ask

seems to be a networking problem to me, but you are here now…

> What could be wrong?

i don’t think i can actually help you, but i’m not sure anyone can until
we have discovered a little more info…not sure, but the way you post
reads, you are the administrator of a linux server with multiple users
accessing it over a network using OpenLDAP/Samba via their wintel

if so lets first learn the exact operating system of your server by you
returning the output of this command run in a user terminal on the server:

cat /etc/SuSE-release

openSUSE®, the “German Automobiles” of operating systems

Yes all correct. The computer has internet access and logs in fine with local sys admin too. Used to be able to login with domain administrator, but now even that one fails . …
On other machines that user fails, as well as the newly created one.

openSUSE 11.4 (x86_64)
VERSION = 11.4
CODENAME = Celadon

Ops, Administrator account got locked after 5 bad password… unlocked and works ok now. However the new user nor the old one still can’t access. Could it be something along the lines of a password database not in sync or similar?
I’m using commandline YaST to do all the work.
Found this link Samba, LDAP and YaST
saying I need to enable Sambaplugin through YaST, but first I’ve to edit /etc/YaST2/ProductFeatures … which is a file that I don’t have.

Since I’ve rsync backups of /etc/ and /var/lib/ldap/ , and since a month ago everything worked fine, can’t I just restore the LDAP files? Which are they?

OK, so there are two problems here.

  1. Winbox takes time to fetch domain info… no idea how to fix or anything, but waiting 5min after starting up helps. Not a big problem, can be ignored.

  2. ldap and samba are not in sync. Changing password with LDAP gets me nowhwere, whereas sambapasswd does the trick.
    pdbedit also shows all the updated info (e.g. SambaBadPasswordCount when I purposely enter it wrongly a few times), whereas LDAP shows outdated info.
    Question is, why does it not sync? And, how do I get it to sync once again?

Sorry for me spamming the forums!

On 09/06/2011 01:16 PM, NaeRey wrote:
> Sorry for me spamming the forums!

actually, i’m sorry that the “right person” didn’t see this thread…i
think more of the right folks would have seen it in networking…but,
could be wrong about that…maybe there are more in install-boot-LOGIN…

see if you can find something here: one of the mods (swerdna) seems to
me to be a Samba guru (among other specialities)…he has lots of info
here: so, i would suggest you look at that,
and if you can’t sort it out easily without him then maybe private mail
and ask him to look in on your thread, at

(i’d try to help but all i know about Samba is that it has something to
do with networking Linux to MS-Windows machines, i think…)

openSUSE®, the “German Automobiles” of operating systems

Mailed swerdna a week ago, got no reply :frowning:

No updates on the problem eiher…

And it may be a few more, he is away at the moment.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.4 (x86_64) Kernel
up 4 days 21:23, 4 users, load average: 0.64, 0.32, 0.25
GPU GeForce 8600 GTS Silent - Driver Version: 280.13