OpenLdap + Postfix

Hello list… look to me another … after resolve problem witch ldap and squid … i have a new problem… now with
POSTFIX

Scenaries:

server 01: openLdap + SambaPDC
server 02: postfix + squi

I trying make integration between systems OPEN LDAP and POSTFIX but all time that configure the server 02 to authentication in server 01 receving bellow error:

Aug 29 08:30:19 gheorghe slapd[7485]: => bdb_search
Aug 29 08:30:19 gheorghe slapd[7485]: bdb_dn2entry(“ou=dns,dc=meudominio,dc=com,dc=br”)
Aug 29 08:30:19 gheorghe slapd[7485]: => send_search_entry: conn 31 dn=“ou=DNS,dc=meudominio,dc=com,dc=br”
Aug 29 08:30:19 gheorghe slapd[7485]: <= send_search_entry: conn 31 exit.
Aug 29 08:30:19 gheorghe slapd[7485]: send_ldap_result: conn=31 op=7 p=3
Aug 29 08:30:19 gheorghe slapd[7485]: send_ldap_response: msgid=8 tag=101 err=0
Aug 29 08:30:19 gheorghe slapd[7485]: connection_get(31): got connid=31
Aug 29 08:30:19 gheorghe slapd[7485]: connection_read(31): checking for input on id=31
Aug 29 08:30:19 gheorghe slapd[7485]: do_search
Aug 29 08:30:19 gheorghe slapd[7485]: >>> dnPrettyNormal: <zoneName=meudominio.com.br,ou=DNS,dc=meudominio,dc=com,dc=br>
Aug 29 08:30:19 gheorghe slapd[7485]: <<< dnPrettyNormal: <zoneName=meudominio.com.br,ou=DNS,dc=meudominio,dc=com,dc=br>, <zoneName=meudominio.com.br,ou=dns,dc=meudominio,dc=com,dc=br>
Aug 29 08:30:19 gheorghe slapd[7485]: => bdb_search
Aug 29 08:30:19 gheorghe slapd[7485]: bdb_dn2entry(“zoneName=meudominio.com.br,ou=dns,dc=meudominio,dc=com,dc=br”)
Aug 29 08:30:19 gheorghe slapd[7485]: => bdb_dn2id(“zoneName=meudominio.com.br.br,ou=dns,dc=meudominio,dc=com,dc=br”)
Aug 29 08:30:19 gheorghe slapd[7485]: <= bdb_dn2id: get failed: DB_NOTFOUND: No matching key/data pair found (-30989)
Aug 29 08:30:19 gheorghe slapd[7485]: send_ldap_result: conn=31 op=8 p=3
Aug 29 08:30:19 gheorghe slapd[7485]: send_ldap_response: msgid=9 tag=101 err=32
Aug 29 08:30:19 gheorghe slapd[7485]: connection_get(31): got connid=31
Aug 29 08:30:19 gheorghe slapd[7485]: connection_read(31): checking for input on id=31
Aug 29 08:30:19 gheorghe slapd[7485]: do_add
Aug 29 08:30:19 gheorghe slapd[7485]: >>> dnPrettyNormal: <zoneName=meudominio.com.br,ou=DNS,dc=meudominio,dc=com,dc=br>
Aug 29 08:30:19 gheorghe slapd[7485]: <<< dnPrettyNormal: <zoneName=meudominio.com.br,ou=DNS,dc=meudominio,dc=com,dc=br>, <zoneName=meudominio.com.br,ou=dns,dc=meudominio,dc=com,dc=br>
Aug 29 08:30:19 gheorghe slapd[7485]: send_ldap_result: conn=31 op=9 p=3
Aug 29 08:30:19 gheorghe slapd[7485]: send_ldap_response: msgid=10 tag=105 err=21

I tray all… our almost all … rs …but i don’t resolver error…

Thanks for any help to me resolve this problem.

BEST REGARDs…

You need to find the cause of this error.

Aug 29 08:30:19 gheorghe slapd[7485]: <= bdb_dn2id: get failed: DB_NOTFOUND: No matching key/data pair found (-30989)

Maybe your LDAP doesn’t have the data or you provided the wrong DN. Try installing a LDAP DB browser like phpldapadmin.

hi ken…

how make create db in phpLDAPadmin…

please help me … thanks

How do you mean create DB? You can only view existing LDAP DBs with phpldapadmin and modify attributes. You can’t create new LDAP DBs, that has to be done in slapd.conf and running slapd. You have to edit the phpldapadmin config file to be able to connect to your LDAP server.

I create dn mydomain…

my ldap.conf

include /etc/openldap/schema/core.schema
include /etc/openldap/schema/cosine.schema
include /etc/openldap/schema/inetorgperson.schema
include /etc/openldap/schema/nis.schema
include /etc/openldap/schema/yast.schema
include /etc/openldap/schema/samba3.schema
include /etc/openldap/schema/postfix.schema
include /etc/openldap/schema/courier.schema
include /etc/openldap/schema/dnszone.schema
#include /etc/openldap/schema/dns.schema
include /etc/openldap/schema/ppolicy.schema
include /etc/openldap/schema/entryDN.schema
include /etc/openldap/schema/openldap.schema

Define global ACLs to disable default read access.

allow bind_v2

Do not enable referrals until AFTER you have a working directory

service AND an understanding of referrals.

#referral ldap://root.openldap.org

pidfile /var/run/slapd/slapd.pid
argsfile /var/run/slapd/slapd.args

Load dynamic backend modules:

modulepath /usr/lib/openldap/modules

access to attrs=SambaLMPassword,SambaNTPassword,userPassword,userPKCS12,shadowLastChange
by anonymous auth
by self write
by dn="cn=Administrator,dc=meudominio,dc=com
by * none

access to *
by dn=“cn=Administrator,dc=meudominio,dc=com” write
by users read
by self write
by * read

loglevel 9

database bdb

suffix “dc=meudominio,dc=com”
rootdn “cn=Administrator,dc=meudominio,dc=com”
rootpw “secret”
directory /var/lib/ldap/
checkpoint 1024 5
cachesize 10000
index objectClass,uidNumber,gidNumber eq
index member,mail eq,pres
index cn,displayname,uid,sn,givenname sub,eq,pres
index sambaSID eq
index sambaPrimaryGroupSID eq
index sambaDomainName eq

Any idea???

What about it? You should have some DB files under /var/lib/ldap.

it looks like the ssl key isn´t matching.
or you´re ldap server isn´t setup to recieve ssl/tsl connection and the client is connecting through ssl/tsl.

Greetings
Arnold