Opening URLS in Thunderbird emails

Search the web tried a few different fixes and thus far all have failed.

When i click on a URL in the body of a Thunderbird email nothing happens.

If i right click > open in browser nothing happens.

Firefox is my default browser set with the firefox application and i have also set firefox as my default browser within KDE and i have set defaults within Konquerer to open html files etc with firefox too.

I have tried editing firefoxe’s config too and nothing works.

Firefox 3.5.6
Thunderbird 3.0

If i click on an email address within the body of an email a new email dialog box opens.

Hope somebody can help me with this.


I’ve the same problem.
I tried to write

user_pref("", "/usr/lib64/firefox/firefox");

in pref.js but that don’t work!..

I believe this is in fact a KDE problem, and it is solved when one updates to KDE-4.3.4 from KDE-4.3.1. Just wait a few weeks or so, and I think SuSE-GmbH plan to put in the “update” directory for openSUSE-11.2 a massive update from KDE-4.3.1 to KDE-4.3.4, and that update when applied to one’s PC should fix the problem.

I’ve found

Edit → Preferences → Advanced → General and click on the Config Editor button.
network.protocol-handler.warn-external.ftp user set boolean true
network.protocol-handler.warn-external.http user set boolean true
network.protocol-handler.warn-external.https user set boolean true

Thank you MoustachuSUSE, your suggestion worked a treat.

Thank you very much.