openGL in OpenSUSE 11.3 not working

I am running KDE 4.4.4 release 3 on an AMD 64 X2 motherboard with a GeForce 8800GT. The 3D driver is the NVIDIA 256.53 and the kernel is 2.6.34.7-0.2-default x86_64. The problem started on the last kernel update when I was running SUSE 11.2 so, I thought I would upgrade to resolve the problem. No luck so far. Everything looks OK but when I try to test an openGL screen saver like KPendulum (GL) nothing happens. Has anyone else had this problem and know how to fix it? This is annoying that every time the kernel is updated it breaks the openGL code. Surely the software engineers can stop this from happening>:(

Also, my task bar has black a gray stripes making the clock very hard to read. One time it came up translucent which was nice but I cannot find a way to change it back to the way it was.

When you install the nVidia driver, did you install the openGL 32 bit Library? If not, I suggest that you do so. openGL works fine on my nVidia 9800 GT and that is what I do. I have installed the KDE3 MATRIXGL screensaver and run it all of the time. Further, I must assume you are using (had added) the kernel load option command nomodeset in grub’s menu.lst file, you installed the nVidia driver while in run mode 3 (init 3) and you have set the kernel option NO_KMS_IN_INTRD=Yes in sysconfig, is that correct?

Thank You,

I have Mesa-32bit loaded. I have NO_KMS_IN_INTRD=Yes in sysconfig. But, when I put nomodeset into the menu.list file it takes suse twice the time to boot and it hangs on this error “ata 7: SRST failed (errno=-16)”. I no longer see the bootlog in YAST or I would have posted that here. Are there any other logs or dumps I can look at to determine if nomodeset is on?

2fry I have Mesa-32bit loaded. I have NO_KMS_IN_INTRD=Yes in sysconfig. But, when I put nomodeset into the menu.list file it takes suse twice the time to boot and it hangs on this error “ata 7: SRST failed (errno=-16)”. I no longer see the bootlog in YAST or I would have posted that here. Are there any other logs or dumps I can look at to determine if nomodeset is on?
2fry, that does not sound right. Can you use the failsafe kernel load option? Without using the nomodeset, which is included in the failsafe selection, and run level 3, the nVidia proprietary binary driver does not load properly. Further, NO_KMS_IN_INTRD=Yes prevents the default nVidia driver from autoloading. I am not sure what is going on, but I would see if the failsafe kernel would load and report back.

Thank You,

I booted the Failsafe – opensuse (default) option. Results were no OpenGL, No Nvidia X driver, and the task bar is light gray with white stripes. When I booted the Failsafe – opensuse (Desktop) option the results are no openGL and no Nvidia X driver but the task bar is black with dark gray stripes.

I can only say that to get the nVidia driver to load I had to, download the kernel source files, download the latest nVidia driver (not beta), boot openSUSE and use both the nomodeset and 3 option together (nomodeset 3 ) for the selected kernel and then the nVidia driver loaded properly. You have to have both to get the driver to install. These two commands will leave you at the Terminal prompt after the boot is complete. After the driver is installed, you need to prevent any other video drivers loading from the kernel, which is why the nomodeset and NO_KMS_IN_INTRD=Yes are required. You have got to get the driver loaded properly before anything else is going to work. Here is my normal text for anyone that needs to install the nVida driver.

You should look at this document before proceeding on…

SDB:Configuring graphics cards - openSUSE

Then, take a look at the procedure I use to install the nVidia driver as I install openSUSE 11.3:

  1. During the install, when you have the option to change your booting setup, I add nomodeset to the kernel load command for the normal load/start of openSUSE. This kernel startup option is already present for the Failsafe selection for openSUSE. I also make sure to install the kernel souce files by adding, base development, kernel development and C/C++ development to my openSUSE install.
  2. During the first start of openSUSE, I download the latest nVidia Video driver to the downloads folder.
  3. I change/save the System/Kernel option NO_KMS_IN_INITRD from “No” to “Yes” in the /etc/sysconfig Editor in Yast.
  4. I do an update of openSUSE on the first run of openSUSE and then a restart/reboot.
  5. In grub OS selection I add the command line option “3” to the openSUSE start line so that I just go to the run level three terminal prompt.
  6. I login in as root and change to the /home/user/Downloads folder.
  7. I run/install the NVIDIA video driver using “sh ./NVIDIA-Linux-x86_64-256.35.run” and answer all questions as appropriate for my system.
  8. Type in reboot at terminal prompt to restart the system with new video driver.

Thank You,

I just searched the thread, there is no mention of blacklisting noveau (spelling ??) the default nvidia driver.

cheers

Well I spent the last 3 days trying to resolve my OpenGL problem with a little success. I wiped my drive and reinstalled a clean version of SUSE 11.3. I found that the update does not work as well as a clean install. I followed the driver installation instructions below-

1: Download the nvidia driver from the nvidia website.
2: Blacklist the nouveau module. Insert “blacklist nouveau” without the quotes at the end of “/etc/modprobe.d/50-blacklist.conf”.
3: Open “/etc/sysconfig/kernel” end set “NO_KMS_IN_INITRD” to “yes”.
4: Run `mkinitrd` and after that.
5: Restart the system with `init 3` boot options.
6: Install the nvidia driver with “sh NVIDIA-Linux-…….run”.
7: Choose 32 bit driver option (YES), create xorg.conf (NO)
8: Generate a default xorg.conf with “nvidia-xconfig”.
9: shutdown -r now

The above installation from jdmcdaniel3 is missing the step "Run mkinitrd" after modifying the /etc/sysconfig file in YAST. Yast does say to run mkinitrd after you modify something but being a novice I missed that the fist time through.

Here are my results -
When I go to my screen savers and try running them they all work except the following:

KPendulum (GL) and KRotation (GL)

The next thing I would like to try is to roll the kernel and Nvidia graphics drive back one or more revisions but I do not know how to do this. Can someone provide some instructions for installing a specific kernel and removing the current one. I have tried once but I get a error that the boot partition is almost full.

2fry, I am happy to hear you got it working. It is very true that doing upgrades are not as likely to work as a fresh install. If you modify NO_KMS_IN_INITRD=Yes using YaST, the mkinitrd is run automatically for you, which is not true if you modify the file manually. Once you have restarted your PC using the NO_KMS_IN_INITRD=Yes, the nouveau driver will no longer load and so black listing it does not seem necessary.

Thank You,

Thanks, It isn’t a complete success though. It looks like I may have found a backwards compatability problem with the latest OpenGL drivers. My current system setup is: AMD Athlon 64 X2 Dual core, KDE 4.4.4 “release 3”, GeForce 8800 GT, Linux 2.6.34.7-0.4-desktop x86_64, NVIDIA 256.53, openSUSE 11.3 (x86_64). I think my OpenGL was working when I started this thread but I have always used the KPendulum (GL) screen saver to test it because it is my favorite. It appears that the latest kernel and NVIDIA drive no longer supports KPendulum (GL) or KRotation (GL) screen savers. Can anyone with similar hardware run these screen savers?

It appears that the latest kernel and NVIDIA drive no longer supports KPendulum (GL) or KRotation (GL) screen savers. Can anyone with similar hardware run these screen savers?
2fry, neither of these two screen savers work on my computer either and I have the nVidia 9800GTX video card and the latest standard nVidia driver release installed as you do. Since I don’t normally use these (I like the old KDE3 GLMatrix myself), I can’t say when they stopped working, if indeed they have ever worked for me. I can say that since the very start, not every screen saver in the set has worked, even as most seem to work. Further, this is not all that uncommon in my estimation and not something I would worry about all that much.

Thank You,

Well I updated my Nvidia driver to the latest version NVIDIA 260.19.12

The open GL screen savers KPendulum (GL) and KRotation (GL) still do not work, but everything else looks fine. I guess backwards compatibility is not important to Nvidia and KDE.

Well I updated my Nvidia driver to the latest version NVIDIA 260.19.12

The open GL screen savers KPendulum (GL) and KRotation (GL) still do not work, but everything else looks fine. I guess backwards compatibility is not important to Nvidia and KDE.
2fry, I also have updated to nVidia 260.19 and went for kernel 2.6.36 with no troubles so far. I have see reports of issues with KDE 4.5 with the latest nVidia driver, so stick with KDE 4.4 as I have for now. As for the two screen savers, I kind of think they are just stuck in time somewhere and may never come back to use, but I am not sure who’s fault that might be.

Thank You,