openct problem: ifdhandler not found

Hello,

after upgradig from openSUSE 11.0 32Bit to 11.1 32Bit my chipcard reader does not work anymore.
I found out that the Problem is openct.
A

rcopenct start

or to be more exact the

openct-control init

gives me the folling output:

# openct-control -d init
Debug: ifd_rutoken_register: ifd_rutoken_register()

Debug: ifd_spawn_handler: driver=cm4000_cs, devtype=pcmcia:/dev/cmm0, index=0
Error: failed to execute /usr/sbin/usr/lib/ifdhandler: No such file or directory

ifdhandler is located at /usr/sbin/ifdhandler. This is also in my /etc/openct.conf:

# Path to ifdhandler
ifdhandler = /usr/sbin/ifdhandler;

Nevertheless openct-controll seems to screw up the path to ifdhandler. It really is located at /usr/sbin:

# which ifdhandler
/usr/sbin/ifdhandler
# ls -l /usr/sbin/ifdhandler
-rwxr-xr-x 1 root root 219788  6. Jan 19:27 /usr/sbin/ifdhandler
# ifdhandler -v
OpenCT 0.6.15

I tried openct version 0.6.16-4.17-i586 and 0.6.15-5.4-i586. I tried uninstalling and reinstalling of openct. Nothing worked.

As a workaround i did the following:

# mkdir /usr/sbin/usr
# mkdir /usr/sbin/usr/lib
# ln /usr/sbin/ifdhandler /usr/sbin/usr/lib/

This works, but its not good i thinkā€¦

Do you have any idea what the Problem might be?
Thank you.

Regards,
pepe