open suse leap 43.2 KDE, HiDPI resolution - dual monitor issue

I installed opensuse Leap 42.3 on dell xps 13.3 inch QHD+ (3200 x 1800) and I have the big problem with resolution it means the letter and icons on my laptop desktop were way too small.
I’ve temporarily solved this problem by changing the scale to 2 (in Display Settings) and changing the DPI value to 192 (in font settings).
But still, some other applications require manual changing in font size etc.

But now I have a issue when I am trying to connect second monitor with the second monitor - 1920x1080 - (dual monitor settings), now the resolution on second monitor is realy bad, but now on the second monitor the icons and letter a too big (completely unuseful) ;(.
Maybe somebody knows how to change the scale or DPI for the second monitor?

My laptop monitor is 3200x1800 (but I change the scale to 2) and my second monitor is 1920x1080.


Just a general rule of thumb,
I always try to avoid any kind of DPI settings, it always results in an unnecessarily complex maze of never ending need to fix things.

I always try to configure screen resolution instead.
You didn’t mention which Desktop you have installed, try inspecting whether you can change the screen resolution for each monitor, and maybe if necessary make adjustments to the Theme.


I think it’s best to stay with using the native display resolution for optimal viewing with each of the displays. See if the advice in this ArchWiki page works for you.

I have a KDE desktop and I had to change DPI since I had to change a scale … otherwise, everything was too small almost impossible to see something.
but, maybe do you know some other solution for suse KDE desctop with HiDPI screan ?

Was scaling alone not sufficient?

when I have changed scale then DPI (fonts DPI) changed automatically from 96 to 192,