Open suse 11.3 Kernel Error and freeze at high I/O // kernel:[22741.852001] Call Trace:

Good day!
The problem is that we have
error message:

kernel:[22741.852001] Call Trace:

and system freezes.

It happens when we use high I/O operations (copy via NFSv.4)
The system is 11.3 and 2.6.34 x86_64 kernel.

I found that there is a bug of the kernel at high I/O operations when cache filled by 100%.
And it is already fixed in the 11.4.

It’s a pity that we cannot change this system anyhow.
And the question is it possible to provide some specific kernel parameters or some tuning to the system to avoid such situation when the cache filled up and the bug in the kernel crashes the system.

We are not able to change the kernel version due to technical reasons.


Probably someone make a tip how to limit the caching the mounted files systems to avoid filling.

I tried tuning rsize and wsize, sync parameters at the client machine in /etc/fstab. For sure it does make performance drop but netherles
it is crucial for is it possible to achieve more or less stability of the system by such tricking things?

Don’t use NFS v4, rather use NFS v3. To do so, edit the file /etc/nfsmount.conf, go to the line that has “# DefaultVers=4” and change that to “DefaultVers=3”. Restart NFS or reboot. This issue was there before, this fixed it.