Open Suse 11.2 Virgin Broadband Can't Connect to Internet

Hi All,

I have just recently installed Open SUSE 11.2 from a CD I got from a Linux Magazine.

Installed this fine as a dual-boot machine on my HP laptop.

To access the Internet, I have normally used 2 ways:

  1. WIFI Connection via my home desktop
    Using Netgear WG111v3 USB Adapter.

  2. Virgin Broadband USB Mobile Broadband stick

I have no problem connecting this via my Windows Vista operating system.

Somehow, under Open SUSE 11.2, this is a problem.

  1. Virgin Broadband - I managed to get the Virgin Broadband icon of a mobile phone saying that it’s connected and “Active” by keying in the number “*99#”, username/password as blank and APN as “VirginBroadband”. However, when I launch Firefox browser, I couldn’t get to any external Website even though the icon for the Virgin Broadband says that it’s Active and connected.

So what’s the problem ?

  1. WIFI Connectivity to Home Desktop WIFI - with this I have never never got any connection at all. It kept saying “Activating” and I have set up the connection and entered the WEP 128-bit paraphrase hex digits. I managed to scan and got the correct SSID and as I know they belong to my desktop.

I read somewhere that Netgear WG111v3 is not compatible with Open Suse 11.2 and will need to install the driver for this. So I did obtain the .INF file and installed ndiswrapper -i with the .inf file… However, still not successful.

I’m thinking of buying a Belkin USB Adapter which is in the list of compatible USB WIFI Adapter for Open Suse 11.2 - … the 802.11g chipset… as I couldn’t get this to work.

Before I do this, if any of you have answers to my above problems, it would be of great help.

Thanks.
DavidSusey:)

Welcome David.

I’m not sure about the Mobile Broadband

I have a thread running about usb dongles, see:
USB Wireless Device that works OOTB? - openSUSE Forums

Your netgear device is the wrong version. You need v2.
They are on ebay here in the UK - about £15

  1. Virgin Broadband - I managed to get the Virgin Broadband icon of a mobile phone saying that it’s connected and “Active” by keying in the number “*99#”, username/password as blank and APN as “VirginBroadband”. However, when I launch Firefox browser, I couldn’t get to any external Website even though the icon for the Virgin Broadband says that it’s Active and connected.

So what’s the problem ?

If the device looks like its connected, maybe its just a gateway or DNS issue. With the device activated, try issuing these commands from a console

cat /etc/resolv.conf

/sbin/route

What is reported?

Thanks Deano.

I’ll get another USB Adaptor - I think the Belkin USB Adapter should work too or the V2 one that you mentioned.

I’ll check the resolv.conf file later on and get back to you on this.

Thanks again.

Cheers
David

if you have not rushed out and bought a new USB wireless device,

I suspect from this thread (post #8 ) that the Netgear WG111v3 will work …

Unable to setup wireless - Netgear WG111v3 - openSUSE Forums

that sends you to

At my wit’s end: Realtek 8187B, 11.1 - openSUSE Forums

where Axel posts an answer in post #2

Try the “compat-wireless” drivers matching your kernel version, kernel type and architecture.

Code:

uname -r # gives you the kernel type and kernel version

cat /etc/SuSE-release # gives you architecture (i586 or x86_64)

Index of /repositories/driver:/wireless

Search for "compat-wireless-kmp-“kernel type”-some date-kernel version-release-number-“architecture”.rpm in openSUSE 11.1 or 11.1-update.

Install and reload module as root (modprobe -r rtl8187 && modprobe rtl8187).

and I can recommend another way to verify before doing any of the above:

download and run this diagnostic script

http://www.linux-tips-and-tricks.de/index.php/collectNWData.sh/collectNWData-Uberblick-/-Overview.html#English

it will offer you answers and it would be good if it verifies the suggested advice above;

the script is overseen by a contributor to this forum, and works very well …

Thanks Deano for the information.
I’ll give this another go before I purchase a different USB adapter.

I’ll do the collection of the network information and post this back to you and see what we can find.

Question: What has Realtek 8187 go to do with this issue ? I thought RL8187 is another chipset/driver - does this work with WG111v3 too ?

Anyway, will get back to you later on tonight.

Cheers
David

If you notice - in the link I gave you @lwfinger refers to the netgear device and chipset it uses:
Permalink: USB Wireless Device that works OOTB? - openSUSE Forums

I’ve now re-installed Open Suse 11.2 again and this time with Gnome instead of KDE.

Still having problems with the WIFI internet connection.

However I think it’s recognising the Netgear WG111v3 USBA adapter as the USB adap.ter and the WIFI light both appeared blue which I think this shows that it has recI’ve now re-installed Open Suse 11.2 again and this time with Gnome instead of KDE.

Still having problems with the WIFI internet connection.

However I think it’s recognising the Netgear WG111v3 USBA adapter as the USB adap.ter and the WIFI light both appeared blue which I think this shows that it has recognised it.

I also issued lsusb recognised it.

I also issued lsusb and it listed the Netgear router and when I used the traditional ifup method I can scan my Belkin router which is on I’ve now re-installed Open Suse 11.2 again and this time with Gnome instead of KDE.

Still having problems with the WIFI internet connection.

However I think it’s recognising the Netgear WG111v3 USBA adapter as the USB adap.ter and the WIFI light both appeared blue which I think this shows that it has recognised it

I issued lsusb and it listed Netgear USB.

i also updated the rooble buut I don’t really know what I should be entering. Please advise

I’m not so sure what I really need to do to establish my WIFI internet connection.

Please help.

Thanks
David

I’ve now re-installed Open Suse 11.2 again and this time with Gnome instead of KDE.

Still having problems with the WIFI internet connection.

However I think it’s recognising the Netgear WG111v3 USBA adapter as the USB adap.ter and the WIFI light both appeared blue which I think this shows that it has recI’ve now re-installed Open Suse 11.2 again and this time with Gnome instead of KDE.

Still having problems with the WIFI internet connection.

However I think it’s recognising the Netgear WG111v3 USBA adapter as the USB adap.ter and the WIFI light both appeared blue which I think this shows that it has recognised it.

I also issued lsusb recognised it.

I also issued lsusb and it listed the Netgear router and when I used the traditional ifup method I can scan my Belkin router which is on I’ve now re-installed Open Suse 11.2 again and this time with Gnome instead of KDE.

Still having problems with the WIFI internet connection.

However I think it’s recognising the Netgear WG111v3 USBA adapter as the USB adapter and the WIFI light both appeared blue which I think this shows that it has recognised it

I issued lsusb and it listed Netgear USB.

i also updated the router table but I don’t really know what I should be entering. Please advise

i also updated the route table what I really need to do to establish my WIFI internet connection.

Please help and if you can provide step by step instructions that would be great.

Thanks
David

My Belkin router is on a Windows Desktop and its WIFI enabled.

I can scan the Belkin router from my Linux Open Suse 11.2 laptop hence its communicating.

But how come I still can’t get my Internet connection on my Open Suse 11.2 laptop.

Is it my route table setup or resolv.conf ? What IP address values should I have and how and where do I get the correct ones ?

Please advise.

Thanks.

Cheers
David

My Belkin router is on a Windows Desktop and its WIFI enabled.

I don’t get this. A router on a windows desktop? Or do you just mean it’s also connected to a windows desktop?

Hi Deano,

I finally got my Netgear WIFI USB Adapter WG111V3 to work. It doesn’t need any additional driver under Open Suse 11.2.

I re-installed Open Suse 11.2 and this time using Gnome Desktop and setup the traditional IFUP network services and have to setup the route table as well as ensuring that its pointing to wlan1 instead of wlan0 as wlan0 is already used by the default SUSE wireless card.

Also had to edit the resolv.conf file and also ensure that the route table is pointing to my Belkin router gateway IP address.

So my next task is to get my Virgin Broadband to work.

I’ll let you know… or if you have any other useful information in regards to setting up wireless broadband to external service provider… do like to hear …

Thanks…

Cheers
david

Thanks for the update.

So my next task is to get my Virgin Broadband to work.

I’ll let you know… or if you have any other useful information in regards to setting up wireless broadband to external service provider… do like to hear …

Thanks…

Cheers
david

My suggestion is to start a new thread on this if you get stuck and need assistance. Don’t forget google either - loads of how to’s and threads dealing with your wireless broadband hardware and provider. Good luck.

if you can to connect your PC to a existing network/cable and in paralel use your stick ,use zypper and having connection the system will take what is need.after you can renounce at the ethernet cable and your system will work

of course install the rpm for you stick like to ozerocdoff,modeswitch or python depend on your stick type.
at the end use wvdial or other to connect.acces to be sure betavine,I am convinced you know about this…

good connection

Thanks.

Can you please explain what exactly do I need to do to get my Virgin Broadband to run under Open Suse 11.2 ?

If you can perhaps give an example step by step if its ok by you.

Thanks again.

Cheers
David

plug in your USB Virgin modem (Virgin UK ??

follow the instructions from here

PHARscape | NetworkManager 0.7.0 and 3G WWAN Modems How-To

… go halfway down page to “create a mobile broadband connection”

with open suse you may have to enter your apn settings

for Virgin UK I understand they are

goto.virginmobile.uk

Carrier APN Settings - ModMyi - Wiki

and for other settings

Username : user
Password: (leave blank)

let us know how you get along

Thanks I’ll give this a go and get back to you.

Cheers
David

Hi,

Still no success.

Tried the wvdial method…doesn’t work either.

Do I need to put anything in the /etc/resolv.conf if so what should I have in there as this time its going directly to the external service provider Virgin Mobile Broadband so what should the entries of the IP address be ???

Anything I should put in the Routing table ?

what about the wvdial.conf any good example of the exact coding what this should be ? I noticed that baud rate has to be a specific baud rate and the username and password is required and the APN in eithe INIT3 or INIT4…i saw some example this is in INIT4 and some this is in INIT3.

So what should I really use ?

I’m really confused… what I should really do to get my Virgin
broad band going…

Please help…

Thanks
David

please plug your device in when your computer has booted

do you get an icon on your desktop? Yes/No ?

first please type

lsusb

now if you have an icon, RIGHT-CLICK on it, and select “eject”

now type

lsusb
… do you get a differing ID?

now please type

dmesg | grep tty

and if you get ttyUSB0 and others, you should be good to configure … as detailed in prior post … how to create …

if you copy and paste the results from the above, so folks can see how it goes

and can you tell us your country, and therefore which Virgin network …

davidsusey wrote:
> Still no success.

i have not read the preceeding in this long thread, so maybe you
have already done, if so just ignore it, if not i offer it as food for
thought:

is it possible that someone else has tried this before?

what i mean is http://tinyurl.com/39uugss is a google search on
(almost your exact words):

linux Virgin Broadband USB Mobile Broadband stick

which turns up over 22,000 hits…are all of them of no use to you?

second: since Virgin might be using different hardware in different
locals, you might try to contact a local Linux User Group…their web
site may have just the info you need in your area, see:

http://www.linux.org/groups/


DenverD (Linux Counter 282315)
CAVEAT: http://is.gd/bpoMD
posted via NNTP w/TBird 2.0.0.23 | KDE 3.5.7 | openSUSE 10.3
2.6.22.19-0.4-default SMP i686
AMD Athlon 1 GB RAM | GeForce FX 5500 | ASRock K8Upgrade-760GX |
CMedia 9761 AC’97 Audio