Open Suse 11.2 + Gnome: No sound

I am using OpenSuse 11.2 + Gnome

After following the message “check your multimedia problem in ten steps”, I still have no sound.

So, any help would be very much appreciated.

rpm --query --all ‘libav*’ ‘libpostproc*’ ‘libswscale*’ ‘xine’ ‘gst’ MPlayer ‘vlc’ | grep -v avahi | sort

banshee-1-backend-engine-gstreamer-1.5.1-1.1.4.x86_64
gstreamer-0_10-0.10.28-999.pm.1000.1.x86_64
gstreamer-0_10-ffmpeg-0.10.10-999.pm.999.1.x86_64
gstreamer-0_10-fluendo-mp3-0.10.10-42.pm.42.5.x86_64
gstreamer-0_10-fluendo-mpegdemux-0.10.23-42.pm.42.4.x86_64
gstreamer-0_10-fluendo-mpegmux-0.10.4-42.pm.42.2.x86_64
gstreamer-0_10-lang-0.10.28-999.pm.1000.1.noarch
gstreamer-0_10-libnice-0.0.9-2.5.x86_64
gstreamer-0_10-plugins-bad-0.10.18-999.pm.1000.6.x86_64
gstreamer-0_10-plugins-bad-lang-0.10.18-999.pm.1000.6.noarch
gstreamer-0_10-plugins-base-0.10.28-999.pm.999.3.x86_64
gstreamer-0_10-plugins-base-lang-0.10.28-999.pm.999.3.noarch
gstreamer-0_10-plugins-farsight-0.12.11-2.3.x86_64
gstreamer-0_10-plugins-good-0.10.21-999.pm.999.4.x86_64
gstreamer-0_10-plugins-good-extra-0.10.21-999.pm.999.4.x86_64
gstreamer-0_10-plugins-good-lang-0.10.21-999.pm.999.4.noarch
gstreamer-0_10-plugins-ugly-0.10.14-999.pm.999.4.x86_64
gstreamer-0_10-plugins-ugly-lang-0.10.14-999.pm.999.4.noarch
gstreamer-0_10-schroedinger-1.0.7-4.3.x86_64
gstreamer-0_10-utils-0.10.24-3.1.x86_64
gstreamer-utils-0.10.24-3.1.x86_64
libavc1394-0-0.5.3-134.2.x86_64
libavcodec52-0.5.22648svn-0.pm.1.1.x86_64
libavdevice52-0.5.22648svn-0.pm.1.1.x86_64
libavformat52-0.5.22648svn-0.pm.1.1.x86_64
libavutil50-0.5.22648svn-0.pm.1.1.x86_64
libgstapp-0_10-0-0.10.24-2.4.x86_64
libgstapp-0_10-0-32bit-0.10.24-2.4.x86_64
libgstbasevideo-0_10-0-0.10.18-999.pm.1000.6.x86_64
libgstfarsight-0_10-0-0.0.16-2.3.x86_64
libgstinterfaces-0_10-0-0.10.28-999.pm.999.3.x86_64
libgstinterfaces-0_10-0-32bit-0.10.24-2.4.x86_64
libgstphotography-0_10-0-0.10.18-999.pm.1000.6.x86_64
libgstreamer-0_10-0-0.10.28-999.pm.1000.1.x86_64
libgstreamer-0_10-0-32bit-0.10.24-3.1.x86_64
libgstsignalprocessor-0_10-0-0.10.18-999.pm.1000.6.x86_64
libgstvdp-0_10-0-0.10.18-999.pm.1000.6.x86_64
libpostproc51-0.5.22648svn-0.pm.1.1.x86_64
libswscale0-0.5.22648svn-0.pm.1.1.x86_64
libvlc2-1.0.5-1.pm.3.20.x86_64
libvlccore2-1.0.5-1.pm.3.20.x86_64
libxine1-1.1.18.1-1.pm.37.2.x86_64
libxine1-codecs-1.1.18.1-1.pm.37.2.x86_64
libxine1-gnome-vfs-1.1.18.1-1.pm.37.2.x86_64
libxine1-pulse-1.1.18.1-1.pm.37.2.x86_64
MPlayer-1.0rc2_r30099-2.pm.6.2.x86_64
phonon-backend-gstreamer-0_10-4.3.1-3.3.x86_64
phonon-backend-xine-4.3.1-3.3.x86_64
python-gstreamer-0_10-0.10.16-2.3.x86_64
vlc-1.0.5-1.pm.3.20.x86_64
vlc-noX-1.0.5-1.pm.3.20.x86_64
vlc-qt-1.0.5-1.pm.3.20.x86_64
xinetd-2.3.14-143.2.x86_64
xine-ui-0.99.5cvs20091115-0.pm.1.4.x86_64

Thank you for the good work you are doing!

I tried testing the speakers by typing:

speaker-test -Dplug:front -c2 -l5 -twav

speaker-test 1.0.21

Playback device is plug:front
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Playback open error: -16,Dispositivo o recurso ocupado
Playback open error: -16,Dispositivo o recurso ocupado
Playback open error: -16,Dispositivo o recurso ocupado
Playback open error: -16,Dispositivo o recurso ocupado
Playback open error: -16,Dispositivo o recurso ocupado
Playback open error: -16,Dispositivo o recurso ocupado
Playback open error: -16,Dispositivo o recurso ocupado
Playback open error: -16,Dispositivo o recurso ocupado
Playback open error: -16,Dispositivo o recurso ocupado
Playback open error: -16,Dispositivo o recurso ocupado
Playback open error: -16,Dispositivo o recurso ocupado
Playback open error: -16,Dispositivo o recurso ocupado
Playback open error: -16,Dispositivo o recurso ocupado
Playback open error: -16,Dispositivo o recurso ocupado
Playback open error: -16,Dispositivo o recurso ocupado
Playback open error: -16,Dispositivo o recurso ocupado

and also

speaker-test -c2 -l5 -twav

speaker-test 1.0.21

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 96 to 1048576
Period size range from 32 to 349526
Using max buffer size 1048576
Periods = 4
was set period_size = 262144
was set buffer_size = 1048576
0 - Front Left
1 - Front Right
Time per period = 11,392658
0 - Front Left
1 - Front Right
Time per period = 11,406199
0 - Front Left
1 - Front Right
Time per period = 11,411823
0 - Front Left
1 - Front Right
Time per period = 11,411786
0 - Front Left
1 - Front Right
Time per period = 11,410520

With the result of no sound at all.

I have the sound back to the laptop!!!

This is what I have done:

1.- I have installed libao-pulse, which was not included in the excellent post “Check you multimedia problem in ten steps”
See Check your multimedia problem in ten steps

2.- I have then gone to YAST —> Sound —> Delete your configuration.
3.- Go yo YAST —> Sound → Edit a new configuration.

  1. Reboot.

Also of great value:
PulseAudio - openSUSE

SDB:AudioTroubleshooting - openSUSE

I am sorry to say, that I have realized today that I am back with no sound at all.

In order to get my sound back now, everytime I turn on the computer I have to go to YAST and delete the Sound Card, and then add it again. After this, the sound is back. The problem is that everytime I turn the computer off, the configuration seems to be lost, and I have to start all over again when I turn on the computer.

Does anyone know of a possible reason for this to happen?

Thanks for your help.