Open Suse 11.1 - How to set default browser MANUALLY

Hello All,
I have use Firefox most of the time, but I do not trust this application anymore. (too many straight modifications, and strange application behavior when using it).
For some things i use Firefox, so I do not want to delete Firefox from my system entirely.

I have installed the Opera Browser on my system, to use it as my main browser.


  1. Where and How can I Set opera to be my default browser of my Open Suse O.S.**

Thanks for your help, answers

Hello ronaldvermeij,

Strange, never had any problems with Firefox.
Are you sure it isn’t an add-on causing all this?

Depends on which DE you use.
If you use KDE you can change it via SystemSettings->Default-Applications->Web browser. (<-- Not sure about the names of the menus)

Then change “mozillafirefox” to “opera” (without quotes).

Good luck!:wink:

I’m using KDE but a windowsmanager IceWM, that i’ve stripped from everything that i do not need :slight_smile:
So i guesed i’ve stripped to much (from KD) to find this setting back

Thanks for pointing me in the right direction Edward_lii.

this is where you can go…and it will give you the info that you need

Opera - openSUSE

and do you not like “HATE IT” when folks can not answer the Q that you like ask!!!..I mean…like “W.T.H”…geeeeeeeeeeeeesh!..


P.S just tap er with ur mouse…and it will send you straight there!