Open Suse 11.1 - Fligthgear 1.9.1 - Source Code install

Hello All,
I am busy installing FlightGear completely “from sourcecode” by manually downloading all tar-balls. I’ve untarred all packages in their own directories like:

I did all the installation commands like
(- ./

  • ./configure without any prefixes or options!
  • make
    (- make test)
  • make install

Current Status:
Finished all the making, building and compiling of all packages
Trying to put all compiled pieces into the right place, directory

Question (if you have FlightGear already up-and-running on your system):

  1. Can you tell me where all your Plib,OpenSceneGraph, Simgear, FlightGear and FlightGear_datafiles have been installed on your machine?

  2. Which commandline options to i need to add to fgfs of fgrun, so that everything works correctly and Flightgear starts up.
    On the FlightGear website i encounter “stupid vague descriptions” like:

  • “/path/to/FlightGear”…(what? directory? executable file?)
  • “/path/to/data”…(which directory of the data? which files must in in that directory??)
  • “/path/to/simgear”
    but no-one tells EXACTLY to which directory and which files those “paths to…” must point! (like /usr/share/flightgear/ <fgfs> exeutable)
  1. Where and how do i need to add the FlightGear environment Variables?
    In which FILE at which LOCATION must i add these settings?
    This is what the manual vaguely writes about it:

(3 Takeoff: How to start the program)
*To add these in the Bourne shell (and compatibles):
export FG_HOME
export FG_ROOT

or in C shell (and compatibles):
setenv FG_HOME=/usr/local/share/FlightGear
setenv FG_ROOT=/usr/local/share/FlightGear/data
setenv FG_SCENERY=\

Thanks for your exact answers, tips :slight_smile:

As for the where well that can be kind of up to you there is nothing stopping you running it from you home environment.(May take a some configs at configure though)

As for the rest Flightgear has more command flags than I’ve ever met… (beta) soo many I couldn’t post it here without getting told too many chars…

So as some of the first few flags, you can pass it with commandline flags… but… you have fgrun use this to start with. It will generate the commandline and you can see it before processing(And it has a nice gui). One other thing look at terrasync for the scenery.

Having had a look at the spec it looks like /usr/something I suspect /usr/share/FlightGear… If you really want to know download the rpm and look at the structure… Index of /repositories/games/openSUSE_11.1

Also rather than using make install look at checkinstall. This may actually be better but you may need to tweak the config if it is using /usr/local or it may install here which won’t completely matter. Or better still look at the spec and see if you can tweak it from the src.rpm.

Also naughty naughty it is generally a bad idea to do make and .configure as root.

Thanks FeatherMonkey for your answer

Let us know if you get this working? A little howto when you’re done would be appreciated :slight_smile:

Hello All,
Here a “progress report” on my Flightgear installation quest:

  1. I have gotten to the point the FlightGear simulator started with a black square screen, and a text line below that mentioned:
    “starting… Loading scenery data… etc etc”. Only the package crashed, because it gave an error message like this: “… can not find plugin to load model data.”

This error was caused by the missing OpenVrml (package,plugin) as a part of the OpenSceneGraph package. I have tried several time to recompile, make and make install the OpenVrml Packege, but i kept crashing into “lack of real detailed documentation”.

  1. One of the main reason that frustrated me, was the serious lack of EXACT documentation and real life EXAMPLES. From those examples i could have been able to deduct the necceasary information myself.

  2. Most README, INSTALL and “manual” writers assume that every reader is as skilled as they are themselves in the field of compilation, debugging and installation.
    Unfortunately i was not yet 100% Linux make compatible at the time of the installation but i have learned an awefull lot the last week :slight_smile: It brought back very good memories for the beginning of my (turbo, microsoft) c-programming times about 15 year ago

  3. An other thing that really killed my enthousiasme was DEPENDENCIES and the lack of documentation about it!
    Just as i tought that a ./configure would run smooth, a error showed up telling me that i needed an “additional library” to perform the trick. grrrr…

  4. A third thing was that i could not find any FlightGear installation documentation online that was able to tell me how a CORRECTLY INSTALLED and WORKING FlightGear Packages looked like on my harddisk. Something like:

  • These libraries (x,y,z…) → /usr/lib
  • FlightGear Executable (fgfs) -> /usr/bin/fgfs
  • FlightGear FGrun -> /usr/bin/fgrun
  • Flight Data directory -> /usr/local/share/FlightGear/data
  • Flight Scenery directory -> /usr/local/share/FlightGear/data/Scenery

I have spend a lot of time:

  • “vi make”, “vi”, “vi configure” the installation scripts to see how they worked
  • “find / | grep <filename>” to figure out where the h**l all "maked " and “make install” stuff was parked on my harddrive…
  • Surfing the internet to find “dependent libraries” to complete the wishlist of a certain package, that “missed a lib” during make.

That is why i choose - afer 4 long hardworking days to do it from scratch - to just fire up “Yast” add the right repository and choose to install FlightGear as an rpm package.

I believe that i had more in-depth handson experience on the Linux commandline + detailed and clear documentation i would have succesfully completed this adventure :slight_smile: Who knows an i going to do it again :slight_smile: A complete manual install from source_code of FlightGear… cause it was a very rewarding and learning experience :slight_smile:

And i wish to thank all hardworking enthousiasts of the OpenSource, Linux - and Flightsim community all over the world for creating the packages that made up this wonderfull flightsim! Respect to you all!

“Check Six Often and keep the blue side up”

The version in the repos is quite old (v1.0) from the looks of it.

You could try and contact the person that packaged that version for a few tips on how to install from scratch.

Saw your postings in the Flightgear forums. Did not bring you any further?

You might use fgrun. If you use that and configure it properly, it does not realy matter where your Flightgear stuff is.

This is not a how to do it but a what I did…

2 spec files

# spec file for package FlightGear (Version 1.9.1)

# norootforbuild

Name:           FlightGear

%if 0%{?suse_version} 
BuildRequires: freeglut-devel gcc-c++ libjpeg-devel openal-devel libOpenSceneGraph-devel plib-devel update-desktop-files xorg-x11
# Be aware that in Build Service games repo
# it is built within games libraries where freealut is split off from openal.
BuildRequires: freealut-devel 
# fgrun needs fltk
BuildRequires: fltk-devel
 %if %suse_version >= 1010
BuildRequires:  libdrm-devel 

# openal is splitted in 10.2 into openal and freealut.
# Reccomends tag is handled in SuSE > 1010
%if %suse_version > 1000  
Recommends: FlightGear-startup-manual

# others distributions then SuSE
 %if 0%{?mandriva_version} 
BuildRequires:  freeglut-devel gcc-c++ libjpeg-devel libdrm-devel openal-devel plib-devel
BuildRequires: fltk-devel
  %if 0%{?fedora_version} 
BuildRequires:  freeglut-devel freealut-devel gcc-c++ libjpeg-devel libdrm-devel openal-devel plib-devel
BuildRequires: fltk-devel

License:        GPL
Group:          Amusements/Games/3D/Simulation
Autoreqprov:    on
Version:        1.9.1
Release:        17.19
Provides:       flightgr
Obsoletes:      flightgr
PreReq:         /bin/ln
Summary:        FlightGear Flight Simulator
Source:         %{name}-1.9.1.tar.gz
%define	simgear	SimGear-1.9.1
Source1:        %{simgear}.tar.gz
Source2:        FG_getstart.pdf.tar.bz2
Source3:        fgrun-1.5.1.tar.gz
# icons
Source4:        fg-icons.tgz
%define fgrunversion   1.5.1
# FlightGear patches
#Patch1:         %{name}-1.0.0-browser.patch
#Patch2:         %{name}-1.0.0-plib_version.patch
# SimGear patches
#Patch11:        %{simgear}-strict_alias.patch
#Patch12:        %{simgear}-plib_version.patch
# FGrun patches
Patch21:        fgrun-suse_prefs.patch
#Patch22:        fgrun-missing_include.patch
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Requires:       FlightGear-data = %version

The Flight Gear Flight Simulator project is a free, Open Source,
multi-platform, cooperative flight simulator development project.

    Raoul Alonzo <>
    Michele America <>
    Michael Basler <>
    Jon S. Berndt <>
    Paul Bleisch <>
    Jim Brennan <>
    Bernie Bright <>
    Bernhard H. Buckel <>
    Gene Buckle <>
    Didier Chauveau <>
    Oliver Delise <>
    Dave Eberly <>
    Francine Evans <>
    Oscar Everitt <>
    Jean-loup Gailly and Mark Adler <>
    Thomas Gellekum <>
    Jeff Goeke-Smith <>
    Michael I. Gold <>
    Charlie Hotchkiss <>
    Bruce Jackson of NASA <>
    Richard Kaszeta <>
    Tom Knienieder <>
    Reto Koradi <>
    Bob Kuehne <>
    Christian Mayer <>
    David Megginson <>
    Eric Mitchell <>
    Anders Morken <>
    Alan Murta <>
    Alexei Novikov <>
    Curt Olson <>
    Tony Peden <>
    Robin Peel <>
    Friedemann Reinhard <>
    Petter Reinholdtsen <>
    William Riley <>
    Paul Schlyter <>
    Chris Schoeneman <>
    Phil Schubert <>
    Jonathan R Shewchuk <>
    Gordan Sikic <>
    Michael Smith <>
    Durk Talsma <>
    Mark Vallevand <>
    Gary R. Van Sickle <>
    Norman Vine <>
    Roland Voegtli <>
    Carmelo Volpe <>
    Darrell Walisser <>
    Robert Allan Zeh <raz@cmg.FCNBD.COM>

%package startup-manual

License:        GPL
Group:          Amusements/Games/3D/Simulation
Version:        1.9.1
Release:        17.19
Summary:        FlightGear Manual

%description startup-manual
The FlightGear Manual Version 1.9.1  December 15, 2007
For FlightGear version 1.9.1.

   Michael Basler, Martin Spott,
   Stuart Buchanan, Jon Berndt,
   Bernhard Buckel, Cameron Moore,
   Curt Olson, Dave Perry,
   Michael Selig, Darrell Walisser,
   and others

%package fgrun

License:        GPL
Group:          Amusements/Games/3D/Simulation
Version:        1.5.1
Release:        17.19
Summary:        FlightGear Graphical Launcher
Requires:       FlightGear = 1.9.1

%description fgrun
The FlightGear Graphical Launcher

  Bernie Bright <>
        Original author.

  Frederic Bouvier <>
        Project admin,

# build only for SuSE 10.0 and higher
# because of need to have uptodate some packages (e.g. openal)
# or use a libs subproject in games project in Build Service
%setup -n FlightGear-1.9.1 -q -b 1 -b 3 -a 2 -a 4
# fgrun patches
pushd ../fgrun-%{fgrunversion}
# SimGear patches
pushd ../%{simgear}
# FlightGear patches
rm -fv docs-mini/README.MSVC*
rm -fv docs-mini/README.IRIX docs-mini/README.MacOS

rm -rf /var/tmp/tmpinstall
mkdir  /var/tmp/tmpinstall
export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
export CXXFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
# beware where is the X libraries installed ( 6.9 vs. 7.x)
%if "%(xft-config --prefix)" == "/usr"
CONFIGURE_OPTIONS="--prefix=%{_prefix} --libdir=%{_libdir} --mandir=%{_mandir} \
--infodir=%{_infodir} --sysconfdir=%{_sysconfdir} --without-logging \
--x-includes=/usr/include --x-libraries=/usr/%{_lib}"
CONFIGURE_OPTIONS="--prefix=%{_prefix} --libdir=%{_libdir} --mandir=%{_mandir} \
--infodir=%{_infodir} --sysconfdir=%{_sysconfdir} --without-logging"
# SimGear build and install
# don't use make %{?jobs:-j%jobs}, fails on some archs everytime
cd ../%{simgear}
%{?suse_update_config:%{suse_update_config -f}}
autoreconf --force --install
CPPFLAGS="-I /var/tmp/tmpinstall/%{_includedir}" ./configure $CONFIGURE_OPTIONS \
    --with-jpeg-factory LDFLAGS=-L/var/tmp/tmpinstall/usr/%{_lib}
make %{?jobs:-j%jobs}
make DESTDIR=$RPM_BUILD_ROOT     install
make DESTDIR=/var/tmp/tmpinstall install
cd ../%{name}-1.9.1*
# FlightGear finally
# don't use make %{?jobs:-j%jobs}, fails sometimes on every archs. 
# should be fixed now
autoreconf --force --install
%{?suse_update_config:%{suse_update_config -f}}
# beware where is the X libraries installed ( 6.9 vs. 7.x) 
%if "%(xft-config --prefix)" == "/usr"
./configure $CONFIGURE_OPTIONS --with-x --with-simgear=/var/tmp/tmpinstall/usr \
 --enable-osgviewer \
 LDFLAGS=-L/var/tmp/tmpinstall/usr/%{_lib} \
 --x-includes=/usr/include --x-libraries=/usr/%{_lib}
./configure $CONFIGURE_OPTIONS --with-x --with-simgear=/var/tmp/tmpinstall/usr \
 --enable-osgviewer \
make %{?jobs:-j%jobs}
# use sdl instead of glut if some problems to run FG, no need to do so now, freeglut is fixed in Suse
#    --enable-sdl 

# install icons and their License
for i in 16 32 48 64 128; do
        install -D -m 0644 icons/fg-${i}.png $RPM_BUILD_ROOT/usr/share/icons/hicolor/${i}x${i}/apps/FG.png
install -D -m 0644 icons/README $RPM_BUILD_ROOT/usr/share/doc/packages/FlightGear/README_icons

# now build fgrun application
cd ../fgrun-%{fgrunversion}
%{?suse_update_config:%{suse_update_config -f}}
%if "%(xft-config --prefix)" == "/usr"
%configure --with-simgear=/var/tmp/tmpinstall/usr  --with-x LDFLAGS=-L/var/tmp/tmpinstall/usr/%{_lib} \
 --x-includes=/usr/include --x-libraries=/usr/%{_lib}
%configure --with-simgear=/var/tmp/tmpinstall/usr --with-x LDFLAGS=-L/var/tmp/tmpinstall/usr/%{_lib}
make %{?jobs:-j%jobs}

mkdir SimGear
mkdir FGrun
cp ../fgrun-%{fgrunversion}/{AUTHORS,COPYING,ChangeLog,NEWS,README} FGrun
# fgrun
pushd ../fgrun-%{fgrunversion}

%if 0%{?suse_version} > 0 
%suse_update_desktop_file -c %name FlightGear "Flight Simulator" fgfs "FG" Game Simulation


%defattr (-, root, root)
%doc AUTHORS COPYING ChangeLog NEWS README Thanks SimGear/ docs-mini/
%doc %{_mandir}/man1/*
%exclude /usr/bin/fgrun
%if 0%{?suse_version} > 0 
%exclude /usr/%{_lib}/*.a
%exclude /usr/include/simgear/*.h
%exclude /usr/include/simgear/*/*.h
%exclude /usr/include/simgear/*/*.hxx
%exclude /usr/include/simgear/*/*/*.hxx

%files startup-manual
%defattr (-, root, root)
%doc FG_getstart.pdf

%files fgrun
%defattr (-, root, root)
%doc FGrun 

* Tue Jul  1 2008
- excluding header files in /usr/include/simgear/*
* Tue Jul  1 2008
- fixed missing include (fgrun-missing_include.patch)
* Mon Jun 30 2008
- added icons from Josh Babcock (GPL licensed)
- added icon name to desktop file
* Wed Apr 30 2008
- switched to OSG viewer instead of plib
- enabled jpeg support in Simgear (libjpeg-devel -> BuildReq)
* Mon Apr 28 2008
- update fgrun to version 1.0.1
  * program internationalized
  * dutch, french, german, italian, polish and portugese localisations
  * fix a crash when "Default" button was pressed
  * fix clock_freeze option
  * added a combo to choose bpp in the wizard
  * added aircraft status and author in the wizard
* Wed Mar  5 2008
- added fgrun 1.0.0 application as subpackage
  needs fltk-devel in BuildReq
  It needs manual setting ;(
* Thu Jan  3 2008
- updated FlightGear, SimGear and get_start manual to version 1.0.0
  obsoleted patches SG-include.patch, FG-includes.patch
* Wed Nov 21 2007
- added OpenSceneGraph-devel to BuildReq
- new subpackage startup-manual which contains manual in pdf
* Tue Oct 16 2007
- update to cvs version 20071016
- obsoletes FG patches: *64bit.patch, *test.patch
  * array_overflow.patch
- obsoletes SG: *uninitialized.patch
Name:		FlightGear-data
Summary:	FlightGear base scenery and data files
Version:	1.9.1
Release:	3%{?dist}
Provides:	FlightGear-data

License:	GPLv2+
Group:		Amusements/Games
Source0:         %{name}-1.9.1.tar.gz
BuildRoot:	%{_tmppath}/%{name}-{version}-%{release}-root-%(%{__id_u} -n)
BuildArch:	noarch
Obsoletes:	fgfs-base < 1.9.0-1

This package contains the base scenery for FlightGear and must be



install -d $RPM_BUILD_ROOT/%{_datadir}/FlightGear/
tar zxvf %{SOURCE0} -C $RPM_BUILD_ROOT/%{_datadir}/FlightGear/

# cleanup temporary files and fix permissions
find $RPM_BUILD_ROOT/%{_datadir}/FlightGear -name '*#*' -exec rm {} \;
find $RPM_BUILD_ROOT/%{_datadir}/FlightGear -type f -exec chmod 644 {} \;

# fix wrong eol encoding on some doc files
for f in data/Docs/FGShortRef.css data/Docs/README.kln89.html data/Docs/FGShortRef.html \
	data/Docs/README.submodels data/Docs/README.yasim data/Docs/README.xmlparticles
	sed -i 's/\r//' $RPM_BUILD_ROOT/%{_datadir}/FlightGear/$f

# remove hidden dirs
for d in data/Aircraft/c172/Panels/Textures/.xvpics \
	rm -rf $RPM_BUILD_ROOT/%{_datadir}/FlightGear/$d

# fix files not in utf-8
for f in data/Thanks data/Docs/README.xmlparticles
	iconv -f iso-8859-1 -t utf-8 -o ${path}.utf8 $path
	mv -f ${path}.utf8 ${path}

# put documentation and license in the proper location
mkdir -p $RPM_BUILD_ROOT/%{_docdir}/%{name}-%{version}
for f in data/COPYING data/AUTHORS data/NEWS data/README /data/Thanks data/Docs
	mv $RPM_BUILD_ROOT/%{_datadir}/FlightGear/$f \


%defattr(-, root, root, 0755)
%doc %{_docdir}/%{name}-%{version}

* Fri Jul 24 2009 Fedora Release Engineering <> - 1.9.0-3
- Rebuilt for

* Mon Feb 23 2009 Fedora Release Engineering <> - 1.9.0-2
- Rebuilt for

* Tue Jan 06 2009 Fabrice Bellet <> 1.9.0-1
- new upstream release

* Mon Jan  7 2008 Fabrice Bellet <> 1.0.0-1
- new upstream release

* Sun Sep 23 2007 Fabrice Bellet <> 0.9.11-0.2.pre1
- update License tag

* Wed Jun 27 2007 Fabrice Bellet <> 0.9.11-0.1.pre1
- new upstream (pre-)release

* Sat Apr  7 2007 Fabrice Bellet <> 0.9.10-3
- use sed instead of dos2unix to correct end-of-line encoding

* Mon Apr  2 2007 Fabrice Bellet <> 0.9.10-2
- Move documentation and license to a better place and mark it as %%doc
- Fix wrong end-of-line encoding in some doc files

* Tue Mar 20 2007 Fabrice Bellet <> 0.9.10-1
- Initial packaging



So sources in /usr/src/packages/SOURCES ditto SPECS then as user

rpmbuild -bb /all/the/path/to.spec

You’ll end up with ls /usr/src/packages/RPMS/i586


data will be in noarch

Only couple of things you need libOpenSceneGraph-devel for build and boost-devel iirc.

For run time you’ll need OpenSceneGraph-plugins

I take nothing away from the authors of the original .specs both are bastardised one from fed the other the original Suse src.rpm which gave the desktop file.

If it works for you well done it works for me, you may have some build deps missed I struggled with some bits in the spec and had to hardcode the version due to problems(Short story they’re a mess but they do work)

Getting the data was tricky I kept finding .xv files which I finally converted but could probably amended the spec. Also renamed 1.9.0 to 1.9.1

Edit Clarity…

When ditto meant
So specs in /usr/src/packages/SPECS

And those specs need some major cleaning up… I now remember why I ended up using another distro a day later and I’m still no closer to understanding all those macros, which was the reasoning for renaming the data tar.gz and why I had to hardcode the version in certain bits with fgrun.

Thanks FeatherMonkey, for sharing your FG-installation knowlegde with me :slight_smile: This clarifies al lot, why it would not run in the first place.

I crashed on manual installation because i could not get the OpenVrml package “complete and compiled”. The rest of the stuff i was able to figure out myself.

What also killed me is the fact that Linux allows software to be installed “all over the harddisk” (/usr, usr/bin, usr/local/…, usr/share… /usr/lib/ in contrast to the windows platform which (mostly) stores

  • Programs and executables -]\programfiles
  • libraries and dll’s -]\windows\ and ]\windows\system32.
  • Settings in the registry

And since i was not able to find detailed installation information (where goes what after make install) i spend a lot of time figuring out and “connecting the packages” together to one working Flightsim.

And using FGRUN is not an option, if you do not know where the stuff was “make installed” to :wink: (which i have found it by now :slight_smile:

Do you know where i can find DEVELOPER-LEVEL documentation on FlightGear on internet? The docs that show my how everything works under-the-hood? of a crsytal clear graphic how everything is tied together within FlightGear?


“I just made my first keyboard_controlled lowpass over KSFO and made a nose dive into the grassland next to the runway”

Mmm well I have to say I found that painful I had similar and fgrun kept asking for flightgear 1.5.1. Then I struggled to understand why the data files where getting stripped of data/ and fgrun was looking for /data regardless of what I told it(Never did find out why and solved the data/ stripping which was caused by a tar flag.)

I tend to prefer using the package manager to handle stuff so I can uninstall when it goes wrong :wink: but having never really played with specs I struggled I never did work out why if using %version fgrun was looking for 1.5.1 so gave up and told it to look for 1.9.1.

As for installed all over the place not really you’ll find most of it in /usr/ /usr/lib holding most libs /usr/bin with the exes and /usr/share the rest. Settings well should be in ~/.config but few stick to this but ~/.*
I probably oversimplify but I just think of the top tier libs /lib as the shared type ones i.e something I don’t need to worry about likewise system settings in /etc(Though these see more action)

It really is rare to see /usr/local used anymore also you tell the program where to install with your configure flags. Make install is just following along to the conventions you set with configure.

As for the devel not really there is several different components to it, simgear would be the main one I would of thought, then flightgear its self, but I suspect you’ll have a lot of the scenery type things based around terrasync. So not sure you’ll find just one but an amalgamation of a few bits. Without looking I wouldn’t be surprised if you found the source heavily commented either, combined with mailing lists I would suspect this would contribute to the docs :wink:

As for flying I may go back I’m determined to fly the cessna to the US from the UK but Greenland is a bit sparse on airports…

(Never did find out why and solved the data/ stripping which was caused by a tar flag.)

I use tar xvfz <tarbal.gz>
This automatically creates a /<tarbal_name> directory in the current directory where you execute the tar command

I tend to prefer using the package manager to handle stuff so I can uninstall when it goes wrong

That is also my favorite way to (de)install software. Since i could not find a FlightGear<version>.rpm via Suse’s Yast, I decided to do it “the hard way” and build the package from scratch.

Back in the old days i use to make a living as a (basic,pascal,clipper,c, c++ ) programmer, so i can read and understand c++ sourcecode, i understand sources, libraries, linking, objects, compilers and make tools. Armed with that knowledge i started the “building FlightGear from the ground up” adventure, with enthusiasm. This process helps me to understand how FlightGear is being architectured and “how it works under-the-hood.”

As for the Linux part of the installation.
I am rapidly learning to “read makefile”, find my way around the linux filesystem, managing the “linux way of doing software installation”. This was a hard, seep but very nice and rewarding learning experience which gave me much insight on the Linux platform by much hands-on trail and error exercise (To my opinion the ONLY way to master stuff on a computer).

It really is rare to see /usr/local used anymore also you tell the program where to install with your configure flags. Make install is just following along to the conventions you set with configure.

I choose to do it thsi way, because

  • when i started to make and compile i did not yet understand al the possible options like -prefix=/installation/directory :frowning:
  • when i found and started /usr/lib/fgfs it produced an error “that it could not find xxxx in /usr/local/share/flightgear”. That is why i moved the FlightGear file to that place on my harddrive.

As for flying I may go back I’m determined to fly the cessna to the US from the UK but Greenland is a bit sparse on airports…

Nice adventure … flying a Cessna from the UK to the US.
And for the lack of airports on Greenland i may have a solution or two

  • it is possible to “maneuver the Nimitz” along your flightpath with you? Then you have always a carrier and landingplace with you :slight_smile:
  • It is possible to embed a flying tanker en-route? via an external script. After all…there is a air-to-air refueling scenario in FlightGear :-).
  • Or MODify the Cessna’s fuel capacity in its xml file, so that you do not need to re-fuel on this trip?

Keep the blue side up and thanks again for the advise

My data stripping was due to using the fed spec it was a flag --strip-components 1 I still think it should of worked though, but I may of been wrong as when I finally solved it I had a runtime dep missing.

The harder way still was to write a spec(Or as I did bastardise one). Couldn’t find a src.rpm for the data though which complicated matters and steepened the learning curve. The other way is to use checkinstall instead of make install which will make a crude rpm. A handy command I was using a lot is to see the structure of the rpm… rpm2cpio /path/to/rpm | cpio -t.

As for the prefix etc sounds like you had better skills than I c++ just looks like hieroglyphics to me.

Nothing stopping you using /usr/local I believe it is the old standard of installing non-standard stuff, for ease of clean up. As for the prefix magic pfft… I had enough hassle with some basic compile knowledge and a set of base specs to use. I find those macros just obfuscate things and over complicate it give me a bash based package system any day of the week.

You really should look at atlas Atlas - The FlightGear mapping utility I tend to have it open you have to tell Flightgear your running it. If you link it with your data files then you can get the navcodes, but if you’ve not been there it won’t help much, but this does Navaid Info Then with Terrasync you shouldn’t get any blank spots, but you will need to rebuild the Atlas maps occasionally. I’m really not going to hunt this down I have a working FG on another distro and I’m done with spec building it is just too difficult, but in case it helps I noticed my version has a heavy patch to it. Arch Linux Repositories [community] View of /flightgear-atlas/repos/community-x86_64/build-fix.patch

As for the cessna its got wet wings, I think I can make some obscure airport in Iceland then some really obscure one in Greenland - Kulusuk Note my navaid site doesn’t help with all, I got that one from List of airports in Greenland - Wikipedia, the free encyclopedia I certainly have wifi when I’m flying hehe… And… you can cheat and just slide the fuel bar

Good luck with your flying…

So did you use the specs, did they work for you, or was it just a source to iron out the niggles?

P.S So did you use the specs, did they work for you, or was it just a source to iron out the niggles?

I saved your specs and printed them out as learning sources.
Later when my new pc is ready, i’m going to do this adventure again.Install Flightgear from source-code, so i will need it then.

Thanks for the NavIad website. I have a nice resource for you to look at.
The Jeppesen website, the AOPA Chart Clinics
Service Overview

This PDF-based tutorial learns you to read jeppesen (IFR) chart in very basis staps :slight_smile: Very much stuff.

Have fun with the chart clinic