Open Suse 11.1 desktop screen look weird on my notebook

Hi all,

My screen look awkward on my HP/compaq V3633AU notebook. I can’t resize to the best resolution like Windows does?

Under System -> Configuration -> Configure X11 System, Monitor Tab.
The option is: 800x600(SVGA) or 1024x768(XGA) on the 16.7milo 24bit.

I selected 1024x768(XGA) and reboot, Still the screen look big to me.

after that i go to Display setting, nothing to reduce to smaller but accept Default or 1024x768 …

How to make my screen size to the max reduction like my Vista?

Problem is my status bar large, the wallpaper huge and when i surfing net using Mozilla Firefox the tab and every thing look squeezing.

Tks pls help

What graphics card has the notebook?
You probably need propertiery drivers.

I not very familiar with graphic thingy. (I just found the version :NVIDIA® GeForce™ Go 7150M, is this the graphic support?

But I do know I saw a icon indicated nvidia icon when I was on Vista OS.

So how to solve this issue?

How to know what actual model/version of graphic card i’m using right now?

From Hp or reboot to Vista?


Okay, nvidia, that shouldn’t be a problem.

Open install or remove software packages (yast)
Menu settings > repositories
Add > community repositories > NVIDIA repository
After adding this repository, the driver should be automatically selected and installed. Reboot and change the video settings to the correct resolution.

PS: the driver is the same for most of the newer nvidia cards

Done. But screen still look the same.

Can’t find any thing that have ‘Video Settings’

I had a similar problem with my Compaq Presario. My problem is that my monitor has a non-native form factor, i.e., 1280x800. The way I fixed it was to login as root and launch the program “nvidia-settings”. There is a tab marked “X Server Display Settings”. There are pull down entries for resolution, color depth, and monitor sync. Save the changes. Examine /etc/X11/xorg.conf to verify that the changes are there. Reboot.

Mmmh think after enabling the nvidia repository and installing the driver the first time it boots up it doesn’t even come up with a GUI but commandline?
In there you can do a sudo nvidia-xconfig command followed by a sax2 -r command, select the proper settings, test/save.
sudo reboot
If it starts up normally you might still need to execute those commands, at least they wont do any harm.

And then it should work.