Open Suse 11.1 - ATI - Laptop - 64Bits

I just come from Ubuntu. To mutch steps for installing aptana. I need to work with the laptop, not playing on “how to install this or that”. So, opensource second change. Here I am, on Opensuse. Really like the openSuse + gnome. Really. Very pratical, the way we can access the terminal, very fast the way we do things, it seams good to work.

“On new Ubuntu 8.10: You start ubuntu, he says that you need the proprietary drivers, he downloads and installs ATI proprietary drivers. DONE.”

on new OpenSuse 11.1:
“ATI? Sorry? AT what? Yes… we have it but… do you have what? A xpress? No? ow… a 64 Bits… yes… well… it’s complicated. We have… a page where you can see how to do it.”

So, I’ve read and follow the manual. Let’s go to the easy way. Ups, OpenSuse 11.1 isn’t there. Ok.
Let’s go to the hard way (even if I don’t like it, I’m a newbie): ups… you download the drivers, you make them a package, but you can only choose 11.0 max. No 11.1. Ok. Let’s choose 11.0 maybe they will work. Ups! Error. Can’t create package. Ohhh…

So… here I am, asking you this very simple question:
How can I properly install a ATI graphic card on my HP 8530p that says on the selling paper: Suse Enterprise Certificated (what a joke!).

I do understand that it can be no easy to install a USB Wireless card, when you have to use inf files. So, I wait the time to come for that to be easy. I do understand that running wine could be complicated, that virtualbox can have multiple issues to look at… etc… etc… but there is some basics things that I cannot understand: Forgeting the ATI graphic cards???

So, please, anyone to help a newbie that wants to stay on openSuse: How can we install a ATI Mobility Radeon HD 3650 graphic card on opensuse 11.1 64bits environment ?


ATI drivers are non-free software, so they can’t be shipped with any true GNU/Linux system. To get them, you must manually add the ATI proprietary repository to your software sources in YaST. See detailed instructions at Additional YaST Package Repositories - openSUSE.
Anyway, since openSUSE 11.1 has just come out, you may have to wait a couple of days for the ATI repository to catch up. Try using the non-accelerated vesa/framebuffer drivers for the time being.
Cheerz and good luck!:slight_smile:

Thanks for your reply. I-m on a live cd right now,cas each time I start, I get a white screen. I-ve tried a fresh instalation! Still get the white screen.

I-m having white screen because i-ve tried another ati driver, and now all is messed up. How can I revert thing for where they where_

Sorry for the mssing pontuation

Please help,

Additional YaST Package Repositories - openSUSE

Hi have been here. I-ve click. But it says>

  1. I can understand that because, the page also says

Note that this repository is not browsable with a web browser …

I see this, and it seams good news, but I cannot click, for reasons already mention


I suppose I have to add this URL to yaST and he would know what to do?

How can we accomplish this?

Regards once again.

ps. i-m really having issues with the white display.

Ok. found the info about how to repositories. Here
Add Package Repositories to YaST - openSUSE

the only issue is now the white screen…

Do a full install. What’s with the live CD?

Those are only for evaluation purposes, IIRC, not for regular everyday use.

I don’t understand your reply, sorry.

Are you telling that openSuse is not a work environment?

I’m doing a clean install using the Live CD. It’s the best way of doing this, I to prefer fix instead of destroy… anyway…

Hope after this, the white screen go away.

Back to the game. After a clean install.

I will try the repository links and post back if any issues.


The white screen should go away if you type

sax2 -r

(you might have to run that as root) in a virtual terminal (booting in safe mode or entering number 3 as kernel parameter in the boot screen). If that command doesn’t reconfigure your screen, try

sax2 -r -m 0=vesa


I have already gparted and everything… :slight_smile:

But thanks for the reply. I will take that for future reference. And for occasions when I will have a lot of things NOT to delete.

Ok. I’m getting this when I try to add a repository from:

"Unable to create repository
from URL ‘’.

Try again?"

So, even if we have the URL we should wait? How do we know that the repository is available?

Regards once again,

i’ve got the same problem with opensuse 11.1

when trying to add the repository in Yast, I get the same message:

"Unable to create repository
from URL ‘’.

Try again?"

When I did it with opensuse 11.0, I was able to add the repository
without errors

It looks to me like suse/11.1 does not exist but suse/11.0 does

However there seems to be no way of checking, because neither are accessible by a browser

Any clues ?


In other threads I have seen it said “…ATI…11.1…” ‘not yet, sometime soon’.

I am waiting as well, similar issues with 11.1 on an HP Media laptop (DV7)

3D Support not working in 11.1 - openSUSE Forums
Might help

The ATI Repository for 11.1 now available.
I have not tried it yet

Additional YaST Package Repositories - openSUSE

They’re still not up, just tried… add > community repositories doesn’t list it.
Also tried manually adding the link and it wont let me, the link on the page is just where it’s expected to become available, too bad ATI is slow… real slow.

Nvidia had their stuff sorted during the beta iirc.