Open-Source Radeon not working after upgrade from 13.1 to 13.2

Hello altogether,

since today, my computer only boots without GPU-acelleration. A few days ago I have upgraded the system from 13.1 (kernel 3.13) to 13.2 (kernel 3.16) and have already worked with it for two days (one boot, one wakeup from suspend to RAM) without any problems. I have an AMD Radeon IGP (Radeon 6320) and use the open-source driver “radeon” for serveral releases without big trouble so far.

My xorg.conf seems okay:

Section "Device"
  Identifier "Default Device"

  Driver "radeon"
#  ## Required magic for radeon/radeonhd drivers; output name
#  ## (here: "DVI-0") can be figured out via 'xrandr -q'
  Option "monitor-DVI-0" "Default Monitor"


lspci says:

/sbin/lspci -nnk | grep VGA -A2
00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Wrestler [Radeon HD 6320] [1002:9806]
        Subsystem: ASUSTeK Computer Inc. Device [1043:84e3]
        Kernel driver in use: radeon

But glxinfo outputs:

name of display: :1
Error: couldn't find RGB GLX visual or fbconfig

I can confirm this by the pixeliness of KDE and the immediate crash of GNOME.

dmesg tells me:

dmesg | egrep 'drm|radeon'
    5.612547] [drm] Initialized drm 1.1.0 20060810
    5.631705] [drm] radeon kernel modesetting enabled.
    5.773167] fb: switching to radeondrmfb from VESA VGA
    5.777281] [drm] initializing kernel modesetting (PALM 0x1002:0x9806 0x1043:0x84E3).
    5.777318] [drm] register mmio base: 0xFEB00000
    5.777324] [drm] register mmio size: 262144
    5.777484] radeon 0000:00:01.0: VRAM: 384M 0x0000000000000000 - 0x0000000017FFFFFF (384M used)
    5.777496] radeon 0000:00:01.0: GTT: 1024M 0x0000000018000000 - 0x0000000057FFFFFF
    5.777504] [drm] Detected VRAM RAM=384M, BAR=256M
    5.777510] [drm] RAM width 32bits DDR
    5.781000] [drm] radeon: 384M of VRAM memory ready
    5.781008] [drm] radeon: 1024M of GTT memory ready.
    5.781043] [drm] Loading PALM Microcode
    5.781153] [drm] Internal thermal controller without fan control
    5.781262] [drm] Found smc ucode version: 0x00010601
    5.781367] [drm] radeon: dpm initialized
    5.781633] [drm] GART: num cpu pages 262144, num gpu pages 262144
    5.812084] [drm] PCIE GART of 1024M enabled (table at 0x0000000000273000).
    5.812317] radeon 0000:00:01.0: WB enabled
    5.812329] radeon 0000:00:01.0: fence driver on ring 0 use gpu addr 0x0000000018000c00 and cpu addr 0xffff880036c16c00
    5.812339] radeon 0000:00:01.0: fence driver on ring 3 use gpu addr 0x0000000018000c0c and cpu addr 0xffff880036c16c0c
    5.813181] radeon 0000:00:01.0: fence driver on ring 5 use gpu addr 0x0000000000072118 and cpu addr 0xffffc90010ab2118
    5.813193] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
    5.813199] [drm] Driver supports precise vblank timestamp query.
    5.813239] radeon 0000:00:01.0: irq 43 for MSI/MSI-X
    5.813264] radeon 0000:00:01.0: radeon: using MSI.
    5.813307] [drm] radeon: irq initialized.
    5.830687] [drm] ring test on 0 succeeded in 1 usecs
    5.830712] [drm] ring test on 3 succeeded in 2 usecs
    5.889697] [drm] ring test on 5 succeeded in 1 usecs
    5.909746] [drm] UVD initialized successfully.
    5.910586] [drm] ib test on ring 0 succeeded in 0 usecs
    5.910641] [drm] ib test on ring 3 succeeded in 0 usecs
    5.931553] [drm] ib test on ring 5 succeeded
    6.004944] [drm] radeon atom DIG backlight initialized
    6.004980] [drm] Radeon Display Connectors
    6.004991] [drm] Connector 0:
    6.005001] [drm]   LVDS-1
    6.005010] [drm]   HPD1
    6.005022] [drm]   DDC: 0x6430 0x6430 0x6434 0x6434 0x6438 0x6438 0x643c 0x643c
    6.005035] [drm]   Encoders:
    6.005044] [drm]     LCD1: INTERNAL_UNIPHY
    6.005054] [drm] Connector 1:
    6.005061] [drm]   HDMI-A-1
    6.005064] [drm]   HPD2
    6.005070] [drm]   DDC: 0x6440 0x6440 0x6444 0x6444 0x6448 0x6448 0x644c 0x644c
    6.005076] [drm]   Encoders:
    6.005080] [drm]     DFP1: INTERNAL_UNIPHY
    6.005084] [drm] Connector 2:
    6.005088] [drm]   VGA-1
    6.005094] [drm]   DDC: 0x64d8 0x64d8 0x64dc 0x64dc 0x64e0 0x64e0 0x64e4 0x64e4
    6.005100] [drm]   Encoders:
    6.005104] [drm]     CRT1: INTERNAL_KLDSCP_DAC1
    6.446664] [drm] fb mappable at 0xC0477000
    6.446681] [drm] vram apper at 0xC0000000
    6.446686] [drm] size 7299072
    6.446691] [drm] fb depth is 24
    6.446695] [drm]    pitch is 6912
    6.446963] fbcon: radeondrmfb (fb0) is primary device
    7.010071] radeon 0000:00:01.0: fb0: radeondrmfb frame buffer device
    7.010074] radeon 0000:00:01.0: registered panic notifier
    7.014215] [drm] Initialized radeon 2.39.0 20080528 for 0000:00:01.0 on minor 0

I did a few reboots but it doesn’t help.
Now I’m not sure about any further steps to solve my problem, so any help is very warmly welcomed!

Greetings and Thank You!

Is this /etc/X11/xorg.conf, or is this /etc/X11/xorg.conf.d/50-device.conf?
You should not need an xorg.conf, and particularly not with this content. radeon is used anyway if possible.
Remove it, even if it is /etc/X11/xorg.conf.d/50-device.conf.

But glxinfo outputs:

name of display: :1
Error: couldn't find RGB GLX visual or fbconfig

I can confirm this by the pixeliness of KDE and the immediate crash of GNOME.

This means that OpenGL support is not working.
But why is it saying “name of display: :1”? Is this a second X session?
Can you please post the file /var/log/Xorg.0.log?

And please post the output of:

getfacl /dev/dri/*

Thank you so much wolfi for your quick response! Your tip helped me to solve the problem. OpenGL is running again as it used to!

Xorg.0.log notified an error that my gcclib was too old. I actually have downgraded gcc due to some old source codes that don’t compile with newer gcc versions. I never had problems installing older versions in parallel before.

Right now I reinstalled the standard libggc_s1 with zypper and it told me:

File /lib64/
  from install of
  conflicts with file from package

Something has gone wrong yesterday.

But it’s okay. My old sources compile against the newer libgcc with the old gcc without problem (I just tried out).

So thank you again! happy