Oops: Umount failed :-(

Hello, i have a serious message when i reboot my serveur…


The server is opensuse11.1 uptodate
hda1 /boot (xfs)
hda2 swap
hda3 / (xfs)

i have notice this problem on 5 servers ( 4 servers SLES10SP2 and 1 opensuse11.1)

What do you think about this problem?

Do you think XFS is the problem??

The picture shows SLES 10SP2, not OpenSUSE 11.1. You do know that SLES/D != OpenSUSE?

Anyway it looks like some process would not die by the time / needed to be umounted. Maybe it was ZMD (arrgh, I still get nightmares about it). Anyway it’s not a serious issue.

Hello thanks for your answer…
I notice this problem on 5 of my servers…
4 servers SLES10SP2
1 server opensuse11.1

So it is a recurent problem whith suse but why…?

It is not ZMD because y have tested it, after a zmd shutdown and it is the same problem…

And Opensuse11.1 has no zmd… and the problem is présent…

is it possible to know the process which block the umount?

Dunno, maybe you could modify the shutdown script to run ps or better still lsof if the umount failed to show you what’s still running. I don’t know if running ps or lsof will work when you have already started a shutdown and libraries are inaccessible. Maybe you need a statically linked version of ps or lsof. Boy it’s getting complicated.

How can you nevertheless have the ‘failed’ about ZMD busy in the openSUSE system?

I have tried to stop ZMD before the shutdown, and the problem is again here

No idea for my problem?

I have found the guilty of my problem…
It is the new version of the package util-linux …
The problem was appeared after an update of this package
(this package contain a lot af commands as mount, umount, etc…)

When i downgrade this package the problem disapear…

Same problem in openSUSE-11.2 Milestone-6 just after installation! (root is xfs partition)( while root was ext4 - same problem was too)

Will try observe util-linux…

I get this error message also with openSUSE 11.2 and newer Linux kernels. (The text is displayed in green colour now.)
Would you like to resolve bug reports like the following?