Oops, I updated Nvidia driver to 304.43 --> how to revert back?

Hi,

I have made the big mistake to update a working driver to the latest version. As usual, i can no longer select the desired resolutions. So I went about to copy-paste a Xorg.conf that I keep around for this situation. However, with this version of the driver, Xorg.conf seems to be ignored.
Is there a way to revert back to the old driver? The version is no longer available in Yast. . . .

Thanks for the help,
regards,
Stephan

OS: Linux 3.1.10-1.16-desktop x86_64
System: openSUSE 12.1 (x86_64)
KDE: 4.7.2 (4.7.2) “release 5”

btw, my Xorg.conf looks like this:

nvidia-settings: X configuration file generated by nvidia-settings

nvidia-settings: version 260.19.36 (buildmeister@swio-display-x86-rhel47-01.nvidia.com) Tue Jan 18 17:15:10 PST 2011

Section “ServerLayout”
Identifier “Layout0”
Screen 0 “Screen0” 0 0
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”
Option “Xinerama” “0”
EndSection

Section “Files”
EndSection

Section “InputDevice”

# generated from default
Identifier     "Mouse0"
Driver         "mouse"
Option         "Protocol" "auto"
Option         "Device" "/dev/psaux"
Option         "Emulate3Buttons" "no"
Option         "ZAxisMapping" "4 5"

EndSection

Section “InputDevice”

# generated from default
Identifier     "Keyboard0"
Driver         "kbd"

EndSection

Section “Monitor”

# HorizSync source: edid, VertRefresh source: edid
Identifier     "Monitor0"
VendorName     "Unknown"
ModelName      "Philips 240S"
HorizSync       24.0 - 94.0
VertRefresh     48.0 - 85.0
# 1920x1080 58.94 Hz (CVT) hsync: 66.02 kHz; pclk: 169.00 MHz
Modeline         "1920x1080_59.00"  169.00  1920 2040 2240 2560  1080 1083 1088 1120 -hsync +vsync
Option         "DPMS"
#Option         "ModeDebug" "TRUE"

EndSection

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “GeForce 8600 GTS”
EndSection

Section “Screen”

Removed Option “metamodes” “DFP-0: 1920x1080 +0+0, DFP-1: 1920x1080 +0+0”

Identifier     "Screen0"
Device         "Device0"
Monitor        "Monitor0"
DefaultDepth    24
Option         "TwinView" "1"
Option         "TwinViewXineramaInfoOrder" "DFP-0"
Option         "metamodes" "DFP-0: 1920x1200_60 +0+0, DFP-1: NULL; DFP-0: 1920x1080_59.00 +0+0, DFP-1: 1920x1080 +0+0; "
SubSection     "Display"
    Modes      "1920x1080_59.00"
Depth       24
EndSubSection

EndSection

Do you still have the older version driver on your PC? How did you install the nVIDIA driver?

You can find the previous driver versions here:

32 bit: ftp://download.nvidia.com/XFree86/Linux-x86/304.37/

64 bit: ftp://download.nvidia.com/XFree86/Linux-x86_64/304.37/

Installing the hard way: Installing the nVIDIA Video Driver the Hard Way - Blogs - openSUSE Forums

Thank You,

Hi James,
Thanks for the reply. I managed to go back to the old drivers, unfortunately the resolution problem persists. Time to finally (after many years of agony) give up on dual screen in Linux.

regards,
Stephan

So I am using a dual screen setup and it is still working for me. Mostly I use it to place some media in one screen while working in another, but it does seem to work OK. I am using the latest nVIDIA video driver, installed the hard way and I use the nvidia-settings file to setup Twinview as I require. I am just not sure what is causing your issue.

Thank You,