Ontbrekende MLT module: glaxnimate vereist om Lottie-animaties te maken

Hi everybody
I did a total fresh install of Tumble KDE.
Installed Kdenlive including FreiOr MLT dvgrab etc
When configuring kdenlive with the wizard it is complaining that a MLT module is not installed: Glaxnimate
It is needed to configure kdenlive with the videocard (nvidia quadro) so it seems.
I can skip this part but when I want to render the renderjob crashes.
glaxnimate itself is nowhere to be found in the repos of opensuse nor in pacman
I have some serious editing to do the coming weeks, who can help me getting kdenlive to work?


Kdenlive states it uses MLT 7.9 whereas 7.10 of MLT is installed from the repo
Could that be the problem?

See this old thread, the solution is at the bottom of the post.

Thnx for taking the time!
It didn´t work for me
It is just one missing module, not the whole lot.
Thanks again


I installed kdenlive in tumbleweed the same result as yours.
Searching around I found out there is no glaxnimate for opensuse.
If you want you can use snap, AppImage or flatpack to install the glaxnimate
and and in the kdenlive settings-environment-default apps-animation editing you have to enter the path to glaxnimate executable.

I am not using snap, AppImage or flatpack. I haven’t tried it. You might want to try this procedure and post back the result.

Thnx for your reply/ideas
I really appreciate this

Snap AppImage or Flatpack. I am not familiar with either of them. I want to think about it whether I install it. But it sure looks like a solution.
This weekend there’s more time to spend digging into it.

Thnx a lot for thinking with me.


Did some digging.
Glaxnimate is not in pacman so I installed it as appimage or as a snap package. I linked it and i can open it as an external piece of software to create or edit animations.
That part was very welcome. On the other hand, Glaxnimate is still not a module of MLT.
Saw that the MLT release notes mentioned that MLT 7.10 updated its module for glaxnimate to 0.5.1 in early november.

The configuration wizard for the videocard is still asking for the MLT glaxnimate module

As for how to solve the problem
I do not know where to find help
Is it here? or Kde forums?

I have possibly another option: as my tumbleweed kdenlive still worked before the time I swapped the ssd for a bigger one and installed all fresh, I could go for a tumbleweed dvd from october 2022 and again have a fresh install
Does anybody know where to find tumbleweed dvd’s from october 2022?


Did you check if kdenlive is available in appimage. If it is then you can try installing it also and see if it will work for you.

Never thought about this, it is a brilliant idea and yes, there is an app image so I wil carry on with that one untill everything is reapaired upstream.
Thnx for all your help


Please post back if it will work or not, you might help others who are having this kind of issue in the future.

Did some testing in the past days.
Downloaded the appimage and everything looked very promising
The hardware accelleration in the config wizard looked as it should, I was able to load my screenlayouts. Audio is fine.
Al was fine until the moment I wanted to render
On exact the same places in various projects as the repo installed kdenlive rendering crashes.

So Appimage is really good but not yet perfect or it is and appimage has the same problem as the repo installed one.


Thanks for posting back.