only using vesa with 640x860 resolution

Recently I installed opensuse11.2 with kde4.3 on a Dell Dimension 2400 - the installation was successful and everything worked fine.

However, at some point I decided to experiment and attempted to enable Desktop Effects in the KDE Desktop Configuration Panel; this immediately made the system unresponsive. I manually shut it down with the power button. When I turned it on again, it got stuck at the green suse splash with the gecko and loading bar (the bar was about halfway). I tried again, this time in failsafe - this worked fine, and I attempted to disable desktop effects. However, the panel wouldn’t let me the checkbox was greyed out - in fact, when I returned to the defaults the system kept them enabled told me that the effects don’t work on my hardware (I more or less gathered that).

At this point, I looked around the forums a bit. I found a similar problem, which suggested I boot into runlevel 3, su, and then run

sax2 -r -m 0=vesa

I did, and accepted the options it presented me (it didn’t work when I tried to change them around to the monitor I actually have with the resolution it actually has - something about this graphics card not supporting them).

However, this didn’t actually fix my problem (namely, not loading the desktop). So, I booted again in fail safe mode and simply created a new user.

Finally, I could log on again without being forced to use fail safe mode. However, now I had a terrible resolution (640 x 860). Running Sax2 as the new user doesn’t fix the problem - it won’t accept the monitor resolution I actually have. I assume this has something to with having accepted Sax2’s earlier proposition, which was in vesa. Now, I tried to run the command again (both in runlevel 3 and in konsole as my new user) like so:

sax2 -r -m 0=intel

however, this simply makes my screen go blank.


Things have changed in 11.2 with not using xorg.conf anymore have a
read of post #4 here;

It may just be the issue of how to disable the dektop effects (if they
are still enabled).

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 2 days 9:02, 2 users, load average: 0.22, 0.17, 0.11
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

hmm… thanks malcolm.

(afaik) I have an intel integrated graphics card on this so I don’t see how using the =radeon/radeonhd/ati would help… I’ll give a try though.
Note I did use the =intel without positive results…

but thank you… at least now I understand more about the situation.

No, ignore the ati stuff, it was the information about xorg.conf not
being used any more :slight_smile: so removing the xorg.conf file and restarting X
( eg init 3; init 5 && exit ) should be enough.

I think the issue is that kwin effects are still enabled and once they
are disabled all should be ok again.

I’m not a KDE4 user, so unsure how to do/confirm this from the command
line… :frowning:

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 2 days 9:56, 2 users, load average: 0.22, 0.11, 0.09
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

Ah! Thank you very much, that solved the problem.

I logged on as my new user in safe mode, copied it to my desktop and then sudo rm’ed xorg.conf from the terminal. The original user is still unusable, but there were only a couple of files on that anyway… I’ll just copy those over.

Thank you again!

You might want to check here

Intel® Embedded Design Center

to see if your chip will support 3d drivers. I don’t believe the “intel” driver that ships with Suse fully supports 3D. Most likely the reason the desktop effects don’t work.

Compiz and kwin run fine on this netbook with a 945GM. Not a speed
daemon but the defaults seem to function with no noticeable affect on
system performance.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.2 (i586) Kernel
up 10:49, 1 user, load average: 0.03, 0.01, 0.00
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME