Only tty after zypper dup (Nvidia GPU, kernel 6.5.2-1.1 and 6.5.3-1.1)

Usually reinstalling the kernel has fixed this in the past, but no dice this time. Also don’t have an older kernel available, only 6.5.2-1.1 and 6.5.3-1.1 (after trying the latest kernel I think, the one before those seemed to work fine). Tried my luck with zypper search -s kernel-default, but that command is pretty useless since there are never any older packages.

startplasma-wayland yields error about not being able to determine $DISPLAY, and kdeinit5_shutdown exiting with code 255.

Could you give some hardware information (as preformatted text) with
inxi -Fxz

Can you find any relevant (error)messages in journalctl -b or in /var/log/boot.log?

I do have the same issue here. It looks like the last supported kernel of the nvidia kmp packages is 6.4. I fear, you will have to stick with kernel version 6.4.* for now.
You should probably desinstall all kernels with 6.5.something to make the graphics mode work again.

Thats not right. If you have the kmp packages installed, the kernel modules get build automatically on the user machine.

I have 3 different Nvidia generations running with the proprietary drivers with kernel 6.5. x series fine.

And most importantly, you don‘t uninstall kernels. You simply boot from a prior working one and make it default until you solved your problems…or use a snapshot if you use btrfs…

Well … thats what I thought. However, please have a look at
rpm -q --changelog nvidia-gfxG04-kmp-default
You will find, that all previous kernels got their update. Then, in
rpm -ql nvidia-gfxG04-kmp-default
you will find prebuilt kernel modules for 6.4.x (weak update modules, that work for all 6.4.x kernels)
Finally, after the installation, try to find the actual kernel module:
find /lib/modules -name nvidia.ko
and the 6.5 modules will be missing. I even tried to build the modules from the delivered src, however that bails out with errors, and I am quite sure that other people will know more about how to fix this than me.

If you install the latest nvidia driver “the hard way” it is up to date and works with k6.5.x and 6.6-rc.
Oh, and is not hard.

well … done that some time ago with some previous version. It is not hard to install, but it is hard to get rid of the variant that is not controlled by rpm. Took me quite some time to make the packaged version work afterwards.

I’ve done it the hard way for years and never felt the need to return to the packaged version. The latest driver packages work well with dkms and only need the hard way when an updated driver is issued.
Also if a new kernel needs a patch for the driver you can either produce one yourself or find someone else’s work online.

Well, the problem is gone now.

I searched for Nvidia packages yesterday using zypper and installed gfxG04 (let’s not pretend I knew what I was doing, that was the -1-number package I saw and went with). That gave me desktop upon reboot, but a very primitive display (resolution was around 10xx) which showed up as “None-1” or something in display settings.

Anyway, today I installed G05 (think I first installed gfxG05 which resulted in no change before finding some other highest-number-good package) to try and debug things again. Anyway, I rebooted into Windows first because I noticed “Failed to load nvidia-drm module” when installing it and wondered whether my GPU was working at all (despite not having an APU). Everything was fine in Windows, so I updated the driver there (maybe that made a difference, no idea, it’s on a separate physical drive though), then finally booted into openSUSE where everything was working again.

I’m curious what the “hard way” is btw. I’m using proprietary drivers from Nvidia repository.

1 Like