only failsafe 11.3 after installing ubuntu10.04

new bought cheap PC, with pleasure installed 11.3 and then I tried to install Ubuntu 10.04… on grub startmenu see I now only SuSE Failsafe. I want my trusted SuSE ro seen, can not find an handy solution on forums. I’m absolutely beginner, help please

The installation of Ubuntu has also installed its own grub boot menu. You need to open a terminal and then type ‘su -’ to become root first. Then provide the output of

fdisk -l
cat /boot/grub/menu.lst

If you’re doing this from Ubuntu, then you’ll need to use ‘sudo’ command instead eg:

sudo fdisk -l

With the correct info, it is possible to carefully enter the openSUSE entry back into /boot/grun/menu.lst again.

zoran@zoran-ubuntu:~$ sudo fdisk -l
[sudo] password for zoran:

Schijf /dev/sda: 500.1 GB, 500107862016 bytes
255 koppen, 63 sectoren/spoor, 60801 cilinders
Eenheid = cilinders van 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Schijf-ID: 0x1549f232

Apparaat Opstart Begin Einde Blokken ID Systeem
/dev/sda1 1 13 102400 7 HPFS/NTFS
Partitie 1 eindigt niet op een cilindergrens.
/dev/sda2 14 3200 25599577+ 83 Linux
/dev/sda3 59283 60802 12201984 7 HPFS/NTFS
/dev/sda4 * 3201 59283 450479105 f W95 Uitgeb. (LBA)
/dev/sda5 29866 30128 2110464 82 Linux wisselgeheugen
/dev/sda6 30129 32740 20972544 83 Linux
/dev/sda7 32740 59283 213206016 83 Linux
/dev/sda8 3201 9279 48827392 83 Linux
/dev/sda9 9279 29865 165357568 83 Linux

Partitietabel-items liggen niet in schijfvolgorde.

zoran@zoran-ubuntu:~$ cat /boot/grub/menu.lst

menu.lst - See: grub(8), info grub, update-grub(8)

grub-install(8), grub-floppy(8),

grub-md5-crypt, /usr/share/doc/grub

and /usr/share/doc/grub-legacy-doc/.

default num

Set the default entry to the entry number NUM. Numbering starts from 0, and

the entry number 0 is the default if the command is not used.

You can specify ‘saved’ instead of a number. In this case, the default entry

is the entry saved with the command ‘savedefault’.

WARNING: If you are using dmraid do not use ‘savedefault’ or your

array will desync and will not let you boot your system.

default 0

timeout sec

Set a timeout, in SEC seconds, before automatically booting the default entry

(normally the first entry defined).

timeout 3


Hides the menu by default (press ESC to see the menu)


Pretty colours

#color cyan/blue white/blue

password ‘–md5’] passwd

If used in the first section of a menu file, disable all interactive editing

control (menu entry editor and command-line) and entries protected by the

command ‘lock’

e.g. password topsecret

password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/

password topsecret


title Windows 95/98/NT/2000

root (hd0,0)


chainloader +1

title Linux

root (hd0,1)

kernel /vmlinuz root=/dev/hda2 ro

Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST


lines between the AUTOMAGIC KERNELS LIST markers will be modified

by the debian update-grub script except for the default options below

DO NOT UNCOMMENT THEM, Just edit them to your needs

## Start Default Options

default kernel options

default kernel options for automagic boot options

If you want special options for specific kernels use kopt_x_y_z

where x.y.z is kernel version. Minor versions can be omitted.

e.g. kopt=root=/dev/hda1 ro

kopt_2_6_8=root=/dev/hdc1 ro

kopt_2_6_8_2_686=root=/dev/hdc2 ro

kopt=root=UUID=7fd9a491-5294-44c3-ae1a-6bdd4fef7310 ro

default grub root device

e.g. groot=(hd0,0)


should update-grub create alternative automagic boot options

e.g. alternative=true



should update-grub lock alternative automagic boot options

e.g. lockalternative=true



additional options to use with the default boot option, but not with the


e.g. defoptions=vga=791 resume=/dev/hda5

defoptions=quiet splash

should update-grub lock old automagic boot options

e.g. lockold=false



Xen hypervisor options to use with the default Xen boot option


Xen Linux kernel options to use with the default Xen boot option


altoption boot targets option

multiple altoptions lines are allowed

e.g. altoptions=(extra menu suffix) extra boot options

altoptions=(recovery) single

altoptions=(recovery mode) single

controls how many kernels should be put into the menu.lst

only counts the first occurence of a kernel, not the

alternative kernel options

e.g. howmany=all



specify if running in Xen domU or have grub detect automatically

update-grub will ignore non-xen kernels when running in domU and vice versa

e.g. indomU=detect




should update-grub create memtest86 boot option

e.g. memtest86=true



should update-grub adjust the value of the default booted system

can be true or false


should update-grub add savedefault to the default options

can be true or false


## End Default Options

title Ubuntu 10.04.1 LTS, kernel 2.6.32-24-generic
uuid 7fd9a491-5294-44c3-ae1a-6bdd4fef7310
kernel /boot/vmlinuz-2.6.32-24-generic root=UUID=7fd9a491-5294-44c3-ae1a-6bdd4fef7310 ro quiet splash
initrd /boot/initrd.img-2.6.32-24-generic

title Ubuntu 10.04.1 LTS, kernel 2.6.32-24-generic (recovery mode)
uuid 7fd9a491-5294-44c3-ae1a-6bdd4fef7310
kernel /boot/vmlinuz-2.6.32-24-generic root=UUID=7fd9a491-5294-44c3-ae1a-6bdd4fef7310 ro single
initrd /boot/initrd.img-2.6.32-24-generic

title Ubuntu 10.04.1 LTS, kernel 2.6.32-21-generic
uuid 7fd9a491-5294-44c3-ae1a-6bdd4fef7310
kernel /boot/vmlinuz-2.6.32-21-generic root=UUID=7fd9a491-5294-44c3-ae1a-6bdd4fef7310 ro quiet splash
initrd /boot/initrd.img-2.6.32-21-generic

title Ubuntu 10.04.1 LTS, kernel 2.6.32-21-generic (recovery mode)
uuid 7fd9a491-5294-44c3-ae1a-6bdd4fef7310
kernel /boot/vmlinuz-2.6.32-21-generic root=UUID=7fd9a491-5294-44c3-ae1a-6bdd4fef7310 ro single
initrd /boot/initrd.img-2.6.32-21-generic

title Chainload into GRUB 2
root 7fd9a491-5294-44c3-ae1a-6bdd4fef7310
kernel /boot/grub/core.img

title Ubuntu 10.04.1 LTS, memtest86+
uuid 7fd9a491-5294-44c3-ae1a-6bdd4fef7310
kernel /boot/memtest86+.bin


Try running this in Ub*

sudo update-grub

then reboot

Thank you very much caf, so simple and it works.

Dude - what can I say :wink:
Live and learn.
Happy to hear it worked. Keep it in mind too, for whenever there are kernel updates to your additional Linux OS’s.

I have to learn so much, i made just now again mistake with deleting C partition, I thought that I knew the way in Yast. Now can only root login on SuSE… I do not need windows anymore, this is fascinating. I can also skip kernel update on Ubuntu, my doughter likes Gnome. I go to search some solutions. Thanks again, greetings

You should not login as root. Ever.

Sounds to me like you should start again. Delete everything and re-partition the drive nicely.

You can install testdisk from suse and run it. get your c partition but you need to have windows repair kit to fix the startup, later update grub with ubuntu cd.

I had also error message about partitions on Ubuntu, it is disapeard after SuSE installation. Can I try testdisk as root? In case of fail testdisk, what to install first, Ubuntu of SuSE, of I can perform only SuSE installation? It is pleasantly that I am able to come on SuSE /home and copy all files.
Thanks very much, this forum is great

First run testdisk from suse if you can boot susse. If you are on Buntu you need to install alien and convert testdisk rpm to .deb. You need to do a google or check Ryan (Ubuntugeek’s website). Testdisk will certainly recover your partitions. Please check ‘testdisk’ videos on YouTube. I am in Mint right now and dont have bookmarks here.

Here is testdisk install from Ubuntu How to: Recover data with testdisk! - Ubuntu Forums

Here is testdisk tutorial

great tool testdisc, thanks for advice but I had still could not login as user. HDD repartioned and shiny new installation, it works brilliant. Thanks for effort, but it was my fault, partitioning was wrong with poorly planned actions. I hope that this case can help other people in the community.