only chrome resolves server

this is odd, really odd. When I start up everything looks normal and I only noticed this when I tried to use yast for package installation from the repositories… so google chrome works fine and connects to the intronet but all of my other browsers and other apps like skype and empathy etc. basically anything that is supposed to resolve servers is not doing so… I’m using 11.4 XFCE 4.8.0. any help would be greatly appreciated…

How do you connect? Wireless, wired? Using Networkmanager or “ifup”?

Please post output of

su -c ifconfig
(enter rootpassword)

ok so… problem solved… I read through a similar problem thread and just changed the nameserver in resol…config file to (google’s dns) everything seems ok!

Soooooooo it seems that Google’s chrome just might have knowledge of Google’s name servers built in – bit naughty of them to be so presumptuous (if the inference is correct).

I was just about to bring up that point… you beat me to it. lol

Interesting…if it’s true. Now I’m going to open up Chrome first instead of pinging out of the network.