Only able to print one (first) page of a document

I’ve configured a Xerox WorkCenter 7345 which is attached to the network. I can print to it from any application as well as via lp. The problem is that it only prints the first page of any job. I can tell it to print a specific page but if I do either All or within a range it will only do the first page.

I’m using the drivers provided by Xerox.

Anyone know how to troubleshoot this?

  1. Have a look at /var/log/cups/error_log for any possible errors.

  2. What happens if you try to print a multi-page document ‘filename’ with something like

lpr -o page-ranges=1-4 filename

  1. Check if ~/.cups/lpoptions exists. (For reference, I have an empty file). Yours may have an option like ‘page-ranges=1’ or similar present. Which desktop are you using BTW?

/var/log/cups/error_log doesn’t indicate any errors. At least, none that could be found by searching for “error” or “Error”.

I ran the command you suggested but used ‘page-ranges=1-2’ since the one file I have to test against is only two pages long. I still only got the first page.

~/.cups/lpoptions exists but is empty.

KDE 4.3.1

What happens if you print a multi-page document to file? When you open the .ps file, does it display all pages ok?

Printing to file (.ps) results in a two pages. If I open in in Okular the first page appears to be cut off at the bottom and the second page only has an Okular icon on it.

Something definitely strange with your printing options, but not sure where the relevant config file might be. I can’t replicate this, as this is working for me. Try generating a multipage text document. Then check whether you get the same problems with printing to printer and file?

Might also be worth searching and/or posting on CUPS forum:

Forums - CUPS

I haven’t had a chance to look at this further. One thing I’m going to attempt to do though is to configure the printer on my laptop and see if I have the same issues.

OK, just tried with a multi-page plain text file and still only got the first page.

I’m having the same problem with a networked Xerox WorkCentre Pro123.

I can print multiple pages to it from 11.1 and 10.2 and 10.3. The new 11.2 box prints only the first page of any request.

/var/log/cups/error_log shows nothing wrong.

contains only my default printer choice.

Submitting from the printer’s web interface works for multiple pages, but is clunky.

I checked the CUPS forums, and the one similar problem I saw posted had no replies.


Yesterday I wrote that it worked on 11.1-- I was wrong. My 11.1 user never prints, and so doesn’t care that he only gets the first page.

I did discover that there is an error on the printer side: all jobs from 11.* boxes get code 116-703.

Google tells me this:

116-703 An error occurred during PostScript processing. Either confirm the print data, or open spool settings on the details tab in the print driver to disable bi-directional

I know the postscript is fine, because I can print it through the printer’s web interface. Any ideas how to disable bi-directional communication in the print driver? I’m not finding anything like that in Yast.

Is this printer connected thru the parallel port of the remote printer?

If so, I’d check in the printer computer BIOS if the LPT port is set to bi-directional.

If it is USB I suppose this can only be set thru the driver.

Just for completeness, I’ll post that I finally decided the drivers supplied both by the distribution and by Xerox simply do not work for my printer model. (My model is a 123, Xerox supplies drivers for 128 and 133.) I’ve got a support request in to Xerox, but I haven’t heard anything.

I set it up as a network printer with a “Raw Queue” driver, and now it prints all the pages of the job, although you can’t access special options like duplex.