online Update not working, internet works

Hi there!
I’m very new to Linux.
I tried to set up my internet connection using the network manager and not the classic iufp method. At first it just didn’t work but after deactivating IPv6 I got it working: firefox can connect to the internet.
What troubles me is the online update with Update Applet. The following message pops up: “Error: packageKit error repo-not-available: Failed to download /media from
Also when I go to Yast->Software->Software repositories I get the msg: Systemadministration is blocked by PID 2459 (/usr/sbin/packagekitd). Close the application and try again.
Using the command “sudo zypper refresh” creates the same message.
I spent already hours trying to figure out the problem without luck.
Any help is appreciated! Thank you.

Right click the updater icon, click Settings, uncheck ‘Start updater on login’, OK. Now right click icon again and choose quit. After this you can start the software installer and the repo manager.

What happens is this: the updater applet puts a lock on the package database.

If you’re on a desktop machine, change networking from Networkmanager to ifup. That way you will also have a working connection when not logged in on the desktop.

thank you for your reply.
I closed the applet and tried to refresh the zypper (I guess it has something to do with the repos from what I’ve googled). I get the following error:
Metadates of repository “openSUSE-11.2-Non-Oss” are being fetched ]/media.l/media could not being fetched from Index of /distribution/11.2/repo/non-oss
I tried to translate this from german to english…so they may not be the exact words.
Could something prevent the connection to the repos?
Still using the Networkmanager because I’m using only desktop.

Ok, I tried to configure my network settings with ifup now.

Global options: IPv6 deactivated, Name of DHCP client: - , hostname: AUTO, standard route changed by DHCP.

hostname changed by DHCP: yes, write hostname in /etc/hosts: yes, Nameserver 1:


activated on systemstart, dynamic IP (DHCP), activate control for non-root user…:yes, MTU: - , Firewall: external zone

I hope thats correct. Internet is working but not the repositories! I can find additional repos but can’t install them. Updates not working either. What could be wrong?