online update is breking Grub! Frustration to the MAX!

I am just a newbie but I have done this 4/5 times and it appears that when I go to YaST and click on the online update for SUSE 11 Beta 1 it breaks grub every time at reboot with a Grub error 22 showing. I have read and tried all the forum post on fixing a Grub22 but nothing has worked, maybe because I am a newbie, and I wind up reinstalling and trying again. It would be nice to know what the file is that is breaking Grub…has anyone identified this file yet? Please feel free to email me Thanks - Johnny

My system is as follows:

OS Name Microsoft Windows XP Professional
Version 5.1.2600 Service Pack 3 Build 2600
OS Manufacturer Microsoft Corporation
System Name KD5LWU
System Manufacturer Dell Computer Corporation
System Model Dimension 3000
System Type X86-based PC
Processor x86 Family 15 Model 4 Stepping 1 GenuineIntel ~2394 Mhz
BIOS Version/Date Dell Computer Corporation A02, 11/8/2004
SMBIOS Version 2.3
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume1
Locale United States
Hardware Abstraction Layer Version = “5.1.2600.5512 (xpsp.080413-2111)”
User Name
Time Zone Mountain Daylight Time
Total Physical Memory 768.00 MB
Available Physical Memory 36.25 MB
Total Virtual Memory 2.00 GB
Available Virtual Memory 1.96 GB
Page File Space 1.83 GB
Page File C:\pagefile.sys

DISPLAY:
Name Intel(R) 82865G Graphics Controller
PNP Device ID PCI\VEN_8086&DEV_2572&SUBSYS_019D1028&REV_02\3&172E68DD&0&10
Adapter Type Intel(R) 82865G Graphics Controller, Intel Corporation compatible
Adapter Description Intel(R) 82865G Graphics Controller
Adapter RAM 96.00 MB (100,663,296 bytes)
Installed Drivers ialmrnt5.dll
Driver Version 6.14.10.4396
INF File oem6.inf (i865G section)
Color Planes 1
Color Table Entries 4294967296
Resolution 1024 x 768 x 60 hertz
Bits/Pixel 32

Sorry forgot the HDD…I am installing SUSE on this external USB drive Drive E:

Partition Disk #1, Partition #0
Partition Size 2.01 GB (2,154,991,104 bytes)
Partition Starting Offset 32,256 bytes
Partition Disk #1, Partition #1
Partition Size 20.00 GB (21,476,206,080 bytes)
Partition Starting Offset 2,155,023,360 bytes
Partition Disk #1, Partition #2
Partition Size 276.08 GB (296,439,091,200 bytes)
Partition Starting Offset 23,631,229,440 bytes

kd5lwu@beyondbb.com

Have a read here
GRUB Boot Multiboot openSUSE Windows (2000, XP, Vista) using the Grub bootloader.

You say you are using beta??
Don’t expect it to work perfectly. Check the bug reports to see if this is an issue.

from swerdna’s page: Error 22: No such Partition: Is the entry pointing to a real partition. This can happen after you alter your partitions

Thanks yes I am aware of Beta issues but what I was asking is if anyone had figured out which update was breaking Grub. - Johnny

Okay have everything resolved and running smoothly now - thanks for the help guys it set me on the right track. Downloaded all the OpenSUSE docs for future reference. At last done with Windows XP as I moved all my important files from XP to SUSE cannot think of a reason to use XP any more! I did go back and look at XP this morning and coming from SUSE 11 is like going from XP to Windows 3.1! I love my SUSE!!! Now to get a Battery backup so when we have electrical outage or brown out (small town here) my system won’t crash. Needless to say I am one happy camper. - Johnny Cortez, Colorado Ham Radio KD5LWU