ongoing font issues with gnome and opensuse 11.4

I’m still having an issue with fonts on my Dell E6400 Laptop running opensuse 11.4 and Gnome 2.32.1. The best way to describe it is that it looks like at about 3 places on the screen, there is an invisible horizontal line running right/left, about 2 inches from the top and from the bottom of the display and then about in the middle. When a line of text is “under” this line, the font is corrupted so that it looks broken. If I scroll the text up or down, the “broken” line of text will move above or below the problem area and display perfectly. The next line of text below it will then appear broken.

It isn’t related to any specific application. Firefox, LibraOffice, they all do the same thing.

I have adjusted font DPI, changed default fonts, messed with subpixel hinting, and even installed the freefonts package. No luck. I know its not the actual monitor because this is a dual-boot laptop and in Windows, the display is perfect.

I’ve got another older Dell laptop, a D610, with opensuse 11.4 and Gnome 2.32.1 and it doesn’t have the problem. So this leads me to believe it is something with the video driver on this particular machine. But I can’t figure out in Gnome how to update the video driver.

Any ideas?

Hi, i had the same problem with my dell netbooks, first i tried installing “font smoothing” from here SubpixelHinting - openSUSE Community Wiki
It helped a little, but dint fix it completely.
Then i discovered that the thing that fixed it 100% (for me at least), was to disable desktop effects (compiz).
Im no linux expert, but i think this problem is related to compiz.

I sugest you try installing the font smoothing package from the link i gave you, and if that doestn help, go to the desktop effects control dialog, un-check the “Enable desktop effects” checkbox, and restart.

Hope this helps.


That fixed it!!! Well, the “unchecking ‘enable desktop effects’” fixed it. I’d already tried installing the subpixelhinting while following the instructions from another thread. But as soon as I unchecked the effects box and restarted, all the font issues went away. All my fonts are crystal clear regardless of which application I’m using.

Thank you! I can stop pulling my hair out now.

Read this if You want to update your video driver.
openSUSE Graphic Card Practical Theory Guide for Users

Best regards,

Glad to hear!
As an added bonus for disabling compiz, you will most likely notice extended battery duration, cooler operation of your laptop, better flash playback, and better overall system performance. :slight_smile:
I hate compiz!, ibe had issues and/or small “Glitches” with it ever since i started using linux.

Usually the “Glitches” are caused by faulty graphics drivers not compiz so in my opinion the desktop effects are actually a great test for one’s GPU drivers. The extended battery duration is not that much bigger with desktop effects disabled and it does not look as cool :slight_smile:

Best regards,

yep, im shure its the drivers, but the point is… no compiz = no glitches :slight_smile:

Battery time for me +26 minutes without compiz, but ibe only tested it on netbooks with limited hardware, maybe in laptops theres not much diference.

Or with properly working graphics drivers :slight_smile: they actually are very important for power saving and the Linux support for almost all GPU chips leaves a lot to be desired in my opinion.

Best regards,