One user has no sound in browser videos

I recently upgraded from 12.3 to 13.1, mostly the system is working but there are a few nagging details, not the least of which is a sound issue.

I normally log in to my account ‘jbenetti’ and this account has been configured for my web development work and any other task such as email web browsing office applications etc.

Since the upgrade my primary account has not been able to generate sound from videos in a browser. It doesn’t matter what browser, firefox, chrome and konquerer have been tried with the same result.

I then logged in to my root account and I was able to hear videos, so this suggests some permission problems.

Then I created a blank test account, this user is also able to hear the videos, when I check the groups and permissions for the new user this user was only added to group ‘users’.

My default account was added to several other groups because of past problems, particularly with firewire and arduino (neither of these issues were solved to my satisfaction BTW), so I removed my primary account from all other groups but still no sound.

So my primary account can:

  • play music using amarok
  • has the startup sound (after a tweak) and has warnings and other user sounds
  • can play the video with no sound in a browser
  • can play a video WITH SOUND using Kaffiene and an mp4 on the hard drive

I am assuming that there is a file in my home directory that is messing up the ability to play videos properly in a browser, any help on where to look would be much appreciated.

There are other issues but for now this one is important to me.
Overall I think opensuse13.1 is pretty awesome but I am getting tapped out on the amount of tweaking to make it a functional system.

Any help would be greatly appreciated,