On shutdown HDD always busy (doesn't umount)

Hi there.
Have a problem here. Since installed OpenSuSE 11.1 i noticed that when booting it was almost always checking integrity of my hdd. Then i noticed that when shutdowning when says often “/home (for example or /) is in use, can’t be unmounted. Waiting that is safe to shutdown” (and to see fuse)
Is shutdown logged somewhere?

Where could it be the problem ??

The warning is like
unmount /home
Unmount failed …

Could it have anything to do with using kde 4.1.3 and having the folder /home in the desktop ?

It shouldn’t.

Is your /home NFS mounted by a client system? Someone else reported similar (but with corruption) through that, in a thread in Soapbox or Chit chat section (Axeia).

Hi there. Thanks for answering.

My /home is local, not mounted in NFS
here is my fstab (now the nfs share isn’t in use) created by Yast

/dev/disk/by-id/scsi-SATA_ST3320613AS_9SZ01RFA-part1 / ext3 noatime,data=writeback,acl,user_xattr,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0 1 1
/dev/disk/by-id/scsi-SATA_ST3320613AS_9SZ01RFA-part3 /dados ext3 data=writeback,acl 1 2
/dev/disk/by-id/scsi-SATA_ST3320613AS_9SZ01RFA-part7 swap swap defaults 0 0
/dev/disk/by-id/scsi-SATA_ST3320613AS_9SZ01RFA-part5 /home ext3 data=writeback,acl 1 2
/dev/disk/by-id/scsi-SATA_ST3320613AS_9SZ01RFA-part6 /windows/ ntfs-3g users,gid=users,fmask=133,dmask=022,rw,locale=pt_PT.UTF-8 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0 /Pastos nfs rsize=8192,wsize=8192,noatime,user,auto 0 0***/ /Asus nfs rsize=8192,wsize=8192,noatime,user,auto 0 0

devpts /dev/pts devpts mode=0620,gid=5 0 0

But think i find the problem. I use kde 4.1.3 and the plasma widget “folder view”, with /home. Removing it from Desktop gives me a normal shutdown… but is useful to me :confused:

Guess i was wrong. Disabled folder view widget from plasma. Next shutdown it made a normal shutdown, next one it gave same error…
What could it be that looks / home and / ?
is there a way to slow down shutdown to see it has time to shutdown ?

here the message in shutdown

Shutting down service (localfs) network
Shutting down DBUS daemon
Unmounting File Systems
/dev/sda6 unmounted
umount: /home: device is busy
(In some cases usefulinfo about processes that use the device is found by lsof(0) ou fuser(1)
/dev/sda3 unmounted
ops: umount failed :frowning:
mount: / : device is busy
mount: /home: device is busy
extra sync…
… hope now it’s ok to reboot
Stopping udevd

Sending all processes the TERM signal…

Have you used online update, there were some fixes to low-level daemons.

Can you please post your current /etc/fstab file, if you are up to date, and see the problem? The /home/**** is something I’d suspect, unless it’s actually a bad word the forum software messes up.

I changed my folder view from /home to /Documents and the shutdown problem went away.

i’ve system up-to-date (forgot to say its 64bit)
Removed folderview and still same issue with /

I had a similar issue with my system (x86)

My “workaround” (until the patch came out - and I remember seeing a patch about unmount) was to switch to runlevel 3 (init 3) and then shutdown / reboot from a console after loging as root. Annoying indeed but I avoided data corruption.

The patch:

aaa_base - Fix shutdown not unmounting the home-partition cleanly

On some system configurations the home-partition may not umount properly at shutdown.
466484 (bugzilla) : bug number 466484

patched version should be: aaa_base 11.1-10007.12.1 + sysvinit 2.86-186.15.1.

Check if these are installed on your system (at least on my x86 system + KDE 4.2 are installed and I do not have this problem any more).

You could also try and re-install this patch. If it still does not work maybe the fix does not work for your system.

Cheers and good luck.

seems it is solved thanks.
Also, the problem with /home was because a symb link to a nfs share in /home/user/folder, and nfs share was broken (server down).