On "Repair Installed System": "Kernel panic"...

I recently bought a new computer, brand new parts, assembled by a friend that I trust. I brought it home, installed OpenSUSE 11.2, and tweaked it over the course of last week, then I experienced a problem, with one of the programs causing a segmentation fault, and crashing.

Another symptom that began at that time was that attempts to move large amounts of data between computers (ftp via router), with no other activity, the computer would simply freeze up – the image on the screen would literally freeze-frame at the time that it occurred. The keyboard froze as well, making any attmempts to restart using ctrl-alt-delete, or to switch to the other computer (via a shared input/output and monitor switch) impossible.

I felt that the best remedy would be to use “Repair Installed System”. However, when I attempted this, I hit another glitch. After it loaded the kernel, it entered VGA mode with details of progress – which wasn’t much. It ends suddenly, with a Call Trace (final entry being “child_rip+0xa/0x20”), and the machine and keyboard lock up again, much like above.

Within these details, these lines seem to be the important indicators of what’s going on:

ata1: softreset failed (device not ready)
VFS: Cannot open root device “<NULL>” or unknown-block(3,1)
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(3,1)

My root partition is located at sda1, so I attempted again using the Boot Option “root=0802” and experienced the same lockup, with a little more information:

EXT3-fs: sda2: couldn’t mount because of unsupported optional features (240).
EXT2-fs: sda2: couldn’t mount because of unsupported optional features (240).
No filesystem could mount root, tried: ext3 ext2 iso9660
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(8,2)

I have two identical hard drives: ATA WDC WD6400AACS-0 – both are formatted with the ext4 filesystem, which the installer is NOT attempting. Using the Boot Options of “rootfstype=ext4” and “root=0802” result in the same error.

I AM ABLE to “Boot from Hard Disk”, so the kernel I currently have installed and configured appears to be uncorrupted. But if I attempt any other selection from the OpenSUSE Installer provided by the DVD – Installation, Repair, Rescue, Check Installation Media, Firmware or Memory Test – it loads the kernel from the DVD, and locks up as above. I attempted to reinstall the OS entirely, for example, but couldn’t get past the Kernel Panic.

I have experienced this problem twice. The first time came at the end of last week. At one point, I unplugged the sdb drive, attempted a few things but went nowhere, then replugged sdb. I’m not sure what it did, but it fixed something. I was able to successfully open Repair Installed System as I wanted, but those attempts failed. After another hour, I chose to attempt a complete reinstallation, which was finally possible, and it was successful. (My apologies for not being more detailed about these processes – I didn’t think to log what I was doing at the time, and I’d rather describe them vaguely than remember incorrect details…)

I ran with this new installation for a few days, I am again encountering segmentation faults, and the machine locking up soon thereafter.

If it matters my motherboard is an ASUS M4A79T Deluxe.

Thanks for hearing me out. I looked for my problem in the forums, but found nothing quite like this. If it’s there and I missed it, please point me in the right direction! Also, if more information is needed about my hardware, please let me know…


read to bottom (because i change my mind halfway down)

kernel panic is very often caused by bad RAM…suggest you boot from
openSUSE install media and select “Memory Test” from the first green
screen…it will take a while to do a complete check…most folks say
run it overnight, at least…

oh, and while you have the disk in, if you didn’t already then check
the install media also…a bad install could also cause memory
clashes and freezes…do this: http://tinyurl.com/yajm2aq

WAIT: reading your note again i think it kinda likely you have a bad
install disk or some flaky hardware or setup (too many things
messed up)…check the install disk first: if you burned the disk
yourself, did you md5sum check the iso BEFORE burning the disk? and
THEN check the disk…see details of how to do all of that here:

the install disk MUST be 100% ok (Garbage in, garbage out.)

and go though the motherboard’s manual and select the correct bios
setup for your system…

then, you can come back and see if anyone else has some specific
advice based on your logs…

and, let us know how you get on…


What video there is a nasty bug that corrupts the FS with certain ATI cards and kernel combinations. Happens when you run a OpenGL program. :\

Thanks for the response, palladium. I’ll attempt your suggestions a bit later and see what happens.

An update on the machine’s behaviour when it’s completely booted: On Friday, I set up an FTP between machines, of a large data transfer, and then went to bed – started the process at 1100. I woke up that evening and checked, and the computer (and screen) were frozen at around 1300 hours. So, after 2 hours of file transfer, it locked up. (The file was, in fact, the ISO image of either SUSE 11.1 or 11.2 – 5 GB. And it choked on it.)

Today, I did a similar thing, leaving it alone after a reboot. No file transfers this time, but I had it read and convert an audio stream into an MP3, and download a handful of others automatically. When I got up this evening, all was well – there were no glitches.

So, I’m fairly certain that the FTP is bogging down and choking out my computer. I’ve no idea if this is related to the bad fs stuff.

Also, the program that was crashing with Segmentation Fault earlier today was Seamonkey. After the reboot, it was functioning normally without crashing. Friday, the seg-fault offender was Audacity – now that I think about it, I don’t believe I tried to restart it after rebooting. I guess I assumed it was a bad install of that program. It works fine now, after the complete system installation.

Again, I’ll try your suggestions, and get back to you with what I find.

Thanks again!


Suggestion; FTP may use temp files on the root partition if you run out of space on root it can lock things up.

Thank you for your input as well, gogalthorp! To answer your first question (I was in a rush earlier and ran out of time to respond), I’m using a BFG Tech BFGE98512GTXPOCE GeForce 9800 GTX+ – an NVIDIA card. So I think I’m outside the possibility of an ATI corruption, but I suppose anything remains possible.

As for FTP, I did not know that, re: temp files. I’ll test that a bit later, and see if that is indeed the case. My Root partition is only 20 Gb or so, and I can easily see it cramping up with temp files, especially if they aren’t cleaned up properly after an FTP session.

As y’all can imagine, I’m really really hoping this is “just” a bad kernel or disk or installation, and NOT my hardware!

Thanks again, and I’ll keep you posted!


I’ll tackle these one item at a time, rather than lumping them all into one massive reply…

Sometimes, I forget the value of owning multiple computers – while the machine in question is balking at letting me use the DVD’s functions, I realized I have two others that aren’t “broken”! So, dropping the disk into my laptop, I ran Check Install Media, and the result is: “Checksum wrong. This CD-ROM is broken.”

I have another copy, burned on the same computer, with the same method… I’ll double-check that as well. I imagine I’ll get the same result, as it also game me the same fits on the new machine. At the same time, I’ll burn another copy at a slower rate or something, unless another method is advised…


I was wrong about the Memory Test portion of the disks posing the same problem. It works. Unfortunately, it didn’t take long at all to determine something is well and truly borked. over 1200 errors detected, before I gave up and rebooted. I can only assume this was a test of the first RAM stick. Which sucks, because it might be difficult to remove without having to shift the CPU cooling fan apparatus. :confused:

And I’m sure it didn’t get anywhere near testing even the second stick.

More as I learn about it…


Wish I could just edit my most recent post to update – I hate inflating my post count by replying to myself. :stuck_out_tongue:

I pulled the number one stick and started the tests with only two – and kicked up more errors. I’ve reinstalled the first (in the #3 slot, easiest access), and am going to run a full-on test overnight.


No need to continue if it is kicking errors. If all modules are bad there is a possibility you have incorrectly speced memory. Be sure that the memory is correct for the motherboard. Also since this is a brand new mother board it is possible that something is not right on it. Also check the BIOS to see if something is being over clocked all should be default at least at first.

It is a wonder that computers run at all rotfl!

Wildcat4Ever wrote:
> I’ll burn another copy at a slower rate or something, unless
> another method is advised…

i already gave you a link to “Download Help” which tells you how to
check the md5sum of the iso BEFORE you burn the disk…and, gives
hints on how to burn a good disk…

if you are downloading and burning on a Redmond system you can expect
it to not go very smoothly, unfortunately…i can’t imagine why…


Wildcat4Ever wrote:
> and am going to run a full-on test overnight.

you don’t have to run over night…one error is enough, 1200 is more
than enough to know you got something BAD wrong…

i guess the memory you installed is not the correct type/speed for
the motherboard…or the board itself is borked (cracked maybe)…or
the BIOS is not setup right for the CPU/RAM mix…or the board is not
properly grounded…or a chip got zapped with static electricity
during install, and then suddenly failed…or the moon is blue…

or . . .


That could always be possible… I ordered these by reading the specs to my friend, who wasn’t exactly looking over my shoulder. I may have read something incorrectly…

I’ll look these over as well.


You did give me that link, and I had forgotten about it. Thank you for the reminder!

I used K3B and the Sony DVD-R on the new machine to burn the instllation DVDs – I installed 11.0 first, from the disk I’ve been using for several months now, and then installed over that.

This machine was built a couple of weeks after the “blue moon” occurred, so I think we can rule that out. ^.^;

Here are the specs…

ASUS M4A79T Deluxe AM3 DDR3 AMD 790FX ATX AMD Motherboard - Retail
Newegg.com - ASUS M4A79T Deluxe AM3 DDR3 AMD 790FX ATX AMD Motherboard - AMD Motherboards

Number of Memory Slots 4×240pin
Memory Standard DDR3 1600(O.C.)/1333/1066
Maximum Memory Supported 16GB
Channel Supported Dual Channel

Patriot 2GB 240-Pin DDR3 SDRAM DDR3 1333 (PC3 10600) Desktop Memory Model PSD32G13332 - Retail
Newegg.com - Patriot 2GB 240-Pin DDR3 SDRAM DDR3 1333 (PC3 10600) Desktop Memory Model PSD32G13332 - Desktop Memory

Brand Patriot
Model PSD32G13332
Type 240-Pin DDR3 SDRAM
Tech Spec
Capacity 2GB
Speed DDR3 1333 (PC3 10600)
Cas Latency 9
Voltage 1.5V
Buffered/Registered Unbuffered
Features 2 Rank Doouble-sided module
7.8US Refresh Interval (8192 CYCLES/64MS)
Auto and self refresh capability
PCB height: 1181(mil)
Serial Presence-Detect (SPD)
100% Tested
RoHS Compliant

They look to me to be compatible – unless there’s something in here that I’m overlooking.

I’ll contact the friend that helped me build it, see if he might put in a house call to look things over, maybe even test the RAM sticks. I’ll also do some homework and learn what I can about this motherboard + SuSE 11.2 + the BIOS.


Check the mother board manual and be sure you are pugging the memory in right. Some times you need to put it in the 1 and 3rd slots if you only have 2 sticks. Also it may require pared ie you can have 1-2-4 sticks can not have 3. But that all should be in the manual that came with the board.

First an update about my RAM – my pulling and juggling the memory sticks has apparently knocked something into place. I went ahead with that extended memtest86 last night, and after 8 hours, it had registered far fewer errors than the thousand-plus I reported the other day. And they were all located at only two memory addresses, in the entire scan. With luck, only one of the sticks is corrupt – I’ll still get it checked out.

Second, tinkering around with the hardware (either removing and replacing the hard drives’ power and data cables, or swapping the memory around, or both) also seems to have dislodged the “Kernel Panic” error, allowing my DVD’s installation, repair, and diagnostice tools to function properly now. I actually experienced this the first time around, though I didn’t want to actually say as much because I wasn’t sure if my jiggering around inside had done that trick. The Repair System function still digs up ntfs errors and invisible (my term) hard drives, but that might be the bad ISO image.

This is what I pull from the manual – are you saying pretty much the same thing?

SS - Single-sided DS - Double-sided
DIMM support:

  • A*: Supports one module inserted in any slot as single-channel memory configuration
  • B*: Supports one pair of modules inserted into either the the orange slots or the black slots as one pair of dual-channel memory configuration.
  • C*: Supports four modules inserted into both the orange and black slots as two pairs of dual-channel memory configuration.

I think I dealt with a similar limitation with my first computer, several years ago – it does sound vaguely familiar. In fact, I now recall talking to customer support, about how the machine I had only supported a maximum of 32Mb of RAM – yet I was somehow getting 48Mb. But I digress…

I am in fact using three identical 2Gb RAM sticks, and my computer seems to be seeing and utilizing all of the 6Gb available.

Now, there’s no guarantee that the Kernel Panic attack won’t return, so I’m not about to say this is resolved just yet. I’ll be back with more info, undoubtedly. :slight_smile:


Wildcat4Ever wrote:
> extended memtest86 last night, and after 8 hours, it had registered
> far fewer errors

one is too many. you are wasting your time and our time until you have
reliable RAM

> but that might be the bad ISO image.

you are wasting your time and our time until you have a 100% perfect
install disk…

> I am in fact using three identical 2Gb RAM sticks, and my computer
> seems to be seeing and utilizing all of the 6Gb available.

but, with errors, so it is not usable…you must follow the
directions of the board maker…

> Now, there’s no guarantee that the Kernel Panic attack won’t return, so
> I’m not about to say this is resolved just yet. I’ll be back with more
> info, undoubtedly. :slight_smile:

please don’t post more until you have good install media and no memory


You can not have 3 sticks they must be single or paired. Try it with only 2 in the correct slots either black or orange. Dual channel must matched sets. Because of small timing differences a random selection of sticks will probably not work right. Always buy dual channel as a paired set. The manufacture has paired them to so the timings are the same.

Don’t even try to install until your hardware is correct!!

It turns out that only one of the RAM sticks is bad – the other two scored zero errors. So, I’m good on that front.

I finally got an ISO image with a matching checksum, and reinstalled entirely. No “kernel panics” or any other hiccups this time around!

And, as for the original problem that started all of this, this post elsewhere describes pretty much the same problem, and offers at least a diagnosis: Kernel OOPS stops copying - openSUSE Forums

palladium, gogalthorp, thank you very much for your help! I’m not very confident when it comes to messing with the guts of my computer, but y’all talked me through a rough spot, and I really do appreciate it! :slight_smile:


Well your motherboard does not support 3 sticks only 1, 2 or 4. So maybe that third sick is alright but maybe it is bad.:stuck_out_tongue:

If you tested them 1 at a time then you would know for sure.

also if you decide to add more memory you need to add two matched sticks.