(on localhost.localdomain) shows up on titlebars

hello i recently installed tumbleweed with XFCE and im not sure if this happened at installing the system or later when i installed programs but for some reason some title bars show the normal title and (on localhost.localdomain) next to it . i used other distros with xfce and installed the same programs but never saw this problem before.

this is what the file manager looks like on the music folder.

https://i.imgur.com/rKrE39P.png

the same thing happens on smplayer and thunderbird and some others but not on mpv or keepass and some other programs.
can anybody tell me why this happens or how to turn it off?

thank you for your help.

Show output of

hostname
cat /etc/hosts
ip a

for hostname:

localhost.localdomain

cat /etc/hosts:

#
# hosts         This file describes a number of hostname-to-address
#               mappings for the TCP/IP subsystem.  It is mostly
#               used at boot time, when no name servers are running.
#               On small systems, this file can be used instead of a
#               "named" name server.
# Syntax:
#    
# IP-Address  Full-Qualified-Hostname  Short-Hostname
#

127.0.0.1    localhost

# special IPv6 addresses
::1             localhost ipv6-localhost ipv6-loopback

fe00::0         ipv6-localnet

ff00::0         ipv6-mcastprefix
ff02::1         ipv6-allnodes
ff02::2         ipv6-allrouters
ff02::3         ipv6-allhosts

ip a:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: p4p1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether 64:00:6a:2f:d3:90 brd ff:ff:ff:ff:ff:ff
    altname enp2s0
3: wlp0s20u1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 50:3e:aa:86:77:d5 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.13/24 brd 192.168.1.255 scope global dynamic noprefixroute wlp0s20u1
       valid_lft 56776sec preferred_lft 56776sec
    inet6 fe80::523e:aaff:fe86:77d5/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

just “sudo vi /etc/hostname” and change the name to what you want to see then reboot to set the new name.

change the vi to whatever text editor you like if you don’t like vi - like pluma, nano, leafpad …

I am not sure that this is good advice. IMHO one should not change the hostname of IP address 127.0.01 (if that is what you want to say).

I think the best way to change the hostname of a system is to use YaST > System > Network Settings. There is a Tab Hostname/DNS. YaST will change in several places where you might forget one or two.

But, I am not even sure this is what the OP asked. I admit that his question is a bit confusing. I am not sure if he does not want to see the host and domain name at all (regardless of what they are), or that he wants a different host/domain name.

This because he violated a basic way of specifying a problem, which should include:

  • what did you do (he explained that he started a file manager, but we do not know which one);
  • what did you get (that is shown very well with the image);
  • what did you expect to get (that is missing complete, we only know he does not like what he sees).

sorry i got your pm but i dont see how to edit my own post, maybe i cant or i just dont see the button.

i wasn’t clear but what i mean is i don’t want to see the hostname on the file manager or video players i want to hide it from those title bars.
the file manager is thunar,what i expected to see when opening that or smplayer is just the name of the folder or video and not the hostname at all.

thank you for trying to explain.

To change hostname, see:

hostnamectl --help

or

man hostnamectl

Here:

linux64:/home/stephan # hostnamectl
   Static hostname: linux64.linux
Transient hostname: linux64
         Icon name: computer-desktop
           Chassis: desktop
        Machine ID: b254f0bd85f5454490c75709752f1fd0
           Boot ID: bf403d9b47d04b3c8f670a7371b72b94
  Operating System: openSUSE Leap 15.3
       CPE OS Name: cpe:/o:opensuse:leap:15.3
            Kernel: Linux 5.13.2-lp153.5.g89416ca-default
      Architecture: x86-64

That the hostname is shown in the titlebar depends maybe also on the running desktop theme?
So change it and see?

All much clearer now. Part of the confusion is that you call a “problem”, what many may see as a feature. And thus they did not understand what you were after.

I assume it is a feature of the applications or the desktop (or a combination). As I do not use the ones you use, I assume we have to hope that other XFCE users tune in here.

And indeed, you can not edit your posts after about 5 minutes (just for repairing a typo you see direct after posting). We do not want people to change their posts because that can lead to confusing threads where people answer to things that are changed/removed.

ok i tried changing the theme to one that comes with opensuse xfce and restarting the computer and now the hostname it shows is diferent but still there.

https://imgur.com/Pbrexsk.png

https://imgur.com/RwmzOll.png

i did this again in case it helps.

nume@DESKTOP-KMA4K1J-2:~> hostname
DESKTOP-KMA4K1J-2.home
nume@DESKTOP-KMA4K1J-2:~> cat /etc/hosts
#
# hosts         This file describes a number of hostname-to-address
#               mappings for the TCP/IP subsystem.  It is mostly
#               used at boot time, when no name servers are running.
#               On small systems, this file can be used instead of a
#               "named" name server.
# Syntax:
#    
# IP-Address  Full-Qualified-Hostname  Short-Hostname
#

127.0.0.1    localhost

# special IPv6 addresses
::1             localhost ipv6-localhost ipv6-loopback

fe00::0         ipv6-localnet

ff00::0         ipv6-mcastprefix
ff02::1         ipv6-allnodes
ff02::2         ipv6-allrouters
ff02::3         ipv6-allhosts

nume@DESKTOP-KMA4K1J-2:~> ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: p4p1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether 64:00:6a:2f:d3:90 brd ff:ff:ff:ff:ff:ff
    altname enp2s0
3: wlp0s20u1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 50:3e:aa:86:77:d5 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.13/24 brd 192.168.1.255 scope global dynamic noprefixroute wlp0s20u1
       valid_lft 86201sec preferred_lft 86201sec
    inet6 fe80::523e:aaff:fe86:77d5/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever


i tried hostnamectl and it says its a transient hostname so thats why it changed i guess.

nume@DESKTOP-KMA4K1J-2:~> hostnamectl
   Static hostname: n/a                                
Transient hostname: DESKTOP-KMA4K1J-2.home
         Icon name: computer-desktop
           Chassis: desktop
        Machine ID: 6724e2a7bc164f7a9e87ff666c89a3ae
           Boot ID: 4ad375e12a7e47bc97ae31457f802efd
  Operating System: openSUSE Tumbleweed                
       CPE OS Name: cpe:/o:opensuse:tumbleweed:20210712
            Kernel: Linux 5.13.0-1-default
      Architecture: x86-64
   Hardware Vendor: Dell Inc.
    Hardware Model: OptiPlex 3020

i haven’t done anything of what you suggested to change the hostname it changed by itself but i don’t care what the hostname is, i just would rather not see it everywhere.

if i change it by using yast or the commands you suggested will that make it a static hostname?
could this be related to using a usb wifi adapter?

I have in fact no idea what is the idea behind posting a hostname there. Somebody must have thought it being information that a user might need (which not in your case, but when one has windows open on different systems, it sounds as useful)).

Initially it used the hostname that belongs to the IP address 127.0.0.1 (my guess).
Now it uses the hostname and domainname that are apparently given by default to your system at installation (the person doing the installation accepting these defaults).

I can only say again that it is something done by the application (giving the whole title string to the Windows Manager). Where it could be that the application does this through the desktop (which might explain why some applications do, those that are tightly bound to XFCE and others don’t).

/etc/hostname is not for localhost - it is what you want to call your computer.

I call mine VM1 - it does not change 127.0.0.1 from localhost.

llrainey@VM1:~> cat /etc/hostname
VM1
llrainey@VM1:~> head -13 /etc/hosts
#
# hosts         This file describes a number of hostname-to-address
#               mappings for the TCP/IP subsystem.  It is mostly
#               used at boot time, when no name servers are running.
#               On small systems, this file can be used instead of a
#               "named" name server.
# Syntax:
#    
# IP-Address  Full-Qualified-Hostname  Short-Hostname
#

127.0.0.1       localhost
192.168.20.1    router
llrainey@VM1:~> 

PS real Linux and Unix people do not use crutches like Yet Another System Tool. We use command line the commands that YAST run in background - we make the computer work for us.
Unix since 1974 and Linux since 1994. I too had to write code for AT&T sysadm for users that could not figure out ksh commands and man pages.

I do not agree. As long as you still know how to do it with commands and editors, a system management tool may be handy. It only becomes tricky when you use the tool and in fact do not know what you are doing.

And the audience here does not consist only of ageing Unix system managers, but also people where a system management tool like YaST (I would say specially YaST, because for many it is one of the main reasons to use openSUSE) will mean the difference between using a Linux distribution, or stay with MS Windows.

ok well i may not be a real linux person but with some help i found the answer and solved the problem, looks like it was a theme problem, for some reason one of the themes i installed manually(downloading the theme using a browser and installing the files) changed the window manager theme too but the themes i installed with yast and the default themes didnt change the window manager theme back by themselves. which is also why those title bars looked so bad.

bottom-line :the solution was changing the window manager theme manually and logging out, that solved the hostname problem and the ugly title-bars.

https://imgur.com/QPsR1XR.png

thank you folks for your help, specially “Sauerland” who gave me the hint that it may be a theme problem. have a nice day.

sorry but its back i spoke too soon i was wrong about the themes… it seems like it shows up when i boot up the system but goes away if i log out of the user and log back into it.

seems like a small problem but maybe il try resintalling with cinamon or mate.

I hope you do not mean that you want to reinstall the whole system just to get those other DEs. Just Install them.

going a little offtopic now, but i read somewhere either in this forum or the support wiki that installing the deskop on the system its fine but wont be the same as installing it as the first and only desktop you install when installing the system, something about using the default settings for the desktop and not the opensuse settings or something.

maybe this is false but yeah that was my plan. thanks.

X Window allows users to run applications on remote hosts. When I used this feature I appreciated the title bar displaying the host associated with the window.

I hinted already at this in the same post. even the same sentence, you quote (but you quote it without that remark, I have no idea why):

… but when one has windows open on different systems, it sounds as useful]

As there is no logical difference in adding DE Patterns already during installation, or installing them later I am missing the point. Each Pattern is only a bunch of software Packages that is installed from the OSS repo.

I am sharing my personal experience.

I have in fact no idea what is the idea behind posting a hostname there. Somebody must have thought it being information that a user might need (which not in your case, but when one has windows open on different systems, it sounds as useful)).

vs.

X Window allows users to run applications on remote hosts. When I used this feature I appreciated the title bar displaying the host associated with the window.

Your statement is a guess (‘somebody must have thought …’). I actually used the feature and confirmed it to be convenient. This makes a difference, in my opinion.