On Acer Aspire ES 17: Bootloader doesn't start

Hi!

I just have installed Leap 42.2 on my Acer Aspire ES 17 (parallel with the delivered win10). Everything worked well during installation. But now when restarted, the bootloader (grub2) does’t start and windows boots directly. Even if I start with the installation dvd and select “boot from hdd” it does’t work. Then I get the error message “no such device: /efi/boot/fallback.efi”.

I tried some things allready:

  • Installation with activated and with deactivated secure boot mode (the same behaviour)
  • Changed the boot order (putting the hdd at higher priority than windows)
  • Deactivated Windows fast boot.
  • In my bios setup there is a possibility to “select a uefi file as trusted for executing”. There I could see, that in hdd0/efi/boot/ there was only one .efi-file called bootx64.efi. So the error message (see above) was right. But there was a folder hdd0/efi/opensuse/ with several .efi-files. I selected them all as trusted.

What else could I do to get the bootloader working? Please answer for a Linux-USER not a professional… Thanks!

I’m sorry that I’m not able to provide an fdisc output as requested in similar threads (because I have no access to the linux system…). Instead I made a screenshot of the partitions in windows. Here the Link to this image: https://www.dropbox.com/s/vk9asafxqyx7tzj/paritionen.jpg?dl=0

Did you install Opensuse in Uefi Mode?
With the dvd insert go to Uefi Bios. In “Bootorder” you can find now 2 new fields. Opensuse and Opensuse-Uefi.
Choose Opensuse-Uefi and boot.
The partition table you posted shows no Microsoft reserved Partition (MSR).
What happend to it? You deleted it?

Yes, you are not the first one complaining about it; I am not sure where this file is supposed to come from, but as far as I can tell openSUSE installer does not add it.

  • In my bios setup there is a possibility to “select a uefi file as trusted for executing”. There I could see, that in hdd0/efi/boot/ there was only one .efi-file called bootx64.efi. So the error message (see above) was right. But there was a folder hdd0/efi/opensuse/ with several .efi-files. I selected them all as trusted.

Do you have option to boot from file? In this case try choosing \EFI\opensue\shim.efi or \EFI\opensue\grubx64.efi (in that order of preference).

What else could I do to get the bootloader working?

Unfortunately some vendors are known to ignore everything except Windows, so firmware effectively ignores any boot option except the one that points to Windows. There is no 100% clean way to fix it. I remember just recently similar thread, and I think it also mentioned Acer. There are several users here with very good EFI experience, hopefully someone may chime in.

Hi testi55,
Thank you for answering.

I 've just tried this out. There are no adittional items called Opensuse oder Opensuse-Uefi in the bootorder. But I discovered another interesting possibility: I can enable or disable a “boot menu” reachable via F12. Perhaps this could make it possible to boot a efi-file directly. The problem is: I do not know how to reach this boot-menue. When I press F12 instead of F2 while starting windows ist booted again…

No, I am workin in it at the moment.

I had losts of problems getting opensuse working with an acer p/c (with windows 10). This was due to the way that acer’s uefi settings work. I was able to get things working with help from this forum and would be happy to post instructions.

As I first step you might wish to try a more straightforward solution that worked for me with a HP system - with similar type of problems. That was to install a uefi manager programme on windows 10 from:

http://www.easyuefi.com/index-us.html

This is quite easy to use and let me set opensuse as the default bootloader. Then whenever I needed to boot into windows 10 I could just use the opensuse bootloader (grub2) to select windows from the menu.