Oldcpu's way of installing ATI proprietary driver

Hi OldCpu,
after futile search on a post about your way to install ATI driver downloaded from ATI site, I kindly ask you to post full procedure of how you do installation your way.

Thanks.

If you also want my way to install amd radeon drivers read this http://forums.opensuse.org/greek/i-i-i-i/i-i-i-iui-i-i-i-i-i-i-i-i-i-i-i-i-isi-i-i-ioei-i-i-i-i/i-iui-i-i-i-i-i-i-i-documentation/453443-i-i-i-i-i-i-i-i-i-i-i-drivers-isi-i-i-izi-i-i-i-i-i-i-izi-nvidia-amd-ati-radeon.html

I have also written other guides about opensuse fuctions if you want, read this http://forums.opensuse.org/greek/i-i-i-i/i-i-i-iui-i-i-i-i-i-i-i-i-i-i-i-i-isi-i-i-ioei-i-i-i-i/i-iui-i-i-i-i-i-i-i-documentation/455009-iyi-i-i-iyi-i-i-isi-i-i-i-iyi-i-i-i.html

Which openSUSE version do you have in mind here ? I do not believe the proprietary ATI driver has been produced yet for openSUSE-11.4.

There are many methods on the web explaining how to do this ‘the hardway’ (which is not hard). I confess I don’t follow directly any of them. I found what works for me and I stick with it.

I am just now testing the proprietary Catalyst-11.2 fglrx driver custom built when booting to a 64-bit openSUSE-11.4 KDE liveCD with Radeon HD3450 graphics (and 4GB RAM on motherboard). One needs LOTS and LOTS of RAM to do this, as when booting from the liveCD one is running out of RAM and not using the hard drive. I described my experience here:
OpenSuse 11.4 startup problems

… but I typically do MORE steps than that, so I would NOT call that a ‘full procedure’. I will not post in this thread a ‘full procedure’ unless I know EXACTLY what openSUSE version, how you installed, it , … etc … ie I need to more about your setup.

I have 11.4, installed today. Yes, no driver for it yet.
But I saw your way of doing things which I liked, but cannot find that post.

in that post, you made init 3, created RPM of downloaded .BIN with some parameters, and installed that RPM in 2 line code or something like it.
This is what I am after.

I am weary of doing just ./ati…bin

What I really seek in this post is NOT “how to install ati driver”. I want “how would Oldcpu install ati driver downloaded from ATI site”

If it was that short then do not trust it, as I was probably assuming a level of knowledge where one MUST have 1st done some previous steps.

I was a bit timid and concerned the first few times I tried it some years back. The first time I tried (some years back) it worked. The second time (after a kernel update) it failed because of my lack of understanding and mistakes, and I actually rolled back the kernel (as opposed to fixing my mistake). Of course I could not fix my mistake because I did not realize at that time I made a mistake.

The third time, I succeeded because I realized my mistake - which was a very silly mistake.

The mistake I made (when installing ‘the hardway (which is not hard)’) was if one already has the proprietary fglrx driver installed, and then one breaks the driver by updating the kernel, BEFORE one can re-install the driver one must first REMOVE the old driver.

So I always first type:

rpm -qa '*fglrx*' 

to look for any instances of the proprietary driver already installed. If I find it installed already (say it is called “fglrx64_7_5_0_SUSE113” ) then I remove it with

rpm -e fglrx64_7_5_0_SUSE113 

at which point in time there is NO fglrx driver installed on the hard drive. And of course, BEFORE I attempt to build the driver I first MUST have either gcc and make installed, or have selected in yast the “base-developement” pattern. And of course have installed kernel-source and kernel-syms that match my PCs kernel. Many new users who are simply following instructions blindly, try to skip steps ( duhhhhh ) and forget to keep the version of kernel-source and kernel-syms at the same version as their kernel. Bad mistake. One MUST keep the version of kernel-source and kernel-syms the same as one’s kernel if one wishes to build a driver. That’s not only incredibly important, it actually makes sense ! :slight_smile:

Is your 11.4 a 32-bit or a 64-bit ? Are you running with the “radeon” driver or the “radeonhd” driver ? Do you need to use ‘nomodeset’ to boot ? What is your exact hardware?

well, yes, I made same mistakes before, not removing old driver and all hell broke loose. I got smarter with failures :slight_smile:
However, last time I did on 11.3 it broke my system (./ati…bin) and I didnt have fglrx, and of course, having kernel-source and other stuff is mandatory.

I am now on 11.4 64bit, Mobility Radeon HD 56xx, using default Radeon driver (3d works). Also I dont use nomodeset, just plain and simple installed 11.4 which worked right out of the box.

I do not know if ‘nomodeset’ nor if NO_KMS_IN_INITRD set to YES is needed for the proprietary graphic driver to build on your PC. I would try it without those settings, and if that does not work, then remove your fglrx install and try again with those settings. The ‘nomodeset’ can be specified as a boot code in YaST if you elect to try it, and you can set the NO_KMS_IN_INITRD by running “yast” (you can run yast in text mode with root permissions if X window not available) and navigate to yast > System > /etc/sysconfig Editor > System > Kernel > NO_KMS_IN_INITRD and change it to “yes”. This takes a minute or two to save once changed is submitted.

As noted, ensure you have gcc, make, kernel-source, and kernel-syms installed. The kernel-source and kernel-syms MUST be the same version as your kernel. One can check this by typing:

rpm -qa '*kernel*' 

So assuming that is all ok, then go get the proprietary driver by going to the ATI web site and download it to a location on your hard drive where you can find it (say /home/username ) . Lets say you end up getting the binary executable file “ati-driver-installer-11-2-x86.x86_64.run”.

One also MUST remove any previous fglrx driver (as I described above). ie first type in a terminal:

rpm -qa '*fglrx*' 

to look for any instances of the proprietary driver already installed. If you find it installed already (say it is called “fglrx64_7_5_0_SUSE113” ) then remove it with root permissions with

rpm -e fglrx64_7_5_0_SUSE113 

at which point in time there is NO fglrx driver installed on the hard drive.

Now you need to get to run level 3 for the next steps. You can switch to run level 5 with root permissions with:

init 3 

and log on as your regular username. There is a small tiny risk there all processes won’t be unloaded if you enter run level 3 that way. Hence INSTEAD I prefer to reboot and type “3” (no quotes) in the grub boot menu options line and then login in to the full screen text mode with my ‘username’. Then type ‘su’ to switch to root permissions. Then navigate to where the ati-driver-installer-11-2-x86.x86_64.run file is located.

Then if you wish to see what packages come with that file (this is NOT essential if you know in advance the needed run command’s argument syntax), run:

sh ./ati-driver-installer-11-2-x86.x86_64.run --listpkg

that may scroll by too fast :frowning: for you to see if openSUSE-11.4 was supported. If that runs by the screen too fast to see (and note again this is not essential IF you know in advance the needed run command arguments syntax) you can redirect its output to a text file with:

sh ./ati-driver-installer-11-2-x86.x86_64.run --listpkg > list-output.txt

and open list-output.txt with a text editor such as midnight commander … ie

mc

and open the file list-output.txt with midnight-commander editor (mc) to check what openSUSE versions are supported. Again not essential if you already know the run command’s argument syntax.

I did that for 11.4 because I did not know if 11.4 was supported. And indeed 11.4 was NOT listed as being supported. :frowning:

So I tried building the Catalyst driver with the 11.3 settings on 11.4 and it worked for me, but it may not for you. To try that, then run:

sh ./ati-driver-installer-11-2-x86.x86_64.run --buildpkg SuSE/SUSE113-AMD64

That may be slow in parts so have patience ! … and if that runs successfully it will ceate an rpm file. I do NOT know what that file will be called with your hardware, so I will make up a name. Lets say it created the file “fglrx64_xpic_SUSE113-8.821-1.x86_64.rpm”

Then install that file with:

zypper in fglrx64_xpic_SUSE113-8.821-1.x86_64.rpm 

That may be slow in parts so have patience !

Now its possible you could simply reboot right now and this will work.

Alternatively, if you want an /etc/X11/xorg.conf file, you can run

aticonfig --initial 

What I recommend at this point after you have built the xorg.conf (or after you have decided you want to try without an xorg.conf file) is to just restart the PC with:

 shutdown -r now 

and hopefully it will work. But again note you are using openSUSE-11.3 driver settings on openSUSE-11.4. Its a gamble.

Worked like a charm! Thanks.
Permission to put this procedure on my blog mentioning your nick?

Anyways, resolution in boot procedure after fglrx was pretty reduced. This also happens with mint/ubuntu when after fglrx install. I reckon this is normal?
(even though proper resolution was set in grub). Not that its a problem… just a question

You are welcome to put this in your blog. No need to mention my nick … you can if you wish … up to you.

You might wish to mention this script: Easy install of ATI proprietary driver in the console by please_try_again. I don’t use such scripts normally as I like to control each stage of the process, but not everyone is like me.

It might be ‘normal’ for your hardware, but it also might be fixable. We have a couple of users who are experts in sorting resolution problems. I recommend you start a separate thread on that problem. In that separate thread point to a copy of your /var/log/Xorg.0.log file (pasted perhaps on SUSE Paste) and also provide an extract from the " /sbin/lspci -nnk " command (the VGA line and 2 or 3 lines afterward) providing detail as to your hardware.

I don’t know if I’m missing something here, but here is my experience. I upgraded from 11.3 to 11.4. I have a Radeon HD 4250. In 11.3, after my initial install letting the system choose my driver, I got no graphics on initial boot. I booted to the rescue system and obtained the Catalyst 11.2 executable, ati-driver-installer-11-2-x86.x86_64.run, from the ATI site. I mounted my hard drive and simply ran the program as downloaded, chose the default options, and everything worked like a charm. When I upgraded to 11.4, again I had no graphics on the initial boot. I rebooted using the failsafe option from GRUB and the computer came up with generic VGA graphics. I again ran the ATI Catalyst executable with default options as before and graphics have worked flawlessly ever since. I used no special procedures and no rpms, just the executable binary.

Note when you installed the Catalyst executable from Failsafe, the ‘nomodeset’ option was specified as that code is part of the FailSafe options.

It is not clear in your first failed attept if you installed the Catalyst executable with ‘nomodeset’. Nor is it clear what your KMS settings in YaST were. Note I typed some cautions about this at the start of my post#8 above, and also earlier in the thread.

In the case of my Radeon HD3450, I needed to specify ‘nomodeset’ else this would not work for me.

I had no failed first attempt. I started with a bare, brand new system, put in the 11.3 DVD and let it make all the choices for me - strictly plain vanilla. I had no graphics. I assumed there was a driver problem, so I went to the ATI site to see if they had a proprietary Linux driver since I assumed whatever the DVD tried to load it was open source. There was one, so I downloaded it on another computer, stuck it on a usb flash drive, and booted the rescue system from the DVD. I then ran the executable - period. Whatever settings there were, they were whatever is specified by default on the Opensuse DVD. Same thing when updating to 11.4. I was surprised when Failsafe booted, actually. Whatever its settings, I changed nothing, inserted the flash drive and ran the program. Voila – graphics. I assume this is what an ignorant newbie would do when faced with the lack of graphics. Thankfully, it works.

@Oldcpu
I have

00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
01:00.0 VGA compatible controller: ATI Technologies Inc Redwood [Radeon HD 5600 Series]

the open source radeonhd driver which is installed, it doesn’t work which made to use “nomodeset” or “radeon.modeset=0”. Then, I used your method to install ATI proprietary driver but it doesn’t work at all + black screen

I’ve never advocated “radeon.modeset=0”. I do not know if that is implemented in the SuSE-GmbH packaged kernel. “nomodeset” is mentioned in the openSUSE-11.4 release notes. “radeon.modeset=0” is NOT mentioned in same release notes.

Note the proprietary ATI driver is QUITE CLEAR by the absence of openSUSE-11.4 in its support list, and that openSUSE-11.4 is not supported. I think I made it clear that trying to use the 11.3 settings is a gamble. Take a look at the LAST words of mine in post#8.

You could remove any ‘fglrx’ rpm and try again in Failsafe mode, but IMHO the 11.3 settings just don’t work with your Radeon device. You may have to wait until ATI produce an updated driver for 11.4.

  • I tried before to install ATI proprietary diver on openSUSE 11.3 but it didn’t work

Funny as it may be, desktop cube animation was smoother with radeon driver then with fglrx.

deleted …

That is strange. How about other tests, such as video playback (using the % cpu load under top as a way to help measure if it is better or not).

Problem 1: I wasn’t making any tests before I isntalled fglrx. Just know that 3D worked then job piled me up.
Problem 2: youtube video (I dont know would it be before installing fglrx), is acting strange. Video is playing correctly, but when I change tab, guess what? video is still on the same place running on all tabs… like it is “above” firefox. Ah yes, default flash player wasnt working properly, so I had to swich it (must anyways) with totally-tested 10.1 debug version (I need debugger version). This one worked in 11.3 perfectly. However, I didnt had time to install opera, or something else, and download new debugger plugin, but will do so.

(writing this from dreaded 7th of system I won’t even mention, due to some work-specific cra{ )