OLD XP machine with Nvidia GeForce 7300 LE has unusable graphics

I’m trying to put openSUSE 13.1 on a old 32-bit PC. The graphics card is a GeForce 7300 LE.

When I login, the graphics is all screwed up. I can get pieces of windows, but never full windows.

At the same time, my wireless is dead until I can set it up via graphics, so I can’t get on the Internet.

I’m using another machine to type this.

A friend downloaded NVIDIA-Linux-x86-195.36.31-pkg1.run (whatever that is), but it doesn’t install.

The error is:

“The kernel header file …/version.h” does not exist.

Can anyone tell me what to do?

btw: I don’t know linux at all, but my friend helped me write this message. Now he is running away! So I need hand holding.


Forget that! That’s ages old (it’s from 2010) and won’t work on openSUSE 13.1.

Add the nVidia repo to your system with YaST->Software Repositories->Add->Community Repositories.
Then enter YaST->Software Management, and install the following packages:
nvidia-gfxG02-kmp-desktop, x11-video-nvidiaG02, nvidia-computeG02.

Please check first what kernel you are using, though. Either look in YaST which kernel package is installed, or run “uname -a”.
The list above is for kernel-desktop. For kernel-default f.e. you would have to install nvidia-gfxG02-kmp-default instead of nvidia-gfxG02-kmp-desktop.

After a reboot your graphics should work better… :wink:

PS: If your system is unusable because of the graphics, try to boot to “recovery mode” under “Advanced Options” in the boot menu.

For your wireless problem, better open a new thread in the appropriate sub-forum if necessary.
But have a look if NetworkManager is enabled in YaST->Network Devices->Network Settings->Global Options.

And please specify the model of your wireless card, when you open a new thread about that. (see also the stickies in the wireless forum)

You will need to get the proper version, as that nVidia driver won’t help you.

btw: I don’t know linux at all, but my friend helped me write this message. Now he is running away! So I need hand holding.


… and this is the place where it gets done. :slight_smile:

First, you can get into the GUI desktop using the “Recovery” mode. When you boot, at the GRUB screen, choose the Advanced Options.

In there, you will see the Recovery mode.

That should take you up so you can log into a desktop session, where you can set up your internet connection.

Once you have done that, follow wolfi’s instructions to install the G02 nVidia driver that matches your system. If you need more clarification on how to do it, just let us know here.

You may need additional help on setting up your desktop if you have a 2nd monitor or an external display (such as sVideo) connected, as it will probably default in a way that lets you see only part of the desktop on the local monitor.

If Recovery mode does not work, you can try changing the BIOS setting in the Advanced category for Primary Video Adapter from PCI-express to Onboard (at least those are the terms for BIOS in my HP a730n). It’s likely the kernel drivers will work with the integrated graphics chip.

One of our computers has a nVidia GeForce 7200 GS card. It works well with the driver from the repository wolfi described. The current version there is 304.119-31.1. According to the nVidia site, it is right for your GeForce 7300 LE.


Forgot to mention, you also have to move the video cable from the PCI-e card connector to the motherboard connector.

The friend I mentioned had responded to a number of failure messages before giving up and helping with my original post. Then I mucked around with it for a while before getting your post. !!!When I logged back on (I had rebooted) - the graphics were working perfectly!!!

I will keep your instructions in case it goes wacky again. The hint you gave regarding the wireless connection was very helpful in getting that resolved.