old kernel gfx driver vs. new kernel gfx driver?

I have another question about kernels and graphics card drivers:
Right now, this is my kernel:
Linux linux-h3s9 #1 SMP PREEMPT 2011-02-21 10:34:10 +0100 x86_64 x86_64 x86_64 GNU/Linux

I’m pretty sure that there is a kernel update, right? What I want to do eventually (lol, I haven’t done it yet) is to install the proprietary NVidia driver for my graphics card. So, if I were to install that driver after the kernel update, and if I needed to boot into the older kernel for some reason (such as the new kernel having trouble booting, or something like that) then would the older kernel use the nouveau driver that is now installed, or would it try to use the proprietary NVidia one?

btw, I changed the /etc/zypp/zypp.conf file as was instructed earlier when I was running 11.2 like this: multiversion = kernel-desktop

My understand is by default (assuming no special code in place) it would try to boot the proprietary driver and fail, since the proprietary driver was built again the new kernel version.

Likely you would be able to use the boot code ‘x11failsafe’ which may force the loading of the FBDEV driver. I have not tried that myself (using ‘x11failsafe’ when proprietary driver is configured) but I think I’ll try that out of curiosity.

I just tried ‘x11failsafe’ on my Sandbox PC which nominally uses the proprietary nVidia driver. With ‘x11failsafe’ entered as an option in the grub boot menu, the PC boots ok to the FBDEV driver (GeForce FX5200 graphics and nominally 173.14.28 nVidia proprietary driver - but NOT that proprietary driver with ‘x11failsafe’ boot code ).

Thanks! That’s good to know! I wrote that down for future reference.

So, right now, I do not have the proprietary driver installed yet. I was waiting to do updates and I saw that there would be a kernel update too.

btw, do you have to clear the “vga=” statement when you use the “x11failsafe” code, or just type it in like you can do with the “nomodeset 3” code?

Either approach should work.

Well I’ve now installed the proprietary driver (and it’s working great!) and I’ve blacklisted the nouveau driver. I still have the kernel atm. Now I will be doing updates to it.
I’m hoping now that when I re-install the driver after the kernel update, that I won’t have to worry about the KMS nor the blacklisting the nouveau driver ever again.
I’m also hoping that the kernel update will also install the correct kernel source too so that the drive can be re-installed.

If all does not go well, I’ll be back to complain, lol.

I think when you update the kernel from to you will STILL need to maintain the same KMS settings and continue the black listing of the nouveau driver. But those settings are already in place now so you should not need to change anything.

When the kernel is updated, the updated kernel-source should also be dragged into being installed as well.

Glad to read you were successful with the proprietary driver and good luck in your future efforts.

:smiley: It all worked nicely. This is now the kernel that I’m using:
Linux linux-h3s9 #1 SMP PREEMPT 2011-04-25 21:48:33 +0200 x86_64 x86_64 x86_64 GNU/Linux

and the 3D driver shows up as: NVIDIA 270.41.06

I’m happy now. Thanks for all your info! Thanks for the virtual hand hold!