Old intel i810 Driver...

Having seen a few problems around with the new intel driver, I happen to know that arch still includes a legacy driver.

This is a bit cheeky but I think this may help a few about… Would someone be so kind to to put it on OBS. I would but firstly I don’t use it so can’t test it. Next I fall into the category I may not what a diff is, be able to create a patch and apply a patch still doesn’t mean I comprehend it.

So I’ve looked http://download.opensuse.org/source/distribution/11.1/repo/oss/suse/src/xorg-x11-driver-video-7.4-19.4.src.rpm

Now from what I can work out it just needs to include a patch but this is where I struggle. One I don’t use it but to me it just needs the spec tweaking and the patch applying. But if this helps others I thought it might be worth doing as there is a few around that seem to be struggling with the new driver.

Also if a bleeding edge distro seems to feel the need to provide a legacy package surely a less than bleeding edge should be.

From what I can see and the little I know it needs the 2.5 replacing with 2.3.2 from here xorg driver the patch applying from here patch and the spec tweaking in the src.rpm.

Perhaps someone will take it up and it’ll help a few people with intel gripes.

Hmm, I always thought the i810 was a seperate development to that of the actual Intel driver.

I doubt it would be nothing less than trivial to get the old driver to work but apparently it was dropped due to the upstream development ceasing completely - what I do wonder about is why no one has packaged the Intel driver in the OBS since newer versions of the xorg-x11-intel driver have been released quite often.

Perhaps it’s licensing issues.

I think you’re are correct about the i810 as in 11 it was included.

This seems to be a patched version of the 2.3.2 where 11.1 is using 2.5.0. I don’t why or if it works but I presume it does. Arch call it the legacy driver for i810/i830/i915/945G/G965

Its patched against an older version of the intel, as I can’t read code for toffee except to work some variables occasionaly and C/C++ is hieroglyphics to me.

I thought intel was GPL, but having just looked at the source build for arch it seems it’s MIT/X11 license surely this acceptable on OBS?

I really have included everything, at the Arch SVN link the license should be there too, just dont know where to begin from here, and even if I do I can’t test it.

I can give a shot at compiling i810 vs the 11.1 de-facto Xorg but I can’t even imagine what the results will be (if any) and even in that case I don’t have a suitable test machine here to compare on so even if I do get the i810 to work and do get it to load the results could be really erratic on a real live machine.

It could be that 2.3.2 still included some legacy code that made “things work”.

That would be my guess I tried to make sense out of the patch but that really did go over my head. I can’t even begin to comprehend the graphics stuff in code.

I know of someone that would be interested in trying a legacy type fix as they are struggling with 11.1 intel one. I would hope we have a few around here that would give it a go, certainly see a few grumbles about intel.

I would of thought the patching of 2.3.2 would be the easiest. Wish I could work out what the patch was doing. The configure flags seem normal(I would of thought speculation again)
./configure --prefix=/usr --enable-dri
Though I suspect the prefix is wrong for Suse.

As far as I know it is using the same xorg seems to be
A few bits tagged with 7.4 the same as Suse
server 1.6.1 Mmm Looking at the src.rpm seems Suse is on 1.5.2

But I struggle untangling the suse xorg naming scheme it’s not the same as upstream.

Oh well guess this just got more complicated with the different servers(But I really haven’t got a clue)

It was worth a try, got to be honest it doesn’t affect me but thought I had found a fix, but this has really has gone beyond me now. I suspect like you do, that will have major implications and more so if the patch is relying on 1.6.1

Thanks for considering it Chrysantine

Chrysantine I have a intel 915 system that uses the i815 driver, and I am willing to try out your patch.
I am not afraid of what it will do to my system as I dual boot Ubuntu 8.04 and OpenSuse 11.0, I could just pop OpenSuse 11.1 on my system again and try out your patch.
I am not afraid if it screws up, if anything happens I can just reinstall 11.0 big whoop.
You got a willing test subject in any case.

I don’t have enough time today to test it out - I’ll give it a shot over the weekend (sat-sun) since I’ll be gone much of fri-sat on travel.

As far as I’ve been able to deduce, the only thing you need to do is replace the i810_drv.so (symlink) in /usr/lib/xorg/modules/drivers/ and replace intel with i810 in xorg.conf (this way we don’t have to touch the intel driver at all and you always have a fallback).

Pretty much the only tricky thing is compiling it against the suitable version of xorg.

Well me I have plenty of time, but if you are going away for a few days I will just wait till you get back so we can have more proper testing and if I have issues i can report them to you.
Like I said plenty of time here, Ubuntu Hardy and OpenSuse 11.0 seem to be working here so I am no big rush.