Old IBM x30 - openSuSE 11.2 KDE4 - intel driver

I have installed 11.2 with KDE4 as default desktop, on a old IBM thinkpad X30 with 1Gb RAM (80Gb HDD). The installation ran without any problem, everything seemed to be ok.

This system was running 10.3 without any problem, and really fast. Sometimes it loosed its wifi connexion.

After doing some tests, I have experienced some difficulties with the Graphic driver of the 830i graphic card. The driver installed is the intel one.

The performance is quite acceptable, some slowness is to be reported with the graphical interface, but this is not the issue (perhaps… :slight_smile: )

I have just installed some small widgets (plasmoids) on the desktop (just for fun and test, the fuzzy clock, eyes and a plasmoid that tells me the buses schedules)

If I leave the system just running (not doing anything), the xorg server begins to use more and more CPU util having the machine running @100%. sometimes it is not xorg, bu knotify4… (apparently when amarok is running). The systems becomes unusable until I kill the X server.

If I try to activate desktop effets, the system freezes and I have to hardreboot it (once I had to unplug the battery)

The compositing is disabled in KDE, but in the xorg config file it, it seems to be enabled :

Section “Device”
BoardName “i830”
Driver “intel”
Identifier “Device[0]”
VendorName “Intel”

Section “ServerLayout”
Identifier “Layout[all]”
InputDevice “Keyboard[0]” “CoreKeyboard”
InputDevice “Mouse[1]” “CorePointer”
Option “Clone” “off”
Option “Xinerama” “off”
Screen “Screen[0]”

Section “DRI”
Group “video”
Mode 0660

Section “Extensions”
Option “Composite” “on”

Anyone has an idea of what is happening here ?

The option NoAccel true seems to solve the problem of cpu usage.

Section "Device"
BoardName "i830"
Driver "intel"
Identifier "Device[0]"
VendorName "Intel"
Option  "NoAccel "true"

But on the other hand, no desktop effects etc…