Old Dell C840 w/ GeForce4 440 Go and openSUSE 11.3 (11.4?) possible

Yes, it’s an old but usefull laptop. I knew that the new xorg server with 11.3 was going to kill the legacy nvidia drivers, but it looks like that turned around now that nvidia released new drivers which do liste the GeForce4 440 Go as supported. I tried installing 11.3, added the nvidia repo, did a update, it picked the 96.* driver and installed it. When it gets to load the login screen, I get nothing. The screen itself is completely off. I even tried LinuxMint and I can hear the login prompt ding, but have a dead screen. Only the nvidia driver loads, not the opensource one.

I went through the troubleshooting on opensuse.org and nothing worked. I got the message “NVIDIA(0): Failed to allocate/map the primary surface!” in the log, tried the nopat boot option, still nothing. Tried an xorg.conf from a 11.2 install and still nothing.

So, has anyone gotten a GeForce4 440 Go to work with the new nvidia driver? Is it even possible?
Think 11.4 might work?
Or just stick XP (~shudder~) on it??

Does this mean 11.2 works with no problem ?

Did you specify nomodeset as a boot code BEFORE installing the nVidia proprietary driver ?

Note also that Nvidia graphic card users who discovered that the “nouveau” driver did not work for them, should pay attention to the openSUSE-11.3 release notes and as appropriate blacklist the “nouveau” driver in the /etc/modprobe.d/50-blacklist.conf file. This can be done with root permissions by typing:

 echo "blacklist nouveau" >> /etc/modprobe.d/50-blacklist.conf 

It may also be necessary to run “yast” (you can run yast in text mode with root permissions if X window not available) and navigate to yast > System > /etc/sysconfig Editor > System > Kernel > NO_KMS_IN_INITRD and change it to “yes”. This takes a minute or two to save once changed is submitted.
… and do that BEFORE installing the proprietary nVidia driver.

Niether of thoes worked. Driver loads, but black screen when specifing the nvidia driver. Although, after installing the driver, the nv driver loaded and I had visual (before, nothing but black screen). And when I say black screen, I mean the screen shut off, not just being black with the backlight on.

Though I wanted gnome on it, I decided to go with XP. Drivers there just work. It is for my son. He just needs to get on the internet for educational websites (lumosity.com is the big one). Plus, I know how to get it all setup in one swoop with parental controls, educational software, etc. Still use things like openoffice, tux software (racer, typing, etc), firefox and chrome. In Windows, it also plays nice with the docks I have. Plus I got like 8 batteries for it (they were all free from work)

Ya know, a lot of people blame Microsoft for making people by new hardware because Windows 7 does not support it, but this falls under xorg being upgraded and nvidia not providing good drivers. Even before that, the nvidia drivers required post-tweaking for suspend/resume to work properly. My intel integrated-graphic laptops run on Windows 7, but driver is only provided by windows updates and no aero. No driver directly from intel supports it. Thoes machines I run openSUSE with 3D effects in both gnome and KDE. Same thing with the Intel wireless 2200BG cards. They just work out of the box. Intel likes linux.

I will still check out 11.4 once the nvidia repository gets the 96 driver.


Sorry to read you had no success.

Next time you try, you could first read the guide that was written to help users who have difficulty (such as you encountered) : SDB:Configuring graphics cards - openSUSE

It may not help, but it may also at least provide a logical process to follow to support a conclusion that its best to wait for now.

Information is very good .](http://www.gedarnet.com/vb/)
Thank you very much