old camera, new system - Firewire?

I have an older ASUS mainboard system that has in the BIOS a setting for allowing IEEE-1394 support.
In that system I installed a PCI card that had the Firewire connectors and could easily grab video from the old Sony Hi-8 camera my wife’s father left us.
It’s still a great camera and we’ve used it a lot.

However… and now I show my ignorance… does a mainboard have to specifically support IEEE-1394 in the BIOS for this to be possible at all?
I would rather do all my video editing on the new system as it’s 8 instead of 2 cores and LOADS more RAM.
I could move the Firewire card from one system to the other, but if there’s no chance for it to work anyway I’d rather not waste time experimenting. :wink:

Kinda hoping that since the new Gigabyte 990FXA-UD5 R5 mainboard has 6Gb 3.0USB ports, GSata, ESata, etc. (don’t even understand those yet) somehow the faster port support might relate to letting the expansion card work on that system.

Continuing thanks for the community support!

If the new Motherboard has a PCI slot you should be fine. I would guess the new Motherboard only has PCIe-xN type slots, then you would need to get a new PCIe type board suitable for the slot x1,x2,x4 etc but IEEE-1394 should work fine…

On my openSUSE Leap 42.1 system (MacBook3,1) I see;

/sbin/lspci -nnk |grep -A3 FireWire

04:03.0 FireWire (IEEE 1394) [0c00]: LSI Corporation FW322/323 [TrueFire] 1394a Controller [11c1:5811] (rev 61)
    Subsystem: LSI Corporation FW322/323 [TrueFire] 1394a Controller [11c1:5811]
    Kernel driver in use: firewire_ohci
    Kernel modules: firewire_ohci

In my experience if the BIOS has options for Firewire then the hardware actually has Firewire on it and either a socket on the back panel or a separate panel you plug in to a header and you should not need a separate card. As has already been said your card will work fine if you have the correct socket on the new board. Not sure what you might use for video grabbing and editing but I have been unable to get kdenlive to grab using Firewire on Leap 42.1, this is a problem with kdenlive not Leap as the dvgrab program works fine and you can still use kdenlive for editing.


On Tumbleweed I tried old tricks to get Sony cam via firewire to be seen by kdenlive, to no avail.


I see the cam as a firewire device in Kinfocentre, but apparently no way to make the cam work in kdelive. Very frustrating.


KDEnlive has removed support for Firewire in KDE5 completely. No joke.

I go now crying 1-2 hours…

Windows delivers only malware trash and Linux fails to take the competition, win over substantial amounts of users (paid and unpaid versions…). It’s so so frustrating.

Can you not just capture the camera content with dvgrab first, then you your favourite video editing software from there?

Many thanks for your reply!

It’s a rather old Sony cam with DV-tapes, no idea how something like that could be handled from CLI…

So maybe I have to start reading the docu for dvgrab.

Believe it or not, one guy posted:

“Problem solved, installed dual boot with Windows, grab my vids with MovieMaker and edit them subsequently in kdenlive”