Okular print encrypted pdf file

having trouble printing an encrypted pdf file (bank statement) using Okular.
Have an HP f-2200 printer with HPLIP 3.9.8 CUPS driver.
Using Okular 4.3.5

Every time I tried to print this file the print notification would advise printing began and then printing completed. However, nothing was ever printed. Looking at the print queue I can see that the print queue has also stopped and I need to restart this as root.

I was scratching my head for hours and playing with the print driver thinking there was a problem there. However, everything else prints fine.

I then noticed that this pdf doc is encrypted - but that is all the information that okular gives in the properties dialogue.

I installed acroread and was able to print the document right away without problem. Looking at the properties dialogue in acroread it identifies what is allowed and what is not allowed in the encrypted file. It lists “printing” as allowed.

Does Okular struggle with encrypted files as far as printing is concerned?
Worth filing a bug report?

Possibly - but do you have DRM set in Okular? Given that acroread says printing is allowed, it may be worth checking first if turning DRM on in Okular solves the problem.

thanks - but yes, that was one of the first things I checked after realising the problem may have been caused by the file being encrypted.

Enabling or disabling DRM appears to make no difference.

Another thought; does printing to PDF or PS from Okular also result in a blank PDF/PS file? That would give you an idea of when in the process the problem occurs - and that information might help in reporting a bug.

Also, have you tried KPDF? I have found there are still a few features of KPDF which haven’t made it to Okular even though Okular has features that KPDF doesn’t.

yes, printing to pdf or postscript produces a blank document.

I tried creating an encrypted pdf file using Openoffice writer and okular is able to print this without problem.

The only difference I can see between the two is the file created in openoffice is compatible pdf version 1.4 (acrobat 5.x) and my bank statement is compatible with pdf version 1.5 (acrobat 6.x)

That may be the problem as the only Linux application I have that can produce 1.5 is Scribus 1.3.6 and when I asked Okular to print this as a PDF it made a 1.4 PDF using Ghostscript.