Ok, kde3 and 4 with 11 not working correctly .. I think

This is my third time posting, and I have had no help at all from any one in this forum. Please if any one can help me, I would appreciate it.

Kde4 will not use the second xterm on my system even though it is active, and with the latest updates kde3 does not show any window borders on the second Xterm, I have deleted all user config files, to forced recreation of the user config. This does not help, the second xterm has become quite useless. Can anybody suggest a config change or tweek that will get me going, I have been using Suse like this for 5 years now, and just can not figure out what is happening. Maybe I have missed something…

I am about ready to go back to 10.3.

do you mean you can use more than one instance of xterm?

I have no issue here.

Sorry, can’t offer much advice here, as I’ve never had (and don’t understand) this problem. Do you mean no. of concurrent graphical desktops? Does this problem relate to using compiz window manager? Do you get different behaviour if kwin is selected?

I have multiple screens, and using separate desktop configuration for each. So that I have a separate desktop on each screen. So yes multiple graphical desktops . one on each attached screen.

My desktop does not span all of the screens. That seems to work fine when I set it to do that. except when I open the menu it appears on the opposite screen.

The way I use my screens, I have done so for quite a while… 9.x suse…

It does not work any longer, kde always just started a desktop on each configured screen. now the second screen is blank except when I move the pointer there, then the pointer changes to an ‘X’ … so the X-server sees the screen but KDE does not use it.

Again, which window manager are you using?

Ok, I tried all the different combinations, and here is what i have discovered.

All tests in suse 11 , Kwin worked in .suse 10.3

KDE4 Kwin4 does not activate a graphic desktop on my second screen
KDE3 Kwin does not display window frames ie. title and edges on windows.

Compwiz Works correctly in kde3 will test kde 4 and update here

I have never used compwiz before… thanks

Ok, tested kde4 with compwiz

in kde4  Compwiz seems to activate the desktop, the mouse pointer in now an arrow not an X, but kde4 does not initialize an active desktop at all, the mouse pointer moves there but the graphic area is just black

Hope this helps

Good work. As I thought the window manager and desktop environment combination is important. Interesting that Compiz works best in this situation. KDE4 is very much work in progress, and KDE4 kWin has also undergone substantial changes from the KDE3 version. Maybe you should file a bug report with KDE.

I just removed Suse 10.3 from my system and put Suse 11.0 on my system.
I had secondary display issues and needed to intsall nVidia Drivers. The borders, colours, or the mouse cursor may not show up right on the second monitor until you install the nVidia Drivers. There is a pretty good outline on Nvidia Download site on how to install drivers for various versions of SUSE.

even after installing the drivers KDE4 does not behave well when using multi-monitors. Menus show in the other monitor, and the widget thing only shown on the secondary monitor as well. There are a lot of cosmetic and setting issues and limitation with KDE4 and multi-monitor. KDE3 works properly tho.

Right now my KDE4 is not even loading, so I can’t test it any longer. what ever happened corrupted the thing, so I’m back to using KDE3 and it works fine as it did with 10.3.

Good info. Interesting to see what others have found.

I have had similar experiences, I currently am using a dual head configuration, using kwin, and I want to get the separate displays to work… like I used to have it in KDE3, 2 separate frame buffers and the whole 9 yards…(as in 2 separate taskbars, sets of icons and a total of 8 virtual desktops between them both).

NOW, after triple checking my configuration, and making sure that I was inputing the right stuff… I end up with 2 different wall papers, 1 set of icons, 4 virtual desktops and 1 taksbar (primary display ONLY)… what the hell is going on?

I have the nVidia graphics driver installed… I know this because not only did i run glxgears… (acceleration running smoothly), but I tried to play… TRIED… unreal tournament 2004. The game decided to strech between the monitors, with the center of the screen (where you are shooting) at the gap between them, like I had twinview (or xinerama) on…

can someone please explain this to me, or the person that originally posted… that may be helpful.

Quick edit to above post…

To get the 2 different desktop wallpapers, “seperate screen” must be enabled in the “nvidia-settings” control, AND Xinerama has to be checked… yeah, i know that sounds counter productive… but its working a little better than nothing… not much, but a little better.