Oh no! Something has gone wrong...

Hi Everyone!
I’ve been searching high and low for a solution on this forum and has seen similar issues but non as unique.

My setup-
Dell XPS 15 laptop that was successfully running encrypted 13.1 up until yesterday after an update that I’m sure was for the NVidia graphics card. The system now shows the white “Oh no! Something has gone wrong…” message, I’ve tried starting in the system in the other advanced options menu but all four show the same message. I’ve downloaded the repair disc and boot to it, unfortunately, it refuses to completely load and just displays the green status bar.

I really need my laptop and I’m not 100% sure where to start since I can’t even get to the login screen or boot to rescue cd :frowning: any help is greatly appreciated.

You should try a live DVD and see if you can boot to a live session.
Try other distros if necessary. At least this will go some way to confirming if there may be a deeper issue.

Luckily, I’m able to boot to the OpenSuse live DVD successfully.

Have you tried to reboot?
The nvidia drivers apparently don’t work on first boot after installation/update at the moment (on some systems at least).
Everything should be ok on subsequent boots though.

Your problem now is that GNOME and GDM unconditionally use OpenGL.
Since the nvidia driver installation breaks Mesa (and therefore its software renderer), you won’t even be able to use it in recovery mode.

Please post the output of:

rpm -qa | egrep "kernel|nvidia"

You could run this in text mode (press Ctrl+Alt+F1 and login).

To get to a graphical system, edit /etc/sysconfig/displaymanager and set a different DISPLAYMANAGER (xdm should be installed by default), then edit /etc/sysconfig/windowmanager to set a different DEFAULT_WM (e.g. “icewm”).

You could then remove the nvidia driver completely, then you should be able to get into GNOME again at least in recovery mode.
But that’s just if you feel uncomfortable with text mode and icewm. Otherwise we could just try to fix your nvidia installation instead… :wink:

While you are getting help, allow me to point to the fact that your title is likely to get answers like: see a plumber or a doctor. Please try to make usefull titles for your threads, that have some keywords about your prblem. Such a title will draw the attention of people that may know more about your subject. This one realy leads to some people who have much knowledge, but also limited amoount of time, to skip our thread and go for a more promising one. Not the effect you try to achieve if I assume correct.

On 2014-08-04 10:56, hcvv wrote:
>
> While you are getting help, allow me to point to the fact that your
> title is likely to get answers like: see a plumber or a doctor. Please
> try to make usefull titles for your threads, that have some keywords
> about your prblem. Such a title will draw the attention of people that
> may know more about your subject. This one realy leads to some people
> who have much knowledge, but also limited amoount of time, to skip our
> thread and go for a more promising one. Not the effect you try to
> achieve if I assume correct.

I believe that the tittle is just the error message he gets on the
screen, a big message, and as such, it is recognizable by people used to
gnome errors :wink:

Actually, I see 3 threads with this same tittle in the last month. Two
using nvidia, one Radeon. The two nvidias very recent, happening after
an update.


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

Oh boy, The humorous feelings of the people creating such sort of messages very much contradicts with the feelings of the people that are getting them >:(.

But a bit more descriptive on when you get it and quoting it would make that more understandable:
Getting “Something has gone wrong…” at boot
or something like that would be much better IMHO. But I feel with the OP, getting this is not very helpful to say the least.

On 2014-08-04 14:16, hcvv wrote:

> Oh boy, The humorous feelings of the people creating such sort of
> messages very much contradicts with the feelings of the people that are
> getting them >:(.
>
> But a bit more descriptive on when you get it and quoting it would make
> that more understandable:
> Getting “Something has gone wrong…” at boot
> or something like that would be much better IMHO. But I feel with the
> OP, getting this is not very helpful to say the least.

Yep. I would not appreciate much the humorous side of getting that “Oh
no! Something has gone wrong…” message when starting up the computer…

But as a programmer I know they, we, have a weird sense of humour.
It comes as a shock when users do not see it and instead are angry
at us. I can’t understand why… O:-) :stuck_out_tongue: :wink:

It is somewhat familiar to Gnome users, but not to KDE users, so if you
are on the second group and just see a post with that tittle you may
think that it is the poster who is trying to be humorous :wink:


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

@wolfi323](https://forums.opensuse.org/member.php/40214-wolfi323) thank you so much for the help! I was able to follow your instructions to load up icewm and remove the nVidia drivers. Once that was complete, I reverted the displaymanager and windowmanager settings and reboot the system which has resolved my issue. I’m going to research Bumblebee and see if that will help the graphics driver. Do you still want the output of rpm?

@hcvv I understand what you’re saying and I’ll keep that in mind for future reference. Thanks!

@robin_listas Your statement was exactly my issue and I noticed you helped others with this issue. Thanks for helping out!

I believe that the tittle is just the error message he gets on the
screen, a big message, and as such, it is recognizable by people used to
gnome errors :wink:

Actually, I see 3 threads with this same tittle in the last month. Two
using nvidia, one Radeon. The two nvidias very recent, happening after
an update.

The main question is, do you actually have a hybrid system? (i.e. Intel and NVidia graphics)

Your original post sounded like the nvidia driver did work before, but stopped working after an update.

Or did you a fresh installation of the nvidia driver lead to your problem?

Please post the output “/sbin/lspci”.

Do you still want the output of rpm?

That was intended to check whether you have the correct driver packages installed.
But since you uninstalled them already, it doesn’t make much sense now.

The Nvidia driver did work previously and the update is what seems to have caused my issue.
Here’s the output of /sbin/lspci -

00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.2 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 3 (rev c4)
00:1c.3 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 4 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM77 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
01:00.0 VGA compatible controller: NVIDIA Corporation GK107M [GeForce GT 640M] (rev a1)
07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 07)
08:00.0 Network controller: Intel Corporation Centrino Advanced-N 6235 (rev 24)
09:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5209 PCI Express Card Reader (rev 01)
09:00.1 SD Host controller: Realtek Semiconductor Co., Ltd. RTS5209 PCI Express Card Reader (rev 01)

Hm. Are you sure that you used the Nvidia driver?

You do indeed have intel and nvidia graphics. This doesn’t necessarily mean that it’s an Optimus system though, but since it apparently is a Laptop I would strongly expect it.

What graphics driver are you actually using now?
If it’s the intel, then it most likely is an Optimus system…

Please install the package “Mesa-demo-x” and post the output of:

glxinfo | grep render

And/or post /var/log/Xorg.0.log.

Mesa-demo-x is already installed, here’s the output-

glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile
GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_packed_depth_stencil,
GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_light_max_exponent,

I’m positive I was using the Nvidia driver but now that it’s removed I’m not sure what it would be using (yes, that sounds dumb).

You’re using the intel graphics and the intel driver.

Sorry, but IMHO it is impossible that you ever used the nvidia driver.
Although I have no idea how GNOME even worked before with having it installed.

As I wrote already, to the best of my knowledge installing the nvidia driver will not automagically switch to nvidia graphics on an Optimus system. It will rather break your system. (although if you do not install the package “nvidia-glG03” the intel driver should still work and you can use the nvidia chip for rendering, i.e. CUDA, but not for graphics)

If you have the option to turn off the intel graphics in your BIOS settings, you would be able to use the nvidia driver (but then you can’t switch to intel to safe battery of course).
If not, the only way is Bumblebee.
See here for details on how to install it: SDB:NVIDIA Bumblebee - openSUSE Wiki