Often recurring error in SMPlayer/ MPlayer

I have observed a recurring problem with video files. Very often the error stated below occurs when I try to play few files, but not when playing few other videos.
The error is:
“Mplayer has finished unexpedtedly. Exit code: 1”
How can i get rid of this recurring error.

Thanks in advance.

What happens if you try to play the file direct from mplayer ? I think maybe there is an mplayer log you can examine.

I tried to play a movie file (downloaded through torrent) The log gave me this information. How can I correct this.?

/usr/bin/mplayer -noquiet -nofs -nomouseinput -afm hwac3 -sub-fuzziness 1 -identify -slave -vo xv -ao alsa -nokeepaspect -framedrop -nodr -double -input nodefault-bindings:conf=/dev/null -stop-xscreensaver -wid 123732401 -monitorpixelaspect 1 -ass -embeddedfonts -ass-line-spacing 0 -ass-font-scale 1 -ass-styles /home/babloo/.config/smplayer/styles.ass -fontconfig -font Arial -subfont-autoscale 0 -subfont-osd-scale 20 -subfont-text-scale 20 -subcp enca:en:ISO-8859-1 -vid 0 -subpos 100 -volume 100 -nocache -osdlevel 0 -vf-add ass -vf-add screenshot -slices -channels 2 -softvol -softvol-max 150 /home/babloo/Videos/Drive Angry 2011 720p BRRip- HDLiTE/Drive Angry 2011 720p BRRip HDLiTE.mkv

MPlayer dev-SVN-r33321-4.5-openSUSE Linux 11.4 (i686)-Packman (C) 2000-2011 MPlayer Team
Can’t open joystick device /dev/input/js0: No such file or directory
Can’t init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /home/babloo/Videos/Drive Angry 2011 720p BRRip- HDLiTE/Drive Angry 2011 720p BRRip HDLiTE.mkv.
libavformat file format detected.
[matroska,webm @ 0x90685e0] max_analyze_duration reached
[matroska,webm @ 0x90685e0] Estimating duration from bitrate, this may be inaccurate
[lavf] stream 0: video (h264), -vid 0
[lavf] stream 1: audio (ac3), -aid 0, -alang eng
[lavf] stream 2: subtitle (unknown), -sid 0, -slang eng
[lavf] stream 3: subtitle (unknown), -sid 1, -slang spa
VIDEO: [H264] 1280x720 0bpp 23.976 fps 0.0 kbps ( 0.0 kbyte/s)
[ass] ENCA detection failed: fallback to ISO-8859-1
[ass] ENCA detection failed: fallback to ISO-8859-1
Load subtitles in /home/babloo/Videos/Drive Angry 2011 720p BRRip- HDLiTE/
ID_FILENAME=/home/babloo/Videos/Drive Angry 2011 720p BRRip- HDLiTE/Drive Angry 2011 720p BRRip HDLiTE.mkv
Opening video filter: [screenshot]
Opening video filter: [ass]

Opening video decoder: [ffmpeg] FFmpeg’s libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)


Trying to force audio codec driver family hwac3…
Opening audio decoder: [hwac3] AC3/DTS pass-through S/PDIF
hwac3: switched to AC3, 448000 bps, 48000 Hz

AUDIO: 48000 Hz, 2 ch, ac3be, 448.0 kbit/29.17% (ratio: 56000->192000)
Selected audio codec: [hwac3] afm: hwac3 (AC3 through S/PDIF)

[AO_ALSA] Format ac3be is not supported by hardware, trying default.
AO: [alsa] 48000Hz 2ch ac3le (2 bytes per sample)
[Mixer] No hardware mixing, inserting volume filter.
[format] Sample format big-endian AC3 not yet supported
Starting playback…
Unsupported PixelFormat 61
Unsupported PixelFormat 53
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
[swscaler @ 0x89e3e80]using unscaled yuv420p → rgb24 special converter
VO: [xv] 1280x720 => 1280x720 Planar YV12

MPlayer interrupted by signal 11 in module: av_sync

  • MPlayer crashed by bad usage of CPU/FPU/RAM.
    Recompile MPlayer with --enable-debug and make a ‘gdb’ backtrace and
    disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
  • MPlayer crashed. This shouldn’t happen.
    It can be a bug in the MPlayer code or in your drivers or in your
    gcc version. If you think it’s MPlayer’s fault, please read
    DOCS/HTML/en/bugreports.html and follow the instructions there. We can’t and
    won’t help unless you provide this information when reporting a possible bug.

what is that ?

Do a SIMPLE test. ie

mplayer HDLITE.mkv

I tried to play a movie file (downloaded through torrent)

that is the first problem ?
ARE you 100% sure that the video IS A VALID video ?

second issue
playing this

Drive Angry 2011 720p BRRip- HDLiTE/Drive Angry 2011 720p BRRip HDLiTE.mkv

in the command line WITHOUT the REQUIRED " " .There ARE spaces in the names , many many spaces

is smplayer set as the default player for mkv files ?
what happens if you double click on it ?

third issue
what codec package do you have installed ?
the recommended " all-20110131.tar.bz2 "
Index of /MPlayer/releases/codecs

Yes I am very much sure, this is a valid video file. I have downloaded many video files from internet from this uploader (viz. HDLiTE) and they play all well. The same file can be played on windows without any error.
Many other .mkv files too can be played in Suse without any errors.

I think there was some error in SMPlayer itself. I have installed vlc player now. The files are running fine.
Thanks for the help once again.

you do know that a .mkv file is just a container
it can be one of many video formats

what codecs do you have installed ? the OLD one from 2010 in the suse repo?
or the current 2011 tarball ?

I have uninstalled SMPlayer now, and made vlc as the default player of Suse.
I feel if SMPlayer can’t update itself, whats the point keeping it.
“zypper up” should update all…

Yap, I have also encountered same problem and it is (or now was) bug in MPlayer (consequently SMPlayer and KMPlayer), so I changed to VLC (just to say that SMPlayer is my favorite), but I haven’t been back to verify in a while. I haven’t even took a note of MPlayer version.

The same problem here playing videos .flv and mp4 -files… But Kaffeine and VLC works excellent and without any problem
SMPlayer log information :

/usr/bin/mplayer -noquiet -nofs -nomouseinput -sub-fuzziness 1 -identify -slave -vo xv -ao alsa -nokeepaspect -framedrop -nodr -double -input nodefault-bindings:conf=/dev/null -stop-xscreensaver -wid 106955168 -monitorpixelaspect 1 -ass -embeddedfonts -ass-line-spacing 0 -ass-font-scale 1 -ass-styles /home/Drake/.config/smplayer/styles.ass -fontconfig -font Arial -subfont-autoscale 0 -subfont-osd-scale 20 -subfont-text-scale 20 -subcp ISO-8859-1 -vid 0 -aid 0 -subpos 100 -volume 60 -nocache -ss 48 -osdlevel 0 -vf-add screenshot -slices -channels 2 -af scaletempo,equalizer=0:0:0:0:0:0:0:0:0:0 -softvol -softvol-max 110 /home/Drake/dwhelper/trailer_high.flv

Option ,alsa needs a parameter at line 77

Regards :slight_smile:

Jan// sm3cua

Anyone tried to compile MPlayer from source?

Option ,alsa needs a parameter at line 77

Check /etc/mplayer/mplayer.conf for “,alsa” at line 77. Delete it or change it to “ao=alsa”.

Has anyone posted on the Packman packager mailing list advising their packaged mplayer has problems with flv and mp4 files ?

I note on my 64-bit openSUSE-11.3 laptop that the command ‘smplayer somefile.flv’ and ‘smplayer somefile.mp4’ works fine, but the command ‘mplayer somefile.flv’ and ‘mplayer somefile.mp4’ has problems. I’m currently travelling on the road on vacation (returning tonight) and can’t look into this now.

I was able to reproduce that error. It seems to be a conflict between mplayer’s softvol option and AC3 through S/PDIF. I was able to play the video by disabling the softvol option. With smplayer you can do it by going to Preferences > Audio Tab and uncheck “use software volume control”.

I have experienced no issues with smplayer
But I don’t use .mkv and or files from strange and illegal sources.

If other files play ok as you suggest

Many other .mkv files too can be played in Suse without any errors.
Then it may just be something with the one file in question here. VLC will often find a way thru errors that other players do not.

I’m back at home, and note that my desktop with 64-bit openSUSE-11.3 does not have this behaviour, and it plays .flv and .mp4 with no problem with smplayer and with mplayer. However my laptop (also running a 64-bit openSUSE-11.3) had a problem with mplayer and .mp4 and .flv. I need to compare the setup/configurations later this week and assuming I can still reproduce the problem on my laptop, check to see where it is different from my desktop.

Thank you Londy, this information is excellent. SMPlayer now works out without any problem so you made my day,

Best regards

sm3cua // Jan

I went back to my laptop which I ‘thought’ had a problem with mp4 and flv and I noted that the following works fine for mp4:

mplayer somefile.mp4 -vo xv 


mplayer somefile.mp4 -vo x11 

and the following for flv:

mplayer somefile.flv -vo xv 


mplayer somefile.flv -vo x11 

So it turns out I don’t have a problem with this after all.