official NVIDIA repository driver is not working for weeks, again!

I have problems with the NVIDIA driver from the official Tumbleweed repository again. For at least 2 or 3 weeks the driver is not working or is not getting udated… which means that i cannot use my home pc anymore. Last time i was able to solve the problem by reinstalling the driver from the repository via:

zypper in -f nvidia-gfxG04-kmp-default

As i tried it last week, it simply does not changed anything. As i tried it a few minutes ago i got an error message, that the File is not found on the official nvidia repository. I have also made a screenshot to give you an overview:

What is the problem here? Also talking about the general problem with the driver for weeks.


zypper ref
zypper up

There is a newer Nvidia Package in the Repo:

Your local repo cache is outdated obviously.
The current driver version in the repo is 384.111, but zypper tries to install 384.98 (which does not exist anymore).

Post your repo list:

zypper lr -d

Also talking about the general problem with the driver for weeks.

The NVidia drivers failed to build with Kernel 4.14.9 and higher.

NVidia did release an update (about two weeks ago, IIRC) to 384.111 to fix this.

Thank you, zypper ref followed by zypper up did the trick.
But i am confused that a normal zypper dup did not also refreshed the cache. And interestingly only the nvdia repo what not up to date.

Maybe Auto-Refresh is disabled for that repo for some reason.

That’s why I asked for the output of “zypper lr -d”…

That was the case, thanks. I do not know why though

Well, how did you add the repo?

YaST has a checkbox which should be activated by default, but can be deactivated
If using “zypper ar”, you need to pass the “-f” option to turn on Auto-Refresh though.