Official 12.1 driver for ATI Radeon HD 6870 video card not working properly

Since OpenSuse 12.1 finally detects my hard drive, I installed it last night on my dual-boot machine. Everything works fine, except the issue users with ATI cards must face: Getting the proper video driver in Linux.

My card is an ATI Radeon HD 6870 (Gigabyte version). I tried both the official driver from as well as the driver on the OpenSuse website. Unfortunately, both of them are buggy and don’t work well, although it’s specified they should work for my video card and OpenSuse 12.1.

The issues I experience with this driver are desktop effects not to activating (including the Blur effect), the desktop sometimes crashing with an error message. OpenSuse even got jammed a few times, and I had to restart the system. I also tried an OpenGL 3D game, and all textures were corrupted and barely anything worked. Visual corruption on active windows and on other parts of the desktop is also present at times. Performance appears to be the same as the stock fglrx driver.

Does anyone know what the problem is and how to get this driver working? Note that I’m normally a Windows user, and am not experienced with xorg and advanced setup. I’m looking for a clear and easy way to install my video driver the same way I do in Windows. I looked at the aticonfig command, but haven’t found anything that fixes these issues there.

Note: Everything works fine with the stock fglrx driver (that gets installed with OpenSuse), including all desktop effects and 3D games. The reason I’m trying to install the proprietary driver is that it feels more right to do so, because it installs Catalyst Control Center (a handy GUI I also use in Windows), and I’m hoping it will improve my framerate in games. Currently, the Linux version of a game I play in Windows works about 3 times slower in OpenSuse. If the proprietary driver doesn’t improve anything over stock fglrx, let me know so I won’t have to bother at all to install this :stuck_out_tongue:

There is a bug reported by some in the proprietary AMD video (catalyst) driver for GNU/Linux that you may or may not be seeing. There are a number of threads with please_try_again providing superb support where this was noted. His script that installs the AMD catalyst driver purportedly also has a work around for one of the Catalyst driver bugs: where missing /usr/X11R6/lib64 and /usr/X11R6/lib in ldconf path, which prevented direct rendering from working. The bug has been discussed and solved in this thread: How do I install the proprietary Radeon Catalyst driver?.

Whether that is related to what you note I can not say.