OfficeJet 6500A, OpenSUSE 11.4, won't print

I installed the 64-bit version of OpenSUSE 11.4 last week and tried to print from it today. I couldn’t get anything to come out. I’ve tried both USB and network printing, and nothing ever works.

Any attempt to print anything results in the HPLIP Status Service app telling me the job is “completed” immediately, with nothing printed, but the CUPS web interface reports “/usr/lib/cups/filter/hpcups failed”.

It’s connected to the network router and hp-setup discovers it when I use manual discovery and give it the IP address, but it still won’t print even a test page, whether as root or as a user.

I’ve also used the CUPS web interface to add my user to the list of users allowed to print, and added my user to the lp group. But I still get the same error and nothing ever prints.

It’s connected to the network router and hp-setup discovers it when I use manual discovery and give it the IP address, but it still won’t print even a test page, whether as root or as a user.

Did you initially configure this printer with hp-setup as root?

I think I initially tried configuring it as a user, but then after reading this, I ran the hp-setup util from the command line, as root. But even as root, it won’t print.

Hopefully, you will get support from a member with HP printer experience.

In the meantime, have a read of this thread. There is a link to another thread suggesting that it may be worthwhile using hplip software from here:

HP Linux Imaging and Printing

I’ve fixed the problem by installing the “system-config-printer” package (which successfully configured Ubuntu for printing to the same printer through the network) and used the “hpijs” driver rather than “hpcups”.


  1. Install system-config-printer (I used zypper from command line: sudo zypper install system-config-printer )

  2. Run the app from the command line:

system-config-printer &
  1. Right-click on the icon representing your printer that doesn’t have “fax” anywhere in its label (you may have to repeat these steps for faxing), and select “Properties” from the menu

  2. Where it says “Make and model”, click the button to the right that says “Change …”

  3. A dialog should appear headed “Change driver”, with the button “Select printer from database” and “HP” highlighted in a list of printer manufacturers. If so, click “Forward”.

  4. A list of HP printer models should appear in the left box, with two driver codes in the right box. Move the scroll bar at the bottom to the right, and you should find that one of them has “hpcups” in the code, and one has “hpijs”. Select the one that says “hpijs”.

  5. In the dialog box that follows, you should see two options, “Use the PPD as is” and “Try to copy the option settings over”. Select “Use the PPD as is”. Then click Finish.

  6. You should be prompted for the root password (note: the box may appear behind the box you can see, with a new entry in the taskbar at the bottom of the screen which is highlighted; you need to click that). Then type the root password and press Enter.

After I’d done that, both test pages and documents from LibreOffice printed without any fuss.

Thanks for the update. You could probably have configured the printer via the CUPS web interface, and achieved the same result. The hpijs printer driver is for use with most HP non-PostScript printers. It has actually been deprecated AFAIU, and replaced by the hplip driver.

For others searching for help with HP printers, some useful resources:

I also found this potentially useful thread:

I checked my printer configuration on Ubuntu (which printed through the network without incident) after switching drivers on my OpenSUSE machine, and found that it’s also configured with hpijs. So, clearly they found that it was better to use the older driver.

I have had a OJ6500 for a while now, and have never used hpcups my systems always use hpjis by default. I have never had to install anything special. hp-setup will work, or in Yast.

Either way it like all my hp printers always use hpjis.