Odd sound problem

Using Xfce.

All of a sudden music files do not produce any sound through my Azalia sound card. I started YaST and tested the card and it produced the test sound. Console use of mpg123 does not work. Mpv produces no sound yet shows the files playing- Pavucontrol which I use also shows signal strengths. Audacity shows the some. Still nothing coming out of the speakers. Then after a few minutes the YaST test is silent although output volumes are still 100%. I switched to headphones in case my amplifier is the problem. No sound.

Any suggestions as to where I should start the diagnosis?

I’d guess you are not using the codecs from packman for some reason

Even though I am sure I had installed the codecs previously I did it again using the Multimedia Guide for openSUSE Leap 42.3. Nothing changed, still no sound. Now here is some more information. When I log into Xfce I have an autostart script that plays a short piece of music using mpg123. It still makes sound. But after that it will not play a second time and although the autostart script takes about 15 seconds to complete playing the second attempt terminates immediately. Then when I try the third time it takes 15 seconds and “top” shows both pulseaudio and mpg123 running but still no sound. Repeated attempts alternate between immediate termination and 15 second operation. I believe Xfce is terminating some running application. After all of this the YaST card test still plays.

A real mystery. I hate to have to re-install to clear this but I think that might be the only solution.

Here is “zypper se pulse” output in case I am missing something obvious.

# zypper se pulseRetrieving repository 'Packman Repository' metadata ......................[done]
Building repository 'Packman Repository' cache ...........................[done]
Retrieving repository 'packman' metadata .................................[done]
Building repository 'packman' cache ......................................[done]
Retrieving repository 'openSUSE-Leap-42.3-Update' metadata ...............[done]
Building repository 'openSUSE-Leap-42.3-Update' cache ....................[done]
Loading repository data...
Reading installed packages...

S  | Name                               | Summary                   | Type      
i+ | alsa-plugins-pulse                 | Pulseaudio Plug-In for -> | package   
i+ | alsa-plugins-pulse-32bit           | Pulseaudio Plug-In for -> | package   
   | apulse                             | PulseAudio emulation fo-> | package   
   | apulse-32bit                       | PulseAudio emulation fo-> | package   
   | cmus-plugin-pulse                  | Pulseaudio output plugi-> | package   
   | cmus-plugin-pulse-debuginfo        | Debug information for p-> | package   
   | gyachi-plugin-pulseaudio           | PulseAudio sound driver   | package   
   | gyachi-plugin-pulseaudio-debuginfo | Debug information for p-> | package   
   | libgvncpulse-1_0-0                 | Pulse audio bridge for -> | package   
   | libpt2_10_10-plugins-pulse         | Pulseaudio support for -> | package   
   | libpulse-devel                     | Development package for-> | package   
   | libpulse-devel-32bit               | Development package for-> | package   
i+ | libpulse-mainloop-glib0            | GLIB 2.0 Main Loop wrap-> | package   
   | libpulse-mainloop-glib0-32bit      | GLIB 2.0 Main Loop wrap-> | package   
i+ | libpulse0                          | Client interface to Pul-> | package   
i+ | libpulse0-32bit                    | Client interface to Pul-> | package   
i  | libxine2-pulse                     | Pulseaudio plugin for x-> | package   
   | libxine2-pulse-debuginfo           | Debug information for p-> | package   
i+ | mpg123-pulse                       | Pulseaudio Support for -> | package   
   | mpg123-pulse-32bit                 | Pulseaudio Support for -> | package   
i+ | pulseaudio                         | A Networked Sound Server  | package   
   | pulseaudio                         | A Networked Sound Server  | srcpackage
i+ | pulseaudio-bash-completion         | PulseAudio Bash complet-> | package   
   | pulseaudio-dlna                    | A DLNA server which bri-> | package   
   | pulseaudio-dlna                    | A DLNA server which bri-> | srcpackage
   | pulseaudio-equalizer               | PulseAudio's LADSPA plu-> | package   
   | pulseaudio-esound-compat           | ESOUND compatibility fo-> | package   
   | pulseaudio-gdm-hooks               | PulseAudio GDM integrat-> | package   
i+ | pulseaudio-lang                    | Languages for package p-> | package   
   | pulseaudio-module-bluetooth        | Bluetooth support for t-> | package   
   | pulseaudio-module-gconf            | GCONF module for PulseA-> | package   
   | pulseaudio-module-jack             | JACK support for the Pu-> | package   
   | pulseaudio-module-lirc             | LIRC module for PulseAu-> | package   
   | pulseaudio-module-x11              | X11 module for PulseAudio | package   
   | pulseaudio-module-zeroconf         | Zeroconf module for Pul-> | package   
   | pulseaudio-system-wide             | Support for running Pul-> | package   
i+ | pulseaudio-utils                   | PulseAudio utilities      | package   
i+ | pulseaudio-utils-32bit             | PulseAudio utilities      | package   
   | pulseaudio-zsh-completion          | PulseAudio zsh completion | package   
   | pulseview                          | Qt-based GUI for sigrok   | package   
   | typelib-1_0-GVncPulse-1_0          | Pulse audio bridge for -> | package   
   | xfce4-panel-plugin-pulseaudio      | Pulseaudio Volume Contr-> | package   
   | xfce4-volumed-pulse                | Daemon Providing Suppor-> | package   
   | xmms2-plugin-pulse                 | Pulse Support for xmms2   | package   
linux-q3kn:/home/ion # 

Some progress. If I boot to a level 3 console my sound works. If I boot into Xfce and open a console (F3) it does not work. So it confirms my assumption that Xfce is causing the problem.

This thread can be closed. I gave up and re-installed.