Odd KDE Sound Failure

I’m running opensuse 11.1, KDE 4.1 on an i7 machine with onboard sound in the ICH10 family. Sound works fine in Flash, streaming audio off the web and CDs. KDE desktop sounds, however, are no longer working.

The odd thing is: they weren’t working earlier. Then I did a complete reinstall, and on the initial login to KDE, desktop sound was working just fine - login sound, logout sound and kmail message notification sound (a .wav file) were all clearly audible.

After a logout and login, however, a warning dialog popped up briefly saying that the phonon backend was unable to use the HDA Digital selection, and was defaulting to the next device in the list. No sound anywhere from KDE, although other applications continue to work, as noted. Bumping the default audio device down through the ‘Configure Desktop’ settings had no effect. No amount of rebooting or twiddling the device order restores the sound that was working so well until I logged out.

I’ll note, too, that I have never been able to get a test sound to play in the Yast sound configurator, and now is no exception.

Anyway, I suspect some configuration file must be getting overwritten during logout or when some portion of the KDE system is shut down, given that everything worked fine and no changes were made to the sound system between working perfectly and not working at all following logout/login.

Any ideas?

I’ve read cases where users solved this by installing “phonon-gstreamer backend”

There is a known bug in openSUSE-11.1 yast that the test sound does not work for some hardware.

If you are looking for a sound test, I recommend you try each of the 3 tests in the following link … One of them should work: SDB:AudioTroubleshooting - openSUSE - how to test your sound

I did the speaker-test; it works just fine. As noted, sound also works fine in Flash, streaming audio files and other media encountered through Firefox and Amarok. The only problem seems to be with the KDE desktop sounds.

gstreamer was already installed. Moving it ahead of Xine in ‘Configure Desktop’ settings made no difference.

It worked fine at first, until I rebooted; since then, nada.

I’ll be happy to run any tests you want, but I suspect that the problem is KDE-related rather than sound system related.

I think you misunderstood my post. … Maybe I did not express myself well. … The references / links I gave you are not for me. They are for you, if you are looking for a sound test. I’m not interested in the result of a sound test on your PC. I have 3 pcs of my own (plus a laptop) to keep me busy. As you noted, you already have sound in some functions. Rather since I was noting that YaST speaker test has bugs, I also thought worth noting IF you want a speaker test, then there are others (than YaST).

Gotcha. My bad.

Hi !
I have another/similar annoying OpenSUSE 11.1/Kde sound issue. Here’s what I did:

  • a fresh install with Gnome, Kde, Xfce and a bunch of stuff (I wrote a script for that purpose)
  • switch to runlevel 3 (as I always do ) and start a minimal X with twm (the simplest X you can think of)
  • listen to a radio stream with mplayer. It works !
  • start X with Gnome as WM, listen to a radio stream. It works !
  • start X with KDE and then …
    Not only it doesn’t work. But after I logged out I had no sound of any kind anywhere anymore, as the mixer would be muted (but it is not).

I did several installs on different machines, with and without alsa and alsa-update repos. It doesn’t seem to be a driver issue (at least not alsa). I suspect Pulse wrote some bullS-H-I-T somewhere (however not in users home directories) or changed some device property. Reboot and alsaconf didn’t help. I will start to investigate but I don’t know Pulse at all … and to be honnest I don’t understand the purpose of it (other than trying to match Windows … which keeps makink Linux worse and worse). So, any advice would be welcome.

I use a basic PCI soundcard (C-Media CM8738), needed for compatibility with other OS (Open/Net/FreeBSD).
No sound problem with BSD (but no Pulse either) and KDE4/Gnome under Ubuntu (jaunty/intrepid/hardy).

I may have found a brute-force solution to my problem. I created a new user, to see if fresh user configuration files would make any difference. Sure enough, the new user had desktop sounds working just fine. And they persisted through a few login/logout and reboot cycles.

So, since this is a new installation and the configuration files aren’t cluttered up with my own customizations yet, I copied the .kde and .kde4 subdirectories from the new user’s home directory to mine.

Like magic, sound was restored to KDE.

So it is apparently something with the KDE configuration files that was causing the problem. Whether I managed to corrupt something (seems unlikely, but not impossible) or they got hosed over by some other process, I have no idea. But for the moment, anyway, I’m back in business.

I probably shoulda never left KDE 3.5 behind, although it seems like it’s departure is inevitable. Things pretty much just worked in that version.

Thanks for the help. At least it pointed me in the right direction.

I don’t know the practical parts of pulse either. But the theoretical has lofty goals. You can read up on some sound concepts here: Sound-concepts - openSUSE

Here is a link to a troubleshooting guide: SDB:AudioTroubleshooting - openSUSE
If you start a new thread, I’ll reply to that with:

  • diagnostics script you can run that gives me detail on your PC
    *] some basic commands to run to tell what audio related rpms (and detail on a key config file)you have on your PC.
    To reply on this thread would be confusing and I’ve learned after 6000+ posts not to mix different sound problems on one thread. It just confuses me and I often mistakenly end up giving the advice for user-a to user-b by mistake.

Indeed that was a brute-force solution. Still, such solutions can be interesting. … Out of curiousity, how much of your desktop did you lose by doing that?

Thanks. But I ran (most of) the tests decribed on that page before I landed here.

For now here are screenshots of 2 boxes running openSUSE 11.1 64-bit:


They look pretty much the same and hang on the same KVM+sound switch. The second one appears to function properly : no error message, no busy device, no access denied … but no sound at all. When I switch back to the other one, I can hear the radio. I do that all the time under differents OS, so I guess a soundcard or switch failure is excluded. Of course I also tried without the switch and with other programs (like mpg123 )

I just noticed that I didn’t use exactly the same command on both. But it doesn’t matter. Pulse wouldn’t have complained if I had specified “-ao alsa” and the two mplayer outputs would have been identical.

I guess to reproduce the error, I will have to do the same fresh install on both computers, check the sound and start KDE on one of them. If at that point I lost the sound again, it might be worth to start a new thread … but where? I don’t think this issue is 64-bit or even hardware related. But I can provide all necessary details about the pcs.

As noted, please start a new thread. Honestly, in the past I have wasted a silly amount of time being confused by multiple problems in one thread. I will not do that again. So if you insist on using this thread, and that is your right, … I will bow out gracefully right now from this thread, and let some one else offer their opinion.

Shortly :
When you’re happy with your desktop, you can copy the .kde and .kde4 directories in /etc/skel, recursively change all the ownership to root (chown -R root:root /etc/skel/{.kde,.kde4} ) and any new user you create (including yourself ) will inherit this desktop. You will have to change some paths for everything to work properly, i.e replace all occurences of the old username (ideally root) with the new username, but there are not that many and they can be easily changed with a single patch. You can do that with Gnome as well and basically any program.

I will after I got some sleep and when I make sure that the problem is real and reproducible - so nobody should waste a silly amount of time trying to solve my one mistake.

None that I’ve noticed. As I said, this is a fairly new installation, so there wasn’t anything in my old subdirectories that mattered. On an older installation, I would have been more careful - maybe - and gone through replacing a single file at a time. But that’s a slog - there are dozens of files in those subdirectories.

It does suggest that one of the KDE configuration files got hosed over somewhere along the line. Where, when and how remain mysteries.


you may also consider upgrading to kde 4.2.3 from the repos. 4.1 really wasn’t a good release

Sadly, I have no reason to believe the 4.2 is a “good” release, either. To be blunt, Opensuse has real problems maintaining quality; their last several releases have caused as many problems as they’ve solved, and it isn’t unusual to see problems that were solved a couple of releases ago crop back up in subsequent releases.

Been using suse since way down in the single digits. I can’t say I’m seeing improvement or cause for hope. Moving to yet another shiny new release fills me with dread at this point.

lol lol!

I’ve been avoiding KDE-4.x until now, … instead using KDE-3.5.9 (on 11.0) and KDE-3.5.10 (on 11.1). On a sandbox PC, I installed openSUSE-11.2 milestone1 with KDE-4.2.3 and its not bad. From a desktop perspective, I still slightly prefer KDE-3.5.10, but KDE-4.2.3 in 11.2 is finally coming of age, and it promises to have KDE-4.3 when released, which should be even better in terms of features and stability. I just may make the move in November-2009 to KDE4.3.

Note 11.2 is not ready for more than testing (too many bugs yet) but it is suitable (and stable enough) for testing. If you have a sandbox PC or a spare partition (and are comfortable in fixing a messed up grub) then you could give 11.2 a try to test your favourite apps (and write bug reports on it).

I’ll wait until 11.2 is officially released. I don’t have time for beta testing, for better or worse.