ocfs2 filesystem mount on 13.1

I am trying to get ocfs2 clustering to work on 13.1. It is working ok on 12.3. I installed all the clustering software from the opensuse factory and tried setting up the cluster the same way I did on 12.3. After a long struggle I got the stonith, dlm, and o2cb resources to activate, and I was able to do a mkf2.ocfs2 on the file system. But when I try to mount it I get the message:

2013-12-11T09:41:36.018210-06:00 ftp1 Filesystem(testfs)[5008]: INFO: Running start for /dev/disk/by-id/scsi-36000eb3b7bcda1ee0000000000002171 on /test2013-12-11T09:41:36.262790-06:00 ftp1 kernel: 1753.027882] ocfs2: Userspace control daemon is not present
2013-12-11T09:41:36.262811-06:00 ftp1 kernel: 1753.027889] (mount.ocfs2,5064,0):ocfs2_dlm_init:3004 ERROR: status = -3
2013-12-11T09:41:36.262814-06:00 ftp1 kernel: 1753.027911] (mount.ocfs2,5064,0):ocfs2_mount_volume:1881 ERROR: status = -3
2013-12-11T09:41:36.262818-06:00 ftp1 kernel: 1753.027955] ocfs2: Unmounting device (253,4) on (node 0)
2013-12-11T09:41:36.262822-06:00 ftp1 kernel: 1753.027964] (mount.ocfs2,5064,0):ocfs2_fill_super:1229 ERROR: status = -3
2013-12-11T09:41:36.290262-06:00 ftp1 Filesystem(testfs)[5008]: ERROR: Couldn’t mount filesystem /dev/disk/by-id/scsi-36000eb3b7bcda1ee0000000000002171 on /test
2013-12-11T09:41:36.290711-06:00 ftp1 lrmd[2188]: notice: operation_finished: testfs_start_0:5008:stderr mount.ocfs2: No such process while mounting /dev/mapper/36000eb3b7bcda1ee0000000000002171 on /test. Check ‘dmesg’ for more information on this error. ]

I tried searching to find out what ‘Userspace control daemon is not present’ means but I could not find anything.

After further investigation I found that on the 12.3 system there is a program running ’ /usr/sbin/ocfs2_controld.pcmk’ which I think is the ‘Userspace control daemon’ the error message refers to. On 12.3 is is part of the ocfs2-tools package, but the 13.1 version of the package does not contain that program.